Topic: Unable to start FusionInventory on a new install

Hi,

I successfully installed GLPI + FusionInventory on a Debian 9 VM Today.

Then, I installed FusionInventory Agent 2.4.1 using the VBS script modified as follows :

SetupOptions = "/acceptlicense /runnow /execmode=Service /installtasks=Full /server='htt ps:// glpi.my in.stall/plugins/fusioninventory/' /S"


The service does launch and stop just after.

Launching fusioninventory-agent.bat gets the following error :

C:\Program Files\FusionInventory-Agent>fusioninventory-agent.bat --debug
Execution failure:.
Can't locate object method "size" via package "1" (perhaps you forgot to load "1"?) at C:\Program Files\FusionInventory-Agent/perl/agent/FusionInventory/Agent/Logger/File.pm line 34.

But, launching the agent with the following options work :

C:\Program Files\FusionInventory-Agent>fusioninventory-agent.bat --config=none --server=htt ps://gl pi.myi n.stall/plugins/fusioninventory/
[info] sending prolog request to server server0
Use of uninitialized value in alarm at C:\Program Files\FusionInventory-Agent/perl/agent/FusionInventory/Agent/HTTP/Client.pm line 91.
[info] running task Deploy
Use of uninitialized value in alarm at C:\Program Files\FusionInventory-Agent/perl/agent/FusionInventory/Agent/HTTP/Client.pm line 91.
[info] No Deploy job enabled or Deploy support disabled server side.
[info] running task Collect
Use of uninitialized value in alarm at C:\Program Files\FusionInventory-Agent/perl/agent/FusionInventory/Agent/HTTP/Client.pm line 91.
[info] No Collect job enabled or Collect support disabled server side.
[info] running task Inventory
Use of uninitialized value in alarm at C:\Program Files\FusionInventory-Agent/perl/agent/FusionInventory/Agent/HTTP/Client.pm line 91.
[info] running task ESX
Use of uninitialized value in alarm at C:\Program Files\FusionInventory-Agent/perl/agent/FusionInventory/Agent/HTTP/Client.pm line 91.
[info] No ESX job enabled or ESX support disabled server side.
[info] running task Maintenance


I most certainly did something wrong, but cannot figure what,

Thanks in advance,

Re: Unable to start FusionInventory on a new install

Hi Nrvnqsr,

I guess you should have agent installed before on this computer and the previous configuration should trigger something around logfile & logfile-maxsize parameters.

Can you check your registry under HKLM\SOFTWARE\FusionInventory-Agent for the values of the following keys ?
logger
logfile
logfile-maxsize

I guess you have "File" in "logger". Can you check the status of the "logfile" file ?