Topic: Is "0.80_1.1-BETA2"'s fusinvdeploy working in Linux?

Hi all

First of all, I would like to thanks for providing this great plugin for GLPI. I really wanted to replace my OCSInventory with FusionInventory for glpi.

I notice that, for version "fusioninventory-for-glpi-metapackage_0.80_1.1-BETA2.tar.gz", it has the deploy feature. I really wanted to use the deploy feature but when I tried in on 2 of my system, the deployment seems like no working.

The server is running on:
openSUSE 11.4 with glpi 0.80.5.
1st system is my production system and 2nd system is my local test system (purely only glpi with fusioninventory and web-services plugin).
The clients are (2 systems):
RHEL 4.8 with FusionInventory Agent (2.1.9) (from Remi)
openSUSE 11.4 with FusionInventory-Agent-2.1.9903.tar.gz and also tried FusionInventory-Agent-2.1.12 from CPAN(uninstall by deleting, before trying the other version)

So far, I created package, task and so on on the deploy, and I use "push" method. I run my client agent in debug mode and from "no-fork background" method, I notice that, there is no activity from fusionventory server to initiate the client to download or deploy the task. At most, I only see "/status" from the agent' http page.

To verify my client is working, I initiate force inventory, the client/agent can run inventory checking without any problem.

When I leave it for some time, the deployment task will end/terminated with "Bad token, impossible to start agent"

So now the question is, it the deploying working on Linux? Or is it not ready yet? Or, did I missed out anything?



Re: Is "0.80_1.1-BETA2"'s fusinvdeploy working in Linux?

We have a bug with push mode for the SNMP in BETA 2, and perhaps have same for deploy, I'm working on this problem tongue

Co-leader, official developper
DCS official PARTNER:

Re: Is "0.80_1.1-BETA2"'s fusinvdeploy working in Linux?

Oh! Maybe that explain.. Just for your info, the "fusioninventory-for-glpi-metapackage_2.4.0.tar.gz" 's SNMP push is working on my system before.
Now that u mention that SNMP push is not working on this beta2 version, I have to go and check on my system now.

Re: Is "0.80_1.1-BETA2"'s fusinvdeploy working in Linux?

hello fusinvdeploy requires the new upcoming 2.2 agent which is currenlty in beta phase

Re: Is "0.80_1.1-BETA2"'s fusinvdeploy working in Linux?

OK... then in this case, I have to revert back my glpi to use back the "fusioninventory-for-glpi-metapackage_2.4.0.tar.gz" version.

I just tried to "push" SNMP and NetDiscovery, both of them cannot work also for the Beta version. No activity on the client/agent and the FusionInventory shows
"Unable to find agent to run this job"