Topic: Agent can not send data to the server

Hello everyone,

I'm having problems with the fusion inventory agent deployed on a machine. I am using Fusion Inventory Agent 2.3.19, GLPI version 9.1.3, and FusionInventory version 9.1+1.0
I can run the Force an Inventory using the localhost with the port 62354 but it seems like it doesn't send any information to my inventory server. I opened the /var/log/apache2/access.log
and I got these messages.


192.168.22.192 - - [04/Aug/2017:14:41:19 +0300] "POST /glpi/plugins/fusioninventory/front/plugin_fusioninventory.communication.php HTTP/1.1" 404 570 "-" "FusionInventory-Agent_v2.3.19"
192.168.22.192 - - [04/Aug/2017:14:41:31 +0300] "POST /glpi/plugins/fusioninventory/front/plugin_fusioninventory.communication.php HTTP/1.1" 404 570 "-" "FusionInventory-Agent_v2.3.19"
192.168.22.192 - - [04/Aug/2017:14:41:43 +0300] "POST /glpi/plugins/fusioninventory/front/plugin_fusioninventory.communication.php HTTP/1.1" 404 570 "-" "FusionInventory-Agent_v2.3.19"
192.168.22.192 - - [04/Aug/2017:14:41:55 +0300] "POST /glpi/plugins/fusioninventory/front/plugin_fusioninventory.communication.php HTTP/1.1" 404 570 "-" "FusionInventory-Agent_v2.3.19"
192.168.22.192 - - [04/Aug/2017:14:42:07 +0300] "POST /glpi/plugins/fusioninventory/front/plugin_fusioninventory.communication.php HTTP/1.1" 404 570 "-" "FusionInventory-Agent_v2.3.19"
192.168.22.192 - - [04/Aug/2017:14:42:19 +0300] "POST /glpi/plugins/fusioninventory/front/plugin_fusioninventory.communication.php HTTP/1.1" 404 570 "-" "FusionInventory-Agent_v2.3.19"

Agent log file shows:

[Fri Aug  4 14:43:07 2017][info] Agent memory usage: 3055616
[Fri Aug  4 14:43:19 2017][info] sending prolog request to server server0
[Fri Aug  4 14:43:19 2017][error] [http client] communication error: 404 Not Found
[Fri Aug  4 14:43:19 2017][error] No answer from server at hxxp://192.168.22.230/glpi/plugins/fusi … cation.php


What is wrong here? Please help, cant figure out...

Re: Agent can not send data to the server

The serveur url is not right, it must be hxxp://192.168.22.230/glpi/plugins/fusioninventory/front/communication.php

Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com

Re: Agent can not send data to the server

Hi ddurieux, thank u for your replay.
Like you said, I changed server line through regedit on Windows10 client, but no luck, same error:
Client log file:
[Mon Aug  7 08:37:45 2017][info] running task Inventory
[Mon Aug  7 08:37:49 2017][warning] 'scan-profiles' configuration parameter disabled, ignoring software in user profiles
[Mon Aug  7 08:37:51 2017][info] Inventory saved in C:\FusionInventory/HP-450G4-ANAP-2017-08-04-15-01-57.ocs
[Mon Aug  7 08:37:59 2017][info] FusionInventory Agent memory usage: 2969600
[Mon Aug  7 08:38:01 2017][info] sending prolog request to server server0
[Mon Aug  7 08:38:01 2017][error] [http client] communication error: 404 Not Found
[Mon Aug  7 08:38:01 2017][error] No answer from server at hxxp://192.168.22.230/glpi/plugins/fusi … cation.php
[Mon Aug  7 08:38:01 2017][info] FusionInventory Agent memory usage: 3133440

/var/log/apache2/access.log

192.168.22.192 - - [07/Aug/2017:08:37:42 +0300] "-" 408 0 "-" "-"
192.168.22.192 - - [07/Aug/2017:08:38:00 +0300] "POST /glpi/plugins/fusioninventory/front/comunication.php HTTP/1.1" 404 546 "-" "FusionInventory-Agent_v2.3.21"
192.168.22.192 - - [07/Aug/2017:08:39:00 +0300] "POST /glpi/plugins/fusioninventory/front/comunication.php HTTP/1.1" 404 546 "-" "FusionInventory-Agent_v2.3.21"
192.168.22.192 - - [07/Aug/2017:08:41:01 +0300] "POST /glpi/plugins/fusioninventory/front/comunication.php HTTP/1.1" 404 546 "-" "FusionInventory-Agent_v2.3.21"

please what else can I do, what I can check more???

Re: Agent can not send data to the server

You have 404, so seems your GLPI installation is not available on the url you define

Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com

Re: Agent can not send data to the server

I figured it out...
I just need to remove "glpi" from
hxxp: // 192.168.22.230/glpi/plugins/fusioninventory/front/plugin_fusioninventory.communication.php
right url must be:
hxxp: // 192.168.22.230/plugins/fusioninventory/front/plugin_fusioninventory.communication.php
Now everything working!

Dont understand why sometimes you need use glpi in url and sometimes not... where it configured???

Re: Agent can not send data to the server

Hello ^_^,

i have the same issue , when i put  http://10.184.55.20/glpi/plugins/fusioninventory/ i get this status error "404 ", but when i put the link without glpi , i get another error " Class 'SimpleXMLElement' not found in /var/www/glpi/plugins/fusioninventory/inc/communication.class.php:55"
any solution please?

Re: Agent can not send data to the server

So the right link is without 'glpi' and you need install the PHP module XML

Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com

Re: Agent can not send data to the server

thank you ddurieux and hermes,

now it works wink