1 (edited by jngelis 2018-10-30 14:35:23)

Topic: Problème de lancement du job "Collect" au sein d'une Tâche

Bonjour à tou(te)s,
J'ai créé une tâche comprenant un job de collecte et un autre job de déploiement (qui n'effectue qu'un test de présence de fichier, pour tester)
Au sein de ma tâche, mon job "Deploy" se lance bien, mais mon job "Collect" reste en "A faire" avec le statut "Préparé"
Lorsque j'analyse les logs de mon agent, il me dit "Nothing to do" pour la partie "Collect" et me trouve bien ma tâche de "Deploy" :

[Tue Oct 30 15:05:52 2018][info] running task Collect
[Tue Oct 30 15:05:52 2018][debug2] h*tp://inventory.**/plugins/fusioninventory/?action=getConfig&machineid=FRRE5628.**-2018-10-30-13-27-22&task[Collect]=2.5
[Tue Oct 30 15:05:52 2018][debug2] h*tp://glpi.**//plugins/fusioninventory/b/collect/?action=getJobs&machineid=FRRE5628.**-2018-10-30-13-27-22
[Tue Oct 30 15:05:53 2018][debug] Nothing to do
[Tue Oct 30 15:05:54 2018][debug] forking process 0 to handle task Deploy
[Tue Oct 30 15:05:55 2018][info] running task Deploy
[Tue Oct 30 15:05:55 2018][debug2] h*tp://inventory.**/plugins/fusioninventory/?action=getConfig&machineid=FRRE5628.**-2018-10-30-13-27-22&task[Deploy]=2.7
[Tue Oct 30 15:05:55 2018][debug2] Looking for Win32_LogicalDisk class WMI objects
...
[Tue Oct 30 15:05:55 2018][debug2] h*tp://glpi.**//plugins/fusioninventory/b/deploy/?action=getJobs&machineid=FRRE5628.**-2018-10-30-13-27-22&version=2.7
[Tue Oct 30 15:05:55 2018][debug2] Deploy job 5bd862f21d953 in the list
[Tue Oct 30 15:05:55 2018][debug2] Processing job 5bd862f21d953 from the list




Côté serveur, tout semble correct :
- mon job "Collect" est bien activé, il effectue une recherche de fichier
- Le module "Collect" est bien activée côté serveur et agent
J'ai tenté une mise à jour de mon agent en v2.4.2 sans changement (v2.3.17 avant)

Info supplemntaire :
- Notre GLPI est en version 0.90.3

Re: Problème de lancement du job "Collect" au sein d'une Tâche

Il faut vérifier dans la conf générale du plugin si le module collecte est bien activé (onglet modules)

Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com

Re: Problème de lancement du job "Collect" au sein d'une Tâche

Bonjour,
Le module "Collecte de donnée" est bien activé dans la conf générale du plugin, onglet "Module des agents".