Topic: pas de remonté fusioninventory dans glpi

Bonjour,
Je suis nouvelle avec les logiciels glpi et ocs ce qui fait que j'ai un peu de mal avec le fonctionnement et configuration de ceuX-ci.
tt d'abord, je les ai installé sur un windows 2k3 et mes clients sous xp ( pour un parc de 600 postes environs). et je suis en version 2.0 de ocs, 0.78 de glpi; j'utilise l'agent deployment tool pour le deploiement de l'agent sur les clients.

J'ai egalement installé les plugins fusioninventory sur glpi ainsi que l'agent sur le même poste, tout c'est bien passé l'agent fusion est bien reconnu dans glpi j'ai bien activer tout pour la découverte mais il s'avere que je n'ai aucune remonté snmp

Re: pas de remonté fusioninventory dans glpi

Ya t-il klkun de disponible pour m'aider svp ?
Aussi dans le plugin je n'ai aucune tache de planifiée, pas de plage ip rien rien du tt est ce normal pourtant je crois avoir bien configuré tt ?

Maintenant dans ocs il est vrai que j'ai aussi activé la decouverte snmp mais dans le scan réseau je n'ai aucune précision dans materiels non inventoriés.

Lorsque je fais un filtre par type (que j'ai créé moi même dans ocs) par exple "IMPRIMANTE" j'ai pleins d'erreurs. que faire?

Merci d'avance

Re: pas de remonté fusioninventory dans glpi

Il faut créer une tache de découverte réseau avec une plage IP sinon l'agent ne scannera rien

Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com

Re: pas de remonté fusioninventory dans glpi

Merci pour la rapidité de reponse.

là j'ai créé une plage ip celle de mon serveur. j'ai créé deux taches snmp et netdiscovery en communication "pull" entre le servuer et l'agent mais j'ai lancé l'agent mais je n'ai tjrs aucune remonté.

j'ai une tâche qui bloque à 25% et l'autre est bien à 100% mais leur statut reste à "préparé" dans taches en cours est ce normal ?

Re: pas de remonté fusioninventory dans glpi

Si c'est en préparé, il faut lancer les agents pour qu'ils récupèrent leurs taches préparées

Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com

Re: pas de remonté fusioninventory dans glpi

Bonjour,
Justement j'ai lancé l'agent par http://localhost:62354/, voici le chemin server, http://192.168.196.61/glpi/plugins/fusi … cation.php
mais toujours rien dans glpi.

et tjrs une action en cours à 25% qui bouge pas depuis.

Re: pas de remonté fusioninventory dans glpi

Il va falloir les logs de l'agent alors 'fichier agents.log'

Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com

Re: pas de remonté fusioninventory dans glpi

Où se trouve ce fichier ? psk il n'est pas dans programmes files/fusioninventory agent/

Re: pas de remonté fusioninventory dans glpi

Normalement si... peut etre activer le debug (base de registre : HKLM/Softwares/FusionInventory-agent)

Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com

Re: pas de remonté fusioninventory dans glpi

dans la base de registre la fonction debug etait à 0 je l'ai mise à 1.
j'ai juste un fichier agent-log.txt qui contient : (mais je crois pas que c'est de celui là dont vous parlez)

[Thu Jun 16 10:39:51 2011][info] PROLOG_FREQ has been set: 1
[Thu Jun 16 10:39:51 2011][info] RPC service started at: http://127.0.0.1:62354
[Thu Jun 16 10:43:21 2011][info] PROLOG_FREQ has changed since last process (old=1,new=10)

Re: pas de remonté fusioninventory dans glpi

si c'ets celui là, il faut maintenant redémarrer le service windows "FusionInventory-agent" et forcer l'inventaire de l'agent

Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com

Re: pas de remonté fusioninventory dans glpi

Merci.
Apres avoir relancé le service voici ce que me donne maintnant ce fichier agent.log:

[Thu Jun 16 10:39:51 2011][info] PROLOG_FREQ has been set: 1
[Thu Jun 16 10:39:51 2011][info] RPC service started at: http://127.0.0.1:62354
[Thu Jun 16 10:43:21 2011][info] PROLOG_FREQ has changed since last process (old=1,new=10)
[Wed Jun 22 10:31:53 2011][debug] FusionInventory unified agent for UNIX, Linux, Windows and MacOSX 2.1.9-2
[Wed Jun 22 10:31:53 2011][debug] Log system initialised (2)
[Wed Jun 22 10:31:53 2011][debug] vardir: C:\Program Files\FusionInventory-Agent\dumps/http..__192.168.196.61_glpi_plugins_fusioninventory_front_plugin_fusioninventory.communication.php
[Wed Jun 22 10:31:53 2011][debug] [http://192.168.196.61/glpi/plugins/fusi … cation.php] Next server contact planned for Wed Jun 22 16:10:34 2011
[Wed Jun 22 10:31:53 2011][debug] No accountinfo file defined
[Wed Jun 22 10:31:53 2011][debug] [RPC] static files are in C:\Program Files\FusionInventory-Agent\share/html
[Wed Jun 22 10:31:54 2011][debug] FusionInventory Agent initialised
[Wed Jun 22 10:31:54 2011][info] RPC service started at: http://127.0.0.1:62354
[Wed Jun 22 10:32:27 2011][debug] FusionInventory unified agent for UNIX, Linux, Windows and MacOSX 2.1.9-2
[Wed Jun 22 10:32:27 2011][debug] Log system initialised (2)
[Wed Jun 22 10:32:27 2011][debug] vardir: C:\Program Files\FusionInventory-Agent\dumps/http..__192.168.196.61_glpi_plugins_fusioninventory_front_plugin_fusioninventory.communication.php
[Wed Jun 22 10:32:27 2011][debug] [http://192.168.196.61/glpi/plugins/fusi … cation.php] Next server contact planned for Wed Jun 22 16:10:34 2011
[Wed Jun 22 10:32:27 2011][debug] No accountinfo file defined
[Wed Jun 22 10:32:27 2011][debug] [RPC] static files are in C:\Program Files\FusionInventory-Agent\share/html
[Wed Jun 22 10:32:27 2011][debug] FusionInventory Agent initialised
[Wed Jun 22 10:32:27 2011][info] RPC service started at: http://127.0.0.1:62354
[Wed Jun 22 10:32:46 2011][debug] [RPC] 127.0.0.1 request /now
[Wed Jun 22 10:32:46 2011][debug] [RPC] 'now' catched
[Wed Jun 22 10:32:46 2011][debug] Agent is now running
[Wed Jun 22 10:32:47 2011][debug] Compress::Zlib is available.
[Wed Jun 22 10:32:47 2011][debug] token is: OUUCEDUR
[Wed Jun 22 10:32:47 2011][debug] sending XML
[Wed Jun 22 10:32:47 2011][debug] =BEGIN=SERVER RET======
[Wed Jun 22 10:32:47 2011][debug] $VAR1 = '<?xml version="1.0" encoding="UTF-8"?>
<REPLY RESPONSE="ERROR : SSL REQUIRED BY SERVER">
</REPLY>
';
[Wed Jun 22 10:32:47 2011][debug] =END=SERVER RET======
[Wed Jun 22 10:32:47 2011][debug] Module FusionInventory::Agent::Task::Deploy is not installed.
[Wed Jun 22 10:32:47 2011][debug] cmd is: '"C:\Program Files\FusionInventory-Agent\perl\bin\perl.exe" -MFusionInventory::Agent::Task::OcsDeploy -e "FusionInventory::Agent::Task::OcsDeploy::main();" -- "C:\Program Files\FusionInventory-Agent\dumps/http..__192.168.196.61_glpi_plugins_fusioninventory_front_plugin_fusioninventory.communication.php"'
[Wed Jun 22 10:32:47 2011][debug] FusionInventory unified agent for UNIX, Linux, Windows and MacOSX 2.1.9-2
[Wed Jun 22 10:32:47 2011][debug] Log system initialised (2)
[Wed Jun 22 10:32:47 2011][debug] Compress::Zlib is available.
[Wed Jun 22 10:32:47 2011][debug] no DOWNLOAD options returned during PROLOG
[Wed Jun 22 10:32:47 2011][debug] End of period...
[Wed Jun 22 10:32:48 2011][debug] [task] end of OcsDeploy
[Wed Jun 22 10:32:48 2011][debug] cmd is: '"C:\Program Files\FusionInventory-Agent\perl\bin\perl.exe" -MFusionInventory::Agent::Task::Inventory -e "FusionInventory::Agent::Task::Inventory::main();" -- "C:\Program Files\FusionInventory-Agent\dumps/http..__192.168.196.61_glpi_plugins_fusioninventory_front_plugin_fusioninventory.communication.php"'
[Wed Jun 22 10:32:48 2011][debug] FusionInventory unified agent for UNIX, Linux, Windows and MacOSX 2.1.9-2
[Wed Jun 22 10:32:48 2011][debug] Log system initialised (2)
[Wed Jun 22 10:32:48 2011][debug] <RESPONSE>SEND</RESPONSE> no found in PROLOG, do not send an inventory.
[Wed Jun 22 10:32:48 2011][debug] [task] end of Inventory
[Wed Jun 22 10:32:48 2011][debug] cmd is: '"C:\Program Files\FusionInventory-Agent\perl\bin\perl.exe" -MFusionInventory::Agent::Task::WakeOnLan -e "FusionInventory::Agent::Task::WakeOnLan::main();" -- "C:\Program Files\FusionInventory-Agent\dumps/http..__192.168.196.61_glpi_plugins_fusioninventory_front_plugin_fusioninventory.communication.php"'
[Wed Jun 22 10:32:48 2011][debug] FusionInventory unified agent for UNIX, Linux, Windows and MacOSX 2.1.9-2
[Wed Jun 22 10:32:48 2011][debug] Log system initialised (2)
[Wed Jun 22 10:32:48 2011][debug] No WAKEONLAN. Exiting...
[Wed Jun 22 10:32:48 2011][debug] [task] end of WakeOnLan
[Wed Jun 22 10:32:48 2011][debug] cmd is: '"C:\Program Files\FusionInventory-Agent\perl\bin\perl.exe" -MFusionInventory::Agent::Task::SNMPQuery -e "FusionInventory::Agent::Task::SNMPQuery::main();" -- "C:\Program Files\FusionInventory-Agent\dumps/http..__192.168.196.61_glpi_plugins_fusioninventory_front_plugin_fusioninventory.communication.php"'
[Wed Jun 22 10:32:49 2011][debug] FusionInventory unified agent for UNIX, Linux, Windows and MacOSX 2.1.9-2
[Wed Jun 22 10:32:49 2011][debug] Log system initialised (2)
[Wed Jun 22 10:32:49 2011][debug] FusionInventory SNMPQuery module 1.3
[Wed Jun 22 10:32:49 2011][debug] No SNMPQuery Asked by the server. Exiting...
[Wed Jun 22 10:32:49 2011][debug] [task] end of SNMPQuery
[Wed Jun 22 10:32:49 2011][debug] cmd is: '"C:\Program Files\FusionInventory-Agent\perl\bin\perl.exe" -MFusionInventory::Agent::Task::NetDiscovery -e "FusionInventory::Agent::Task::NetDiscovery::main();" -- "C:\Program Files\FusionInventory-Agent\dumps/http..__192.168.196.61_glpi_plugins_fusioninventory_front_plugin_fusioninventory.communication.php"'
[Wed Jun 22 10:32:49 2011][debug] FusionInventory unified agent for UNIX, Linux, Windows and MacOSX 2.1.9-2
[Wed Jun 22 10:32:49 2011][debug] Log system initialised (2)
[Wed Jun 22 10:32:49 2011][debug] FusionInventory NetDiscovery module 1.5
[Wed Jun 22 10:32:49 2011][debug] No NETDISCOVERY Asked by the server. Exiting...
[Wed Jun 22 10:32:49 2011][debug] [task] end of NetDiscovery
[Wed Jun 22 10:32:49 2011][debug] cmd is: '"C:\Program Files\FusionInventory-Agent\perl\bin\perl.exe" -MFusionInventory::Agent::Task::ESX -e "FusionInventory::Agent::Task::ESX::main();" -- "C:\Program Files\FusionInventory-Agent\dumps/http..__192.168.196.61_glpi_plugins_fusioninventory_front_plugin_fusioninventory.communication.php"'
[Wed Jun 22 10:32:49 2011][debug] [task] end of ESX
[Wed Jun 22 10:32:49 2011][debug] [http://192.168.196.61/glpi/plugins/fusi … cation.php] Next server contact has just been planned for Wed Jun 22 19:13:52 2011

Re: pas de remonté fusioninventory dans glpi

ERROR : SSL REQUIRED BY SERVER => vous avez spécifié sur le sevruer que vous ne voulez que du SSL mais vous communiquez en http

Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com

Re: pas de remonté fusioninventory dans glpi

Vraiment MERCI !!!!!
Vous m'avez bcp aidé psk je savais plus quoi faire.

Et là j'ai bien une décourverte reseau qui est remontée.

A bientot si j'ai d'autres qustions ou blocages.

Bonne continuation à vous.

Re: pas de remonté fusioninventory dans glpi

Bonsoir c'est encore moi. il s'avere que j'ai encore des questions.
Lorsque je fais état des decouvertes j'ai bien un résultat correspondant je crois au nombre d'équipements présents sur la plage.
=> je ne peux les visualiser qu"en allant dans matériels inconnu

Lorsque je fais état des inventaires réseaux je n'ai rien du tt aucun résultat.
=> Comment faire pour avoir l'inventaire des switch, imprimante avec les port et etats des cartouches etc...
=> comment importer apres dans glpi ( à quoi servent réellement les regles d'imprt de matériels)

Merci d'avance, j'espere que vous allez comprendre qlq chose.

Re: pas de remonté fusioninventory dans glpi

?????????

Re: pas de remonté fusioninventory dans glpi

bjr est ce que vous pouvez m'aider, j'arrive à faire la decouverte de matériels avec fusioninventory sur une plage mais je vois pas cmt faire ni où aller pour voir l'inventaire de ces équipements.

Aussi cmt faire après limport dans glpi ?

Re: pas de remonté fusioninventory dans glpi

Au fait dans l'etat des inventaires séseaux je n'ai tjrs rien, c'est normal ?