Topic: Filter 'is/is not' don't work in SNMP models...

Hello to all,

   My FusionInventory for GLPI v.2.4x test environment is as following:

      .- The server
         .- Ubuntu Server 10.04.3 LTS (Lucid Lynx) - Architecture AMD64
         .- OCS Inventory NG Management Server v2.0
         .- GLPI v0.80.2
            .- GLPI v0.80.2 Agents
               .- FusionInventory for GLPI v2.4.0 (Nightly Build 20110912-0805)
                  .- FusionInventory v2.4.0
                  .- FusionInventory INVENTORY v2.4.0
                  .- FusionInventory SNMP v2.4.0
               .- Shell Commands v1.4.0
               .- Bays Management v1.2.0

      .- The agents
         .- FusionInventory-Agent v2.1.10 (for Windows)
         .- FusionInventory-Agent v2.1.9-3 (for Windows)
         .- FusionInventory-Agent v2.1.9-3 (for GNU/Linux)


   Filter 'is/is not' don't work in SNMP models. Example:

   Home> Plugins> FusionInventory> SNMP models
      Filter: Name is 100911
         *** No item found ***

   Home> Plugins> FusionInventory> SNMP models
      Filter: Name is not 100911
         100911
         102642
         1062513
         ...
         *** Show all models ***

Tomás Abad

2 (edited by tabad 2011-09-17 16:50:27)

Re: Filter 'is/is not' don't work in SNMP models...

Hello to all,

   Due to errors detected in the Nightly Build System, this time I updated the test environment with the development version to 2011-09-17 11:56h UTC, synchronized with Git repository through the Bash script I created for this purpose. (See Topic "A Bash script to synchronize with Git repositories...")

   My test environment is now as follow:

      .- The server
         .- Ubuntu Server 10.04.3 LTS (Lucid Lynx) - Architecture AMD64
         .- OCS Inventory NG Management Server v2.0
         .- GLPI v0.80.2
            .- GLPI v0.80.2 Agents
               .- FusionInventory for GLPI v2.4.0 (Synchronized with Git repository at 20110917-1156 UTC)
                  .- FusionInventory v2.4.0
                  .- FusionInventory INVENTORY v2.4.0
                  .- FusionInventory SNMP v2.4.0
               .- Shell Commands v1.4.0
               .- Bays Management v1.2.0

      .- The agents
         .- FusionInventory-Agent v2.1.11-1 (for Windows)
         .- FusionInventory-Agent v2.1.10-1 (for Windows)
         .- FusionInventory-Agent v2.1.9-3 (for Windows)
         .- FusionInventory-Agent v2.1.10-1 (for GNU/Linux)
         .- FusionInventory-Agent v2.1.9-3 (for GNU/Linux)


   I have repeated my previous test and I have the same problems:

   Home> Plugins> FusionInventory> SNMP models
      Filter: Name is 100911
         *** No item found ***        <---- Bug. It should find the 100911.

   Home> Plugins> FusionInventory> SNMP models
      Filter: Name is not 100911
         100911                       <---- Bug. It shouldn't show the 100911.
         102642
         1062513
         ...
         *** Show all models ***


   Filter 'is/is not' don't work in SNMP models.

Tomás Abad

Re: Filter 'is/is not' don't work in SNMP models...

Works for me, it found it.

Have you select in select box the "100911" model?

Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com

Re: Filter 'is/is not' don't work in SNMP models...

Yes, I selected the '100911'  model in select box.

Tomás Abad