Topic: Can't edit Rule 0.83+1.0Beta4

When I try to view or edit a rule at "FusionInventory -> Equipment" import and link rules
I just get "During loading..."

I tried it with Firefox 10.0.5, Chrome 19.0.1084.56 m, IE6 (Windows) and Firefox 12 under Linux.

I think, this is a bug

Re: Can't edit Rule 0.83+1.0Beta4

Not have this problem. Have you errors in glpi/files/_log/php-errors.log or in apache error log?

Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com

Re: Can't edit Rule 0.83+1.0Beta4

Thank you. Yes, you are right. I get the following error:

[Wed Jun 13 11:12:47 2012] [error] [client IP] PHP Fatal error:  Call to undefined function header_nocache() in /var/www/glpi/plugins/fusioninventory/ajax/ruleimportequipment.tabs.php on line 42, referer: http://MyFusioninventory/glpi/plugins/fusioninventory/front/ruleimportequipment.form.php?id=9

Any hints what I can do to fix this problem?

Re: Can't edit Rule 0.83+1.0Beta4

This file not exist in version 0.83+1.0 . You has deleted folders fus* in folder glpi/plugins before uncomrpess the new archive 0.83+1.0 BETA4 ?

Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com

Re: Can't edit Rule 0.83+1.0Beta4

Thank you.

I removed the old files in plugin/fus* and extracted the new ones.

It works now :-)

Re: Can't edit Rule 0.83+1.0Beta4

nice wink

Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com