Welcome, Guest
You have to register before you can post on our site.

Username
  

Password
  





Search Forums



(Advanced Search)

Forum Statistics
» Members: 7,231
» Latest member: oliviacrew
» Forum threads: 4,118
» Forum posts: 22,140

Full Statistics

Online Users
There are currently 65 online users.
» 0 Member(s) | 62 Guest(s)
Bing, Google, Yandex

Latest Threads
How can I update agent co...
Forum: fusioninventory-agent
Last Post: ddurieux
Yesterday, 19:08:44
» Replies: 1
» Views: 79
"Architecture" GLPI+Fusio...
Forum: FusionInventory for GLPI
Last Post: ddurieux
Yesterday, 12:43:22
» Replies: 3
» Views: 336
Parc Ordinateurs vide
Forum: FusionInventory for GLPI
Last Post: ddurieux
Yesterday, 10:24:19
» Replies: 1
» Views: 47
question concernant le ré...
Forum: FusionInventory for GLPI
Last Post: ddurieux
Yesterday, 10:20:10
» Replies: 3
» Views: 96
Network Discovery and Net...
Forum: FusionInventory for GLPI
Last Post: ddurieux
Yesterday, 10:13:45
» Replies: 1
» Views: 172
Equipement non-géré
Forum: FusionInventory for GLPI
Last Post: ddurieux
Yesterday, 10:12:33
» Replies: 1
» Views: 35
Bug inventaire
Forum: fusioninventory-agent
Last Post: ddurieux
Yesterday, 10:10:20
» Replies: 1
» Views: 38
[Plugin] GLPI + Fusion + ...
Forum: FusionInventory for GLPI
Last Post: ddurieux
Yesterday, 10:09:37
» Replies: 2
» Views: 1,166
Question au développeur -...
Forum: FusionInventory for GLPI
Last Post: ddurieux
Yesterday, 10:07:33
» Replies: 1
» Views: 40
Déploiement GLPI par GPO ...
Forum: FusionInventory for GLPI
Last Post: ddurieux
Yesterday, 10:07:00
» Replies: 1
» Views: 39

 
  Instalación y ejecución de FusionInventory Agent (2.3.16) en UBUNTU..
Posted by: ramses.sevilla@gmail.com - 2020-07-02, 07:37:23 - Forum: FusionInventory for GLPI - No Replies

Hola a tod@s,

He instalado FusionInventory Agent (2.3.16) en un UBUNTU 18.04 y tengo un par de dudas:

Primera.-

He modificado el fichero "/etc/default/fusioninventory-agent" y he cambiado la línea:

MODE=daemon

Y he reiniciado el servicio después.

Si veo el estado del Servicio parece que está corriendo correctamente:

Quote:$ service fusioninventory-agent status
● fusioninventory-agent.service - LSB: starts FusionInventory Agent
  Loaded: loaded (/etc/init.d/fusioninventory-agent; generated)
  Active: active (exited) since Wed 2020-07-01 14:25:24 CEST; 18h ago
    Docs: manConfusedystemd-sysv-generator(8)
  Process: 681 ExecStart=/etc/init.d/fusioninventory-agent start (code=exited, status=0/SUCCESS)

jul 01 14:25:22 ws-usuario systemd[1]: Starting LSB: starts FusionInventory Agent...
jul 01 14:25:23 ws-usuario fusioninventory-agent[681]: Starting fusioninventory-agent: File::Glob::glob() will disappear in perl 5.30. Use File::
jul 01 14:25:24 ws-usuario fusioninventory-agent[681]: fusioninventory-agent.
jul 01 14:25:24 ws-usuario systemd[1]: Started LSB: starts FusionInventory Agent.
$


Sin embargo, si intento conectarme a http://localhost:62354/ no me conecta.

Compruebo que el Puerto 62354 no está a la escucha:


Quote:$ netstat -putan | grep 62354
(No todos los procesos pueden ser identificados, no hay información de propiedad del proceso
no se mostrarán, necesita ser superusuario para verlos todos.)
$

Si cargo FusionInventory como Demonio a mano: sudo fusioninventory-agent -d

Sí puedo acceder al puerto 62354 sin problemas y está a la escucha:

Quote:$ netstat -putan | grep 62354
(No todos los procesos pueden ser identificados, no hay información de propiedad del proceso
no se mostrarán, necesita ser superusuario para verlos todos.)
tcp        0      0 0.0.0.0:62354          0.0.0.0:*              ESCUCHAR    -                 
$

Segunda.-

Para propósitos de pruebas, quiero modificar la configuración para que el Agente reporte al Servidor el inventario cada 30 minutos, ¿qué parámetro del fichero /etc/fusioninventory/agent.cfg tendría que modificar?


Gracias y saludos


  Ne peut pas installer le plugin
Posted by: Erwun - 2020-06-30, 17:51:25 - Forum: FusionInventory for GLPI - No Replies

Bonjour à tous,
Ne voulant pas passer pour un noob, je pense que c'est rater.
J'ai installé un GLPI et voulant mettre du fusion inventory, je me retrouve avec une erreur 500 :
500 - Erreur interne au serveur.

La ressource que vous recherchez présente un problème, elle ne peut donc pas être affichée.


Je ne comprends pas réellement je dois vous avouez Sad .

Le serveur est sur une instance IIS, avec du mysql / php qui tourne

Version :
mysql - 8.0.20 - x64
PHP - 7.2.8
GLPI - 9.4.6
fusioninventory - 9.4 + 2.4

Merci de votre aide

Erwan


  Parc Ordinateurs vide
Posted by: cave2180 - 2020-06-26, 13:57:19 - Forum: FusionInventory for GLPI - Replies (1)

Bonjour,

Suite à l'installation de fusion inventory, je ne retrouve aucunes de mes machines dans "Parc / Ordinateurs".

Cependant, tout se trouve dans "Parc / Global"

Pouvez-vous m'aider à ce niveau ?

Merci d'avance


  FusionInventory for GLPI 9.5
Posted by: ramses.sevilla@gmail.com - 2020-06-26, 11:46:55 - Forum: FusionInventory for GLPI - No Replies

Hi everybody,

Is there a FusionInventory plugin for the new GLPI 9.5 RC?


Regards,

Ramsés


  FusionInventory for GLPI 9.5
Posted by: ramses.sevilla@gmail.com - 2020-06-26, 11:45:54 - Forum: FusionInventory for GLPI - No Replies

Hola a tod@s,

¿Sabéis si está ya el plugin, aunque sea en pruebas, FusionInventory plugin para el nuevo GLPI 9.5 RC.


Saludos y gracias


  No SSL connection possible
Posted by: zumodevidrio - 2020-06-26, 10:21:32 - Forum: fusioninventory-agent - Replies (4)

Hello, I have a problem with the SSL connection since 30 May, maybe linked to: https://support.sectigo.com/articles/Kno...ay-30-2020 but all the possible solutions that I have found won't work. 

Specially I don't understand why:

Code:
curl --cacert /etc/pki/tls/certs/mycert.crt https://my_glpi_url/plugins/fusioninventory/

 answers fine with the content of the site but the command:

Code:
fusioninventory-agent --ca-cert-file=/etc/pki/tls/certs/mycert.crt

Gives:


Code:
[info] sending prolog request to server server0
[error] [http client] communication error: 500 Can't connect to my_glpi_url:443
[error] No answer from server at https://my_glpi_url/plugins/fusioninventory/

So the communications between all my Linux agents and my server are completely down (However, Windows agents with the same crt are still working properly)

Has anyone experienced this?

FusionInventory Agent (2.3.21)


  Fusioninventory Task creation
Posted by: talekksna - 2020-06-25, 14:37:29 - Forum: FusionInventory for GLPI - No Replies

Hi,

Can anyone point me on the web, detail description how Task is created? And I do not mean on this:
http://fusioninventory.org/documentation...overy.html

I mean detail description of the function and options when task is crated.

What means:

Schedule start
Schedule end
Preparation timeslot
Execution timeslot
Agent wakeup interval (in minutes)
Number of agents to wake up

Thank you very much.


  Installation Fusion Inventory erreur
Posted by: adil.nouri - 2020-06-24, 13:56:04 - Forum: fusioninventory-agent - No Replies

Bonjour les amis.

J'ai un petit soucis.
J'aimerais installer Fusion inventory avec Jamf mais visiblement celui ci ne se déploie pas.

J'ai une erreur qui est la suivante.


error message : 

Installation failed. The installer reported: installer: Package name is FusionInventory-Agent installer: Upgrading at base path / installer: The upgrade failed. (Le programme d’installation a rencontré une erreur qui a provoqué l’échec de l’installation. Contactez l’éditeur du logiciel pour obtenir de l’aide. Une erreur s’est produite pendant l’exécution des scripts du paquet « FusionInventory-Agent-2.5.2-1.pkg ».)


Si vous avez une solutions à me proposer je suis preneur.

Merci bien à vous.


  Impossible to Install Fusion Inventory with Jamf
Posted by: adil.nouri - 2020-06-24, 13:53:28 - Forum: fusioninventory-agent - Replies (1)

Hi all dear friends

Have little problem.
I try to install Fusion inventory Agent on my mac with Jamf but have error message

error message : 

Installation failed. The installer reported: installer: Package name is FusionInventory-Agent installer: Upgrading at base path / installer: The upgrade failed. (Le programme d’installation a rencontré une erreur qui a provoqué l’échec de l’installation. Contactez l’éditeur du logiciel pour obtenir de l’aide. Une erreur s’est produite pendant l’exécution des scripts du paquet « FusionInventory-Agent-2.5.2-1.pkg ».)

If Have solution

Thx a lot


  Network discovery works through manual CLI but not working in GLPI
Posted by: talekksna - 2020-06-18, 13:42:15 - Forum: FusionInventory for GLPI - Replies (2)

Hi,

I try to set up network discovery using Fusioninventory Network discavery documentation and I can not make it work!
I am running VM Debian 10. I instaled GLPI 9.4.6 with Fusioninventory plug in 9.4+2.4. I have installed all the packages with all dependencies:
fusioninventory-agent_2.5.2-1_all.deb
fusioninventory-agent-task-collect_2.5.2-1_all.deb
fusioninventory-agent-task-network_2.5.2-1_all.deb
fusioninventory-agent-task-deploy_2.5.2-1_all.deb
fusioninventory-agent-task-esx_2.5.2-1_all.deb


Computers, Windows or Linux that have Fusioninventory agent installed on, they are communicating with GLPI great. I have them in the list with all information.

When I run from GLPI server (GNU/Linux debian 10) in command line fusioninventory-netdiscovery with appropriate options, I got every information that I suppose to.

This is my network printer:

<?xml version="1.0" encoding="UTF-8" ?>
<REQUEST>
  <CONTENT>
    <DEVICE>
      <AUTHSNMP>1</AUTHSNMP>
      <DESCRIPTION>HP ETHERNET MULTI-ENVIRONMENT</DESCRIPTION>
      <DNSHOSTNAME>IP ADDRESS</DNSHOSTNAME>
      <FIRMWARE>TETONXXXXN002.2014A.00</FIRMWARE>
      <IP>IP ADDRESS</IP>
      <IPS>
        <IP>IP ADDRESS</IP>
        <IP>127.0.0.1</IP>
      </IPS>
      <MAC>MAC ADDRESS</MAC>
      <MANUFACTURER>Hewlett-Packard</MANUFACTURER>
      <MODEL>HP LaserJet Pro MFP M428fdn</MODEL>
      <NETBIOSNAME>CAC14</NETBIOSNAME>
      <SERIAL>CNBKM860FR</SERIAL>
      <SNMPHOSTNAME>CAC14</SNMPHOSTNAME>
      <TYPE>PRINTER</TYPE>
      <UPTIME>23 days, 05:32:49.29</UPTIME>
      <USERSESSION>CAC14</USERSESSION>
      <WORKGROUP>WORKGROUP</WORKGROUP>
    </DEVICE>
    <MODULEVERSION>4.1</MODULEVERSION>
    <PROCESSNUMBER>1</PROCESSNUMBER>
  </CONTENT>
  <DEVICEID>foo</DEVICEID>
  <QUERY>NETDISCOVERY</QUERY>
</REQUEST>



But when I create task and job for that task as it is described in documentation, nothing is happening...?

When I run in command line fusioninventory-netinventory with appropriate options, I got every information that I suppose to:

<?xml version="1.0" encoding="UTF-8" ?>
<REQUEST>
  <CONTENT>
    <DEVICE>
      <CARTRIDGES>
        <TONERBLACK>81</TONERBLACK>
      </CARTRIDGES>
      <FIRMWARES>
        <DATE>2020-04-02</DATE>
        <DESCRIPTION>device firmware</DESCRIPTION>
        <MANUFACTURER>Hewlett-Packard</MANUFACTURER>
        <NAME>HP LaserJet Pro MFP M428fdn</NAME>
        <TYPE>device</TYPE>
        <VERSION>TETONXXXXN002.2014A.00</VERSION>
      </FIRMWARES>
      <INFO>
        <COMMENTS>HP ETHERNET MULTI-ENVIRONMENT</COMMENTS>
        <FIRMWARE>TETONXXXXN002.2014A.00</FIRMWARE>
        <ID>0</ID>
        <IPS>
          <IP>IP ADDRESS</IP>
          <IP>127.0.0.1</IP>
        </IPS>
        <MAC>MAC ADDRESS</MAC>
        <MANUFACTURER>Hewlett-Packard</MANUFACTURER>
        <MEMORY>340</MEMORY>
        <MODEL>HP LaserJet Pro MFP M428fdn</MODEL>
        <NAME>CAC14</NAME>
        <RAM>340</RAM>
        <SERIAL>CNBKM860FR</SERIAL>
        <TYPE>PRINTER</TYPE>
        <UPTIME>23 days, 05:38:42.20</UPTIME>
      </INFO>
      <PAGECOUNTERS>
        <DUPLEX>120</DUPLEX>
        <TOTAL>642</TOTAL>
      </PAGECOUNTERS>
      <PORTS>
        <PORT>
          <IFDESCR>lo</IFDESCR>
          <IFINERRORS>0</IFINERRORS>
          <IFINOCTETS>1020901705</IFINOCTETS>
          <IFINTERNALSTATUS>1</IFINTERNALSTATUS>
          <IFLASTCHANGE>0.00 seconds</IFLASTCHANGE>
          <IFMTU>65536</IFMTU>
          <IFNAME>lo</IFNAME>
          <IFNUMBER>1</IFNUMBER>
          <IFOUTERRORS>0</IFOUTERRORS>
          <IFOUTOCTETS>1020901705</IFOUTOCTETS>
          <IFSPEED>10000000</IFSPEED>
          <IFSTATUS>1</IFSTATUS>
          <IFTYPE>24</IFTYPE>
          <IP>127.0.0.1</IP>
          <IPS>
            <IP>127.0.0.1</IP>
          </IPS>
        </PORT>
        <PORT>
          <IFDESCR>eth0</IFDESCR>
          <IFINERRORS>0</IFINERRORS>
          <IFINOCTETS>394639220</IFINOCTETS>
          <IFINTERNALSTATUS>1</IFINTERNALSTATUS>
          <IFLASTCHANGE>1 day, 02:30:29.78</IFLASTCHANGE>
          <IFMTU>1500</IFMTU>
          <IFNAME>eth0</IFNAME>
          <IFNUMBER>2</IFNUMBER>
          <IFOUTERRORS>0</IFOUTERRORS>
          <IFOUTOCTETS>125566796</IFOUTOCTETS>
          <IFSPEED>1000000000</IFSPEED>
          <IFSTATUS>1</IFSTATUS>
          <IFTYPE>6</IFTYPE>
          <IP>IP ADDRESS</IP>
          <IPS>
            <IP>IP ADDRESS</IP>
          </IPS>
          <MAC>MAC ADDRESS</MAC>
        </PORT>
      </PORTS>
    </DEVICE>
    <MODULEVERSION>4.1</MODULEVERSION>
    <PROCESSNUMBER>1</PROCESSNUMBER>
  </CONTENT>
  <DEVICEID>foo</DEVICEID>
  <QUERY>SNMPQUERY</QUERY>
</REQUEST>



What em I doing wrong so I can not get this information in the GLPI?

Thank you very much.

Regards,

Đorđe Talović