Forums FusionInventory
Valeur du paramètre "server" dans agent.cfg non prise en compte - Printable Version

+- Forums FusionInventory (https://forum.fusioninventory.org)
+-- Forum: Français (https://forum.fusioninventory.org/forumdisplay.php?fid=4)
+--- Forum: fusioninventory-agent (https://forum.fusioninventory.org/forumdisplay.php?fid=9)
+--- Thread: Valeur du paramètre "server" dans agent.cfg non prise en compte (/showthread.php?tid=2273)



Valeur du paramètre "server" dans agent.cfg non prise en compte - spiky - 2014-10-20

J'ai récemment changé de nom DNS pour mon serveur GLPI. J'ai passé de "www.glpi.prod" à "glpi". J'ai évidemment reflété ça dans la config des agents mais, même après un redémarrage de l'agent, c'est l'ancien nom qui reste actif. Je remarque ça grâce à la vérification du certificat SSL côté client:

Oct 20 10:40:02 laa002 fusinv-agent[4803]: [http client] communication error: 500 Can't connect to www.glpi.prod:443 (SSL connect attempt failed with unknown errorerror:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed)

J'ai également essayé de supprimer /var/lib/fusioninventory/* puis redémarrer l'agent, sans succès. Quelqu'un a une idée?


Valeur du paramètre "server" dans agent.cfg non prise en compte - spiky - 2014-10-20

J'utilise les versions suivantes:

- GLPI 0.84.7
- L'agent fusion 2.3.12
- plugin fusion pour GLPI 0.84+3.4


Valeur du paramètre "server" dans agent.cfg non prise en compte - spiky - 2014-10-20

Hmm.. C'est vraiment étrange. Si j'utilise le FQDN du serveur (soit https://glpi.<domaine>/plugins/fusioninventory/), le nom est pris en compte et l'erreur du certificat SSL ne mentionne plus le même ancien serveur (www.glpi.prod). Par contre, si, après coup, je rechange la valeur pour "https://glpi/plugins/fusioninventory/" dans agent.cfg, l'erreur avec l'ancien nom revient..!


Valeur du paramètre "server" dans agent.cfg non prise en compte - spiky - 2014-10-20

Je viens de réaliser qu'il y avait le paramètre "URL d'accès au service" dans la configuration générale des agents dans GLPI qui valait "https://www.glpi.prod". Avec la dernière version du plugin fusion pour GLPI, ce paramètre n'est plus dans l'interface même si l'ancienne valeur apparait dans la BD (agent_base_url dans la table glpi_plugin_fusioninventory_configs). J'ai essayé de mettre à jour ce paramètre pour mon nouveau nom DNS en modifiant la BD directement mais je continue d'avoir des mentions de "www.glpi.prod" dans mes logs..


Valeur du paramètre "server" dans agent.cfg non prise en compte - ddurieux - 2014-10-20

Elle est dans un onglet dans les fiches entités (ça a été déplacé)


Valeur du paramètre "server" dans agent.cfg non prise en compte - spiky - 2014-10-20

Je viens de retrouver le paramètre, merci.

Après l'avoir changé pour mon nouveau nom, ça s'est remis à marcher Smile