Forums FusionInventory
Installation agent 2.3.16 error - Printable Version

+- Forums FusionInventory (https://forum.fusioninventory.org)
+-- Forum: Français (https://forum.fusioninventory.org/forumdisplay.php?fid=4)
+--- Forum: fusioninventory-agent (https://forum.fusioninventory.org/forumdisplay.php?fid=9)
+--- Thread: Installation agent 2.3.16 error (/showthread.php?tid=2509)



Installation agent 2.3.16 error - ludof54 - 2015-03-13

Bonjour,

Cela fait pas mal de temps que j'essaye d'installer le dernier agent sous Centos 6.5 ou 7 mais impossible.
J'ai toujours les mêmes messages d'erreurs, voici les logs des erreurs :

Use of uninitialized value in subroutine entry at /usr/local/share/perl5/HTTP/Server/Simple.pm line 397, <DATA> line 16.
Bailout called. Further testing stopped: can't launch the server: Bad arg length for Socket:Confusedockaddr_family, length is 0, should be at least 2 at /usr/local/share/perl5/HTTP/Server/Simple.pm line 397, <DATA> line 16.

# Failed test 'response is a success'
# at t/agent/http/client/connection.t line 448.
# Looks like you failed 1 test of 1.

# Failed test 'correct response'
# at t/agent/http/client/connection.t line 195.

# Failed test 'error message content'
# at t/agent/http/client/connection.t line 470.
# got: '[http client] communication error: 500 Can't connect to 127.0.0.1:8080'
# expected: '[http client] authentication required, no credentials available'
# Looks like you failed 1 test of 3.

# Failed test 'no response'
# at t/agent/http/client/connection.t line 211.

# Failed test 'response is a success'
# at t/agent/http/client/connection.t line 448.
# Looks like you failed 1 test of 1.

# Failed test 'correct response'
# at t/agent/http/client/connection.t line 227.
# We are are supposed to do HTTPS over a proxy and HTTP_X_FORWARDED_FOR environment variables is defined. This should not happen since the proxy cannot access the encrypted data. This means the local LWP library doesn't provide real SSL proxy support and try to contact the server using plaintext HTTP. HTTPS over proxy will not work properly. Please see: https://github.com/libwww-perl/libwww-perl/pull/52
# We are are supposed to do HTTPS over a proxy and HTTP_X_FORWARDED_FOR environment variables is defined. This should not happen since the proxy cannot access the encrypted data. This means the local LWP library doesn't provide real SSL proxy support and try to contact the server using plaintext HTTP. HTTPS over proxy will not work properly. Please see: https://github.com/libwww-perl/libwww-perl/pull/52
# Looks like you failed 3 tests of 36.
FAILED--Further testing stopped: can't launch the server: Bad arg length for Socket:Confusedockaddr_family, length is 0, should be at least 2 at /usr/local/share/perl5/HTTP/Server/Simple.pm line 397, <DATA> line 16.
make: *** [test_dynamic] Erreur 3

Quelqu'un saurait-il comment résoudre ce problème ?

Merci d'avance Wink


Installation agent 2.3.16 error - ludof54 - 2015-04-02

Bonjour, serait il possible d'avoir une réponse car les tâches ne marchent plus depuis le 30 janvier...


Installation agent 2.3.16 error - pepeEL - 2015-04-29

Hello
Can anybody help me step by step how i can install agent 2.3.16 on my Debian ? Now i have installed version agent 2.3.15 from Fusioninventory Own Repository ( http://www.fusioninventory.org/documentation/agent/installation/linux/deb/) but new version 2.3.16 there is now available.