Forums FusionInventory
Erreur de l'agent fusioninventory dans error.log de apache - Printable Version

+- Forums FusionInventory (https://forum.fusioninventory.org)
+-- Forum: Français (https://forum.fusioninventory.org/forumdisplay.php?fid=4)
+--- Forum: fusioninventory-agent (https://forum.fusioninventory.org/forumdisplay.php?fid=9)
+--- Thread: Erreur de l'agent fusioninventory dans error.log de apache (/showthread.php?tid=2551)



Erreur de l'agent fusioninventory dans error.log de apache - durand.jm - 2015-04-08

Bonjour,

voila je suis en train de faire évoluer ma plateforme de windows2003+apache 2.2+ php 5.3+mysql5.1 à windows2008r2+apache 2.4+php5.6+mysql 5.6 en vue de monter en version glpi et fusioninventory

je suis actuellement sur cette nouvelle plateforme avec glpi 0.83.6 et fusioninventory 0.83+1.0
ma migration vers la nouvelle architecture c'est bien passé

mais maintenant avec apache 2.4et PHP5.6 j'ai cette erreur dans le fichier error.log de apache


[Wed Apr 08 08:36:54.889362 2015] [:error] [pid 1612:tid 964] [client 150.10.2.205:54820] PHP Deprecated: Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php://input stream instead. in Unknown on line 0
[Wed Apr 08 08:36:54.889362 2015] [:error] [pid 1612:tid 964] [client 150.10.2.205:54820] PHP Warning: Cannot modify header information - headers already sent in Unknown on line 0


je voulais savoir si il y avait un risque à mettre le parametre 'always_populate_raw_post_data' à '-1 dans le fichier php.ini


Erreur de l'agent fusioninventory dans error.log de apache - ddurieux - 2015-04-08

il faut modifier le php.ini ( set 'always_populate_raw_post_data' to '-1' in php.ini)

Ca a été modifié dans le code dans les dernières version du plugin