Forums FusionInventory
Wake on lan - Printable Version

+- Forums FusionInventory (https://forum.fusioninventory.org)
+-- Forum: Français (https://forum.fusioninventory.org/forumdisplay.php?fid=4)
+--- Forum: fusioninventory-agent (https://forum.fusioninventory.org/forumdisplay.php?fid=9)
+--- Thread: Wake on lan (/showthread.php?tid=2573)



Wake on lan - francois50 - 2015-04-27

Bonjour,

j'essaie d'exécuter un Wake on lan sur un PC mais dans le log de l'agent, j'ai l'erreur suivante:

[Mon Apr 27 17:52:15 2015][error] Can't use string ("1") as a HASH ref while "strict refs" in use at ../agent/FusionInventory/Agent/Task/WakeOnLan.pm line 32.

Quelqu'un peut il me dire d'où cela vient. et comment je peut réparer?

GLIP 0.84.8 Agent: 2.3.16 FI: 0.84+3.5


Wake on lan - francois50 - 2015-04-30

Un petit up pour mon problème

est ce un problème de paramètre ou un bug de l'agent?

Merci d'avance


Wake on lan - francois50 - 2015-05-04

Quelqu'un connaît il ce problème dois je ouvrir un ticket?


Wake on lan - francois50 - 2015-05-04

J'ai ouvert un ticket concernant ce problème: http://forge.fusioninventory.org/issues/2937


Wake on lan - francois50 - 2015-05-06

A ddurieux,
pouvez vous me dire si l'option Wake on lan de l'agent FI est maintenu pour l'utilisation sur Windows?
Dans le ticket mentionné ci-dessus j'ai fait plusieurs tests et il semble que le code rencontre certains problèmes sur Windows.
peut on espérer avoir des correctifs concernant ces erreur?
je doit implémenter cette fonctionnalité et j'aimerais savoir si je dois m'orienter vers une autre application son exécution.
merci d'avance pour le feed-back.


Wake on lan - ddurieux - 2015-05-06

Normalement, ça devrait fonctionner, je vais essayer de trouver un windows pour tester


Wake on lan - francois50 - 2015-05-06

Un grand merci pour la réponse.
Vous pouvez aussi voir dans le ticket j'ai déjà fait un test.

en mettant en commentaire la ligne 3 ( use Strict; ) dans le fichier WakeOnLan.pm, je ne reçois plus le message: Can't use string ("1") as a HASH..........

Mais je reçois le message suivant: [error] no mac address defined

En mettant le debug à deux, je peut constater que l'adresse mac du PC à démarrer est belle et bien correctement récupérée par le programme
___________________________________________________________________________________
<?xml version="1.0" encoding="UTF-8" ?>
&lt;REQUEST&gt;
&lt;DEVICEID&gt;CHMS0017.emea.busch.inet-2015-05-05-17-25-25&lt;/DEVICEID&gt;
&lt;QUERY&gt;PROLOG&lt;/QUERY&gt;
&lt;TOKEN&gt;12345678&lt;/TOKEN&gt;
&lt;/REQUEST&gt;
[Wed May 6 08:34:16 2015][debug2] format: Zlib
[Wed May 6 08:34:16 2015][debug2] [http client] receiving message:
<?xml version="1.0" encoding="UTF-8"?>
&lt;REPLY&gt;
&lt;OPTION&gt;
&lt;NAME&gt;WAKEONLAN&lt;/NAME&gt;
&lt;PARAM MAC="6c:0b:84:0a:14:51"&gt;
&lt;/PARAM&gt;
&lt;/OPTION&gt;
&lt;RESPONSE&gt;SEND&lt;/RESPONSE&gt;
&lt;PROLOG_FREQ&gt;6&lt;/PROLOG_FREQ&gt;
&lt;/REPLY&gt;
_______________________________________________________________________________________

Je reste à disposition si vous avez besoins d'information pour progresser avec ce problème

merci d'avance pour l'aide


Wake on lan - francois50 - 2015-05-19

Bonjour ddurieux,

J'ai reçu un message concernant le ticket que j'avais ouvert: http://forge.fusioninventory.org/issues/2937

Il est mentionné: Fixed in commit #a36f5fa

mais malheureusement, je ne peux pas trouver ou je peux consulter ce commit #a36f5fa

pouvez vous m'aider, et me dire comment je peux y accéder.

un grand merci pour votre aide