Forums FusionInventory
Détection WMI Antivirus Windows 7 - Printable Version

+- Forums FusionInventory (https://forum.fusioninventory.org)
+-- Forum: Français (https://forum.fusioninventory.org/forumdisplay.php?fid=4)
+--- Forum: fusioninventory-agent (https://forum.fusioninventory.org/forumdisplay.php?fid=9)
+--- Thread: Détection WMI Antivirus Windows 7 (/showthread.php?tid=279)



Détection WMI Antivirus Windows 7 - cerede2000 - 2011-03-30

Bonjour,

La détection de l'antivirus présent sur la machine ne fonctionne actuellement pas sous Windows 7.

Malgrès le fait d'utiliser SecurityCenter2 cela ne remonte rien chez moi Sad

Les champs qui sont présents chez moi sont :
- displayName
- instanceGuid
- pathToSignedProductExe
- productState

Testé avec un VBS chez moi, antivirus Symantec EndPoint Protection.

Le fait de remonter par exemple le champ versionNumber qui n'existe pas chez moi peut il planter cette récupération ?


Détection WMI Antivirus Windows 7 - goneri - 2011-03-30

Bonjour, Vous utilisez l'agent 2.1.8-1 ? Normalement le problème est corrigé.


Détection WMI Antivirus Windows 7 - cerede2000 - 2011-03-31

Oui j'utilise l'agent en version 2.1.8-1, je vais retester cette partie.


Détection WMI Antivirus Windows 7 - goneri - 2011-03-31

Pouvez-vous m'envoyer le fichier XML généré par l'agent ici : goneri@rulezlan.org


Détection WMI Antivirus Windows 7 - cerede2000 - 2011-04-01

Bonjour, après de nouveaux tests c'est en effet ok Wink
Les info remontent comme il faut sous Windows 7.


Détection WMI Antivirus Windows 7 - slayer722 - 2011-05-24

Bonjour,

J'ai le même problème sous Windows 7 32bits avec la version de développement 2.1.8+dev-2.1.x-20110523-0913.
Pourtant dans le centre de maintenance Symantec Endpoint Protection indique bien qu'il est activé et à jour.

Cordialement

Les infos dans le XML :
<ANTIVIRUS>
<GUID>{88C95A36-8C3B-2F2C-1B8B-30FCCFDC4855}</GUID>
<NAME>Symantec Endpoint Protection</NAME>
</ANTIVIRUS>


Détection WMI Antivirus Windows 7 - goneri - 2011-05-24

Le centre de sécurité est-il actif ? Que retournent ces commandes ?

Code:
wmic /namespace:\\root\SecurityCenter PATH AntiVirusProduct GET /valie
wmic /namespace:\\root\SecurityCenter2 PATH AntiVirusProduct GET /value



Détection WMI Antivirus Windows 7 - slayer722 - 2011-05-24

SecurityCenter :
retourne rien, également avec un logiciel d'exploration des objets WMI on voit bien que rien n'est renseigné dans SecurityCenter

SecurityCenter2 :
displayName=Symantec Endpoint Protection
instanceGuid={88C95A36-8C3B-2F2C-1B8B-30FCCFDC4855}
pathToSignedProductExe=C:\Program Files\Symantec\Symantec Endpoint Protection\WS
CSavNotifier.exe
pathToSignedReportingExe=C:\Program Files\Symantec\Symantec Endpoint Protection\
Rtvscan.exe
productState=462848

Le service centre de sécurité est bien actif.


Détection WMI Antivirus Windows 7 - goneri - 2011-05-24

Merci, j'ai corrigé le bug, pouvez-vous vérifier qu'il est bien corrigé pour vous :
http://prebuilt.fusioninventory.org/devel/2.1.x/windows-i386/


Détection WMI Antivirus Windows 7 - slayer722 - 2011-05-24

Apparemment ça fonctionne.

Merci beaucoup !


Détection WMI Antivirus Windows 7 - goneri - 2011-05-24

super, merci pour le retour Smile