• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Deploy : bad JSON: jobs/actions must be an array
#1
Bonjour,

J'ai mis à jour dernièrement FusionInventory vers la nouvelle release 9.1+1.1, sous une version de GLPI 9.1.1.
J'avais ce problème de manière aléatoire sous l'ancienne version, je pensais que la nouvelle version allait corriger ce problème : que nenni.

La plupart des déploiements que je lance sur les postes se plantent : dans le statut de la tâche, celle-ci passe bien en statut "En cours" mais reste sur la première étape, à savoir "Préparé".
L'agent exécute très rapidement le mode Deploy : en 1 à 2 sec j'obtiens l'erreur et il passe ensuite à l'Inventaire.

Dans les logs de l'agent, voici l'erreur que j'obtiens :

[Thu Feb 2 10:17:31 2017][debug] forking process -3676 to handle task Deploy
[Thu Feb 2 10:17:31 2017][info] running task Deploy
[Thu Feb 2 10:17:31 2017][debug2] xxxxxxx/glpi/plugins/fusioninventory?action=getConfig&task[Deploy]=2.1.0&machineid=xxxxxxx-234.xxxxxxx.local-2016-07-21-12-24-30
[Thu Feb 2 10:17:32 2017][debug] Free space on C:\Program Files\FusionInventory-Agent\var\xxxxxxxx_glpi_plugins_fusioninventory\deploy: 148983
[Thu Feb 2 10:17:32 2017][debug2] glpi//plugins/fusioninventory/b/deploy/?action=getJobs&machineid=xxxxxxx-234.xxxxxx.local-2016-07-21-12-24-30
[Thu Feb 2 10:17:32 2017][debug] bad JSON: jobs/actions must be an array


Je précise j'ai déjà refait plusieurs fois le paquet, la tâche. Cela peut très bien fonctionner sur certains paquets comme pas du tout sur d'autre. J'ai la même erreur sur des taches de désinstallation, ou pourtant j'exécute simplement l'uninstaller distant sur le poste (donc sans aucun téléchargement de fichier).

Pouvez-vous m'aider ?
Merci Smile
  Reply


Messages In This Thread

Forum Jump:


Users browsing this thread: 1 Guest(s)