• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Deploiement de fusioninventory
#3
Bonjour,

Je ne sais quel peut être ton problème, mais si ça peut t'aider, je me suis mis au VBS hier et je me suis personnalisé un script que j'ai trouvé, si ça peut t'aider le voici.
Il fonctionne, mais il fait juste l'installation et ne met pas à jour l'agent.


Option Explicit
Dim Setup, SetupArchitecture, InstallCommandx64, SetupVersion, InstallCommandx86, FusionArguments, FusionSetupExe, WshShell, InstallCommand, Installx64, Installx86, OsType

SetupVersion = "2.3.19"
SetupArchitecture = "Auto"
FusionArguments = " /acceptlicense /runnow /execmode=service /add-firewall-exception /server='http://Ipserveur/glpi/plugins/fusioninventory/' /installtasks=Full /S"
FusionSetupExe = "\\Partage\netlogon\fusioninventory\fusioninventory-agent_windows-" & OsType & "_" & SetupVersion & ".exe"
Installx64= "\\Partage\netlogon\fusioninventory\fusioninventory-agent_windows-amd64_" & SetupVersion & ".exe"
Installx86= "\\Partage\netlogon\fusioninventory\fusioninventory-agent_windows-x86_" & SetupVersion & ".exe"

InstallCommandx64= Installx64 & " " & FusionArguments
InstallCommandx86= Installx86 & " " & FusionArguments

Set WshShell = Wscript.CreateObject("Wscript.shell")
OsType = WshShell.RegRead("HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment\PROCESSOR_ARCHITECTURE")

if (OsType = "x86") then
WshShell.Run "CMD.EXE /C """ & InstallCommandx86
else
WshShell.Run "CMD.EXE /C """ & InstallCommandx64
end if
  Reply


Messages In This Thread

Forum Jump:


Users browsing this thread: 1 Guest(s)