• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Deploiement de fusioninventory
#7
Bonjour,

Quand je lance le vbs sur un poste, une fenêtre rapide s'ouvre et se referme immédiatement mais rien ne s'installe...

Voilà ton script modifier avec mes path :

Option Explicit
Dim Setup, SetupArchitecture, InstallCommandx64, SetupVersion, InstallCommandx86, FusionArguments, FusionSetupExe, WshShell, InstallCommand, Installx64, Installx86, OsType

SetupVersion = "2.3.18"
SetupArchitecture = "Auto"
FusionArguments = " /acceptlicense /runnow /execmode=service /add-firewall-exception /server='http://172.16.1.50/glpi/plugins/fusioninventory/' /installtasks=Full /S"
FusionSetupExe = "\\172.16.1.50\netlogon\Fusion\fusioninventory-agent_windows-" & OsType & "_" & SetupVersion & ".exe"
Installx64= "\\\\172.16.1.50\netlogon\Fusion\fusioninventory-agent_windows-x64_" & SetupVersion & ".exe"
Installx86= "\\\\172.16.1.50\netlogon\Fusion\fusioninventory-agent_windows-x86_" & SetupVersion & ".exe"

InstallCommandx64= Installx64 & " " & FusionArguments
InstallCommandx86= Installx86 & " " & FusionArguments

Set WshShell = Wscript.CreateObject("Wscript.shell")
OsType = WshShell.RegRead("HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment\PROCESSOR_ARCHITECTURE")

if (OsType = "x86") then
WshShell.Run "CMD.EXE /C """ & InstallCommandx86
else
WshShell.Run "CMD.EXE /C """ & InstallCommandx64
end if


Si tu vois un truc bizarre????
Merci beaucoup en tout cas ;o)
Magali
  Reply


Messages In This Thread

Forum Jump:


Users browsing this thread: 1 Guest(s)