• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fusion Inventory through linux native SNMP-agentx daemon is only summary
#1
Hello to everyone!

Intro
------
I installed GLPI server with agent in the following configuration:
- Ubuntu 18.04.3 LTS
- PHP 7.2, Perl 5.26
- GLPI 9.4.4 + FusionInventory 2.3
- installed all perl, php dependencies from the README of
- on the same GLPI server I installed also the FusionInventory-Agent-2.5.2 from .deb packages with all required dependencies, following:
https://github.com/fusioninventory/fusio...t/releases
http://fusioninventory.org/documentation.../agent.cfg
- internal test of GLPI shows that all dependencies are met

1. If I scan from GLPI server, a specific ip-range using a Fusion Network Discovery task, having fusioninventory-agent listening as service with (--daemon --no-fork $OPTIONS) on targeted ubuntu servers,
then are imported correctly, the entry is displayed Assets > Computers > PCName and contains all discovered hardware devices, volumes and software,
the Active import rules being:
- Computer import (by mac)
- Computer update (by mac)
- Global import (by mac)

2. In all above conditions, from GLPI server, if I use the same Fusion Network Discovery task, and assign the SNMP credentials, in Assets > Computers are imported only:
- Computer: Name, Domain
- Network port: Name, MAC, IP addresses, IP networks

3. If I run snmpwalk from GLPI server to a targeted server (Ubuntu 18.04) with SNMPD configured and applying grep filtering by any software installed on it then I receive the results that exists,
which proves that SNMPD daemon is delivering all installed software list, see attachment for details.

# snmpwalk -v2c -c public server01.fqdn | grep -i apache2-bin
Response: iso.3.6.1.2.1.25.6.3.1.2.7 = STRING: "apache2-bin-2.4.29-1ubuntu4.11"

# snmpwalk -v2c -c public server01.fqdn sysObjectID.0                                                 
sysObjectID.0: Unknown Object Identifier (Sub-id not found: (top) -> sysObjectID)

4. If I run fusioninventory-netinventory binary from GLPI server to the same targeted server with SNMPD configured I'm receiving only a summary, see attachment;
# fusioninventory-netinventory --host server01.fqdn --credentials version:2c,community:public--debug

5. Which settings are needed to obtain full hardware and software inventory to GLPI server, but from native Ubuntu SNMPD-agentx server instead of FusionInventory-agent ?


Thank you!
Marius


Attached Files
.zip   snmpwalk_server01.fqdn.zip (Size: 37.31 KB / Downloads: 2)
  Reply
#2
Hi Marius,

sorry, actually, computers snmp remote inventory is absolutely not supported.

This could be a big enhancement, btw don't expect an inventory as good as local inventory.

Eventually, can you submit your full snmp walk ?
  Reply
#3
Thank you gbougard for your reply!

I added the full snmpwalk_server01.fqdn.zip to the first post.

Best Regards,
Marius
  Reply
#4
Hi Marius,

I confirm you this would be a pain to support computers which such poor walk: no serial, no UUID, just MAC to match a uniq computer. You should know enabling the import on MAC rule can be a problem in some context.

Btw, your walk is showing you're running a ubuntu linux system under in a Vmware VM. You should really use the agent as latest agent debian package are provided for such systems. Agent on linux is really stable, easy to setup and secure. I can understand you don't have the choice, but this is the best alternative.
  Reply
#5
Hello,

Do you have any rules that I can enable in order to do a complete SNMP inventory of linux vm's ?
As you said I have poor walk: no serial, no UUID, just MAC to match a uniq computer, could give me a snmpd.conf example to help us assign the missing tags?
I was reading some snmp tutorials, but couldn't figure out what I can set to help the fusion inventory, or point me to a specific tutorial pls.

Thanks a lot!
Marius
  Reply
#6
Hi Marius,

sorry, we don't have any such configuration to give you as I told you we can't support COMPUTER inventory via SNMP even for linux.

I must admit nothing can prevent us from implementing a FusionInventory MIB with dedicated SNMP config to support it on linux (and even we surely could develop a dedicated DLL for windows too). Btw we made the choice to develop a dedicated agent for every platform where it's easy to use perl.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)