• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
erreur dmidecode.exe agent 2.2.0-4
#1
bonjour,

j'avais cette erreur deja avec le client 2.2.0-3 sur un serveur 2003 R2 SP2
lorsque j'etais avec un client 2.1 je n'avais pas cette erreur

l'erreur se produit lors de l'ouverture de session
sinon l'inventaire fonctionne

j'ai installé le client avec le script vbs.
voici ce que je lance
/S /tag=site /server=http://serveur/glpi/plugins/fusioninventory/front/plugin_fusioninventory.communication.php /rpc-trust-localhost /runnow

merci
  Reply
#2
bonjour,
quelle erreur ? vous pouvez joindre une capture d'écran par exemple ?
  Reply
#3
C'est une session utilisateur avec les droits d'admin ?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#4
J'ai le même souci sur des serveurs 2003 et 2003R2
L'agent tourne comme service.
Agent version 2.2.0-4


voici les screens:
[Image: dmi1.png]
[Image: dmi2.png]
  Reply
#5
Bonsoir,

excusez-moi pour mon absence
merci pour tex bill j'ai les memes messages
agent en tant que service
compte administrateur du domaine
le serveur est virtualisé sous vmware esxi 5.0
vmtools à jour

merci
  Reply
#6
La version 2.2 est stable ? Ou quel est la dernière version stable à utiliser sachant que je suis en 2.1.14 ?
GLPI 0.83.7
Fusioninventory 0.83+2.1
Agent v2.1.14
  Reply
#7
Bonjour,

je viens de mettre à jour en version 2.2.1-1 même erreur
je rappelle que je n'ai pas l'erreur en version 2.1.14-1

avez-vous une solution svp

merci pour votre aide
  Reply
#8
voici le message d'erreur

Application défaillante dmidecode.exe, version 0.0.0.0, module défaillant ntdll.dll, version 5.2.3790.4789, adresse de défaillance 0x0000eda8.

merci pour votre aide
  Reply
#9
bonjour,

personne pour m'aider?
une idée

j'ai cette erreur depuis la version 2.2

merci
  Reply
#10
Bonjour,

J'ai aussi cette erreur chez plusieurs de mes clients, ça fait vraiment désordre.
Je viens d'installer une version 2.2.4, et ça le fait toujours.

Comment corriger ce problème ?
GLPI 9.4.5 - Fusioninventory for GLPI 9.4+2.4 - Fusioninventory Agent 2.5.2
  Reply
#11
Même problème sur la quasi totalité de mes serveurs 2003 R2, j'ai tout repassé en version 2.1.14-1 :/
  Reply
#12
Salut,

Je découvre le problème, il fallait plutôt ouvrir un bug pour le coup Sad Pouvez-vous essayer ce patch :

diff --git a/lib/FusionInventory/Agent/Tools/Generic.pm b/lib/FusionInventory/Agent/Tools/Generic.pm
index 840e68c..940cc58 100644
--- a/lib/FusionInventory/Agent/Tools/Generic.pm
+++ b/lib/FusionInventory/Agent/Tools/Generic.pm
@@ -24,6 +24,15 @@ sub getDmidecodeInfos {
@_
);

+# don't run dmidecode on Win2003
+# http://forge.fusioninventory.org/issues/379
+ Win32->require();
+ my @osver = Win32::GetOSVersion();
+ return if
+ $osver[4] == 2 &&
+ $osver[1] == 5 &&
+ $osver[2] == 2;
+
my $handle = getFileHandle(%params);

my ($info, $block, $type);
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
  Reply
#13
J'ai le problème chez un de mes clients, je ne peux pas essayer tout de suite. Je tente dès que j'y retourne.
En revanche, chez ce client ça plante sous Windows XP x64, qui je crois utilise le même noyau que Windows Server 2003, ça me semble donc cohérent...
GLPI 9.4.5 - Fusioninventory for GLPI 9.4+2.4 - Fusioninventory Agent 2.5.2
  Reply
#14
goneri Wrote:Salut,

Je découvre le problème, il fallait plutôt ouvrir un bug pour le coup Sad Pouvez-vous essayer ce patch :

diff --git a/lib/FusionInventory/Agent/Tools/Generic.pm b/lib/FusionInventory/Agent/Tools/Generic.pm
index 840e68c..940cc58 100644
--- a/lib/FusionInventory/Agent/Tools/Generic.pm
+++ b/lib/FusionInventory/Agent/Tools/Generic.pm
@@ -24,6 +24,15 @@ sub getDmidecodeInfos {
@_
);

+# don't run dmidecode on Win2003
+# http://forge.fusioninventory.org/issues/379

+ Win32->require();
+ my @osver = Win32::GetOSVersion();
+ return if
+ $osver[4] == 2 &&
+ $osver[1] == 5 &&
+ $osver[2] == 2;
+
my $handle = getFileHandle(%params);

my ($info, $block, $type);

Bonjour, n'étant clairement pas développeur, j'aurai besoin d'une explication en "français" si possible Smile
Quel fichier faut il modifier et que faut il rajouter ?

Merci d'avance Wink
  Reply
#15
Bonjour,

Je pense avoir corrigé le problème, pouvez-vous essayer cette pré-version :
http://prebuilt.fusioninventory.org/deve...dows-i386/

et reporter les éventuels problèmes ici : http://forge.fusioninventory.org/issues/1746

Merci d'avance
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
  Reply
#16
Ok je teste çà, merci beaucoup Wink
  Reply
#17
Je viens faire un petit retour, apparemment ça corrige le problème, merci ^^
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)