• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
partial match for sysobjectID
#1
Hello,

I am trying to add to my inventory the AP from Aruba Manufacturer, but when I make a network discovery I get the following error "partial match for sysobjectID .1.3.6.1.4.1.674.10895.5032 in database: unknown device ID"

When I type the snmp walk I get the OID .1.3.6.1.2.1.1.2.0 = OID: .1.3.6.1.4.1.674.10895.5032

I edited the file sysobject and add the following line 674.10895.5032 ArubaOS (MODEL: W-IAP109) but the error is not fixed.

How can I fix the problem?

thanks in advance.
Regards.
  Reply
#2
You should add the following line to your sysobject.ids file and using tabulation between fields:
Code:
674.10895.5032 Dell    NETWORKING PowerConnect W-IAP109

You should also open an issue on https://github.com/fusioninventory/sysobject.ids
  Reply
#3
Thanksssss!! was the tabulation, but........ when I make the inventory in GLPi I get the error 

Importation denied [mac]:xx:xx:xx:xx:xx:xx, [ip]:192.168.1.36, [name]: DeviceSerial, [entities_id]:0, [itemtype]:NetworkEquipment

Te command from cmd in windows fusioninventory-netdiscovery --first 192.168.1.36 --last 192.168.1.36 --credentials version:1,community:public --debug is ok
  Reply
#4
Still another device with poor SNMP standard support... I think we don't see the serial number or the name "DeviceSerial" is blacklisted...

We need a full snmpwalk output to check this device support, see http://fusioninventory.org/documentation...alk-output
  Reply
#5
(2020-08-20, 16:07:42)gbougard Wrote: Still another device with poor SNMP standard support... I think we don't see the serial number or the name "DeviceSerial" is blacklisted...

We need a full snmpwalk output to check this device support, see http://fusioninventory.org/documentation...alk-output

Hello!!

Here you have the snmpwalk file.

Thanks in advance


Attached Files
.txt   aruba.txt (Size: 55.55 KB / Downloads: 2)
  Reply
#6
Hi,

when using this walk with fusioninventory-netinventory, I see name set to "ApSerial123456", and the device has no serial. Do you know the serial of the device and can you give it so I can check if it is exposed in that walk ?
  Reply
#7
(2020-08-24, 09:01:46)gbougard Wrote: Hi,

when using this walk with fusioninventory-netinventory, I see name set to "ApSerial123456", and the device has no serial. Do you know the serial of the device and can you give it so I can check if it is exposed in that walk ?

Where you see ApSerial123456 you have to read Ap-9NPT3Y1 That is the serial number. Thanks in advance
  Reply
#8
Do you mean the serialnumber is in the device name and you obfuscate it manually in .1.3.6.1.2.1.1.5.0 OID ?

If yes, that's a shame Aruba did that and you must complain to Aruba... They should better provide a dedicated OID for serialnumber as other manufacturers.

I see a private OID where I can see "AUCCTfNorte-9NPT3Y1"

It still contains the aiVirtualControllerName, so maybe we can extract the serial, but I also see another string "DA0006068" which should be the AP serialnumber if I understand well the AI-AP-MIB Aruba AP MIB. So maybe AUCCTfNorte-9NPT3Y1 is a unique identifier in the AP, not a name and a serial.

Can you double-check the S/N of the device ?
  Reply
#9
(2020-08-25, 09:28:28)gbougard Wrote: Do you mean the serialnumber is in the device name and you obfuscate it manually in .1.3.6.1.2.1.1.5.0 OID ?

If yes, that's a shame Aruba did that and you must complain to Aruba... They should better provide a dedicated OID for serialnumber as other manufacturers.

I see a private OID where I can see "AUCCTfNorte-9NPT3Y1"

It still contains the aiVirtualControllerName, so maybe we can extract the serial, but I also see another string "DA0006068" which should be the AP serialnumber if I understand well the AI-AP-MIB Aruba AP MIB. So maybe AUCCTfNorte-9NPT3Y1 is a unique identifier in the AP, not a name and a serial.

Can you double-check the S/N of the device ?

Hello!!

The Serial Number is 9NPT3Y1
  Reply
#10
Solved!!
Thanks
  Reply
#11
Hi eudelio,

what do you mean by "Solved!!" ? Can you share the action you did ?

Thank you
  Reply
#12
Can you share what you did? I also encountered this problem when I added the manufacturer's AP to the list
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)