• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problems with netdiscovery
#1
Hello,

I'm totally lost. I'm running fusioninventory-netdiscovery and it shows me an XML. I save this to disk. I'm running fusioninventory-injector and it says

Loading manual/netdiscovery/192.168.0.1.xml...OK

BUT then I check in GLPI, and I see and entry in 'Equipment ignored list' - how can I find out WHY? I know about the 'rule test', but it's totally unclear to me how the entries from the XML map agains the fields in the tester. For example, I see an XML tag ('IP') holding the IP address, and a field 'MAC' holding the MAC address, but in 'Test Rules engine' I see an entry for 'Asset > Network port > MAC' and 'Asset > Network port > Port number' etc. pp. - how are they mapped?

When I set the most logical fields from the XML still all the tested rules show 'no' and the result is 'Validation Yes' - what does this mean?

Thank you for any help, hints or pointers to documentation on these topics.

Best regards,
    Jörg
  Reply
#2
Hi Jorg

I use discovery tasks, not manual injector - I'm not sure than. But for me, the most common reason for ignoring imports is lack of information. Which rule was applied I see in: Administration > Fusioninventory > Rules > Asset skipped during import > Column Rule name.

Example: Global import denied
Criteria: Asset > Item type is No itemtype defined. It means that agent doesn't know if it is a printer, or a computer, or...

If I assign valid snmp credentials to my scaned IP range it should recognize the device and import it.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)