• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Inventaire d'un matériel réseau Dell
#7
(2021-02-10, 14:15:02)gbougard Wrote: "fusioninventory-netdiscovery" ne fait pas d'inventaire complet, c'est "fusioninventory-netinventory" qu'il faut utiliser pour l'inventaire. Il ne faut pas confondre.

Peux-tu nous remettre l'output de la commande simplifiée pour ne pas être polluer par les messages de contrôle inutiles ici:
Code:
fusioninventory-netinventory --debug --debug --timeout 1 --host 192.168.0.15

Bonjour gbougard,

Oui, effectivement, c'est "Lors de l’exécution de la commande "fusioninventory-netinventory", l'ID est bien reconnu..." ...

Comme demandé dans ton précédent post, j'ai exécuté la commande (plus d'autres pour essayer):

Code:
# fusioninventory-netinventory --debug --debug --timeout 1 -host 192.168.0.15
[debug] creating 1 worker threads
[debug] [thread 1] creation
[debug] [thread 1] #1, scanning 0: 192.168.0.15
<?xml version="1.0" encoding="UTF-8" ?>
<REQUEST>
  <CONTENT>
    <DEVICE>
      <INFO>
        <ID>0</ID>
        <TYPE /></INFO>
    </DEVICE>
    <MODULEVERSION>4.0</MODULEVERSION>
    <PROCESSNUMBER>1</PROCESSNUMBER>
  </CONTENT>
  <DEVICEID>foo</DEVICEID>
  <QUERY>SNMPQUERY</QUERY>
</REQUEST>
[debug] [thread 1] termination
[debug] All netinventory threads terminated


# fusioninventory-netinventory --debug --debug --timeout 1 -host 192.168.0.15 --credentials version:3,username:myuser,authprotocol:sha,authpassword:mypassword
[debug] creating 1 worker threads
[debug] [thread 1] creation
[debug] [thread 1] #1, scanning 0: 192.168.0.15
<?xml version="1.0" encoding="UTF-8" ?>
<REQUEST>
  <CONTENT>
    <DEVICE>
      <INFO>
        <ID>0</ID>
        <TYPE /></INFO>
    </DEVICE>
    <MODULEVERSION>4.0</MODULEVERSION>
    <PROCESSNUMBER>1</PROCESSNUMBER>
  </CONTENT>
  <DEVICEID>foo</DEVICEID>
  <QUERY>SNMPQUERY</QUERY>
</REQUEST>
[debug] [thread 1] termination
[debug] All netinventory threads terminated


# fusioninventory-netinventory --debug --debug --timeout 1 -host 192.168.0.15 --credentials version:2c,community:mycommunity
[[debug] creating 1 worker threads
[debug] [thread 1] creation
[debug] [thread 1] #1, scanning 0: 192.168.0.15
<?xml version="1.0" encoding="UTF-8" ?>
<REQUEST>
  <CONTENT>
    <DEVICE>
      <INFO>
        <ID>0</ID>
        <TYPE /></INFO>
    </DEVICE>
    <MODULEVERSION>4.0</MODULEVERSION>
    <PROCESSNUMBER>1</PROCESSNUMBER>
  </CONTENT>
  <DEVICEID>foo</DEVICEID>
  <QUERY>SNMPQUERY</QUERY>
</REQUEST>
[debug] [thread 1] termination
[debug] All netinventory threads terminated
  Reply


Messages In This Thread
RE: Inventaire d'un matériel réseau Dell - by xnits31 - 2021-02-10, 16:07:27

Forum Jump:


Users browsing this thread: 1 Guest(s)