• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Import denied AP
#1
Hello,
I am trying to add my AP's Extreme Aerohive to GLPI.
I added the following lines to the file sysobtect.ids
26928   Extreme         NETWORKING
26928.1         Extreme         NETWORKING      AH-209100
After that, GLPI doesn't detect my APs. Now GLPI detect my devices but the snmp job show me:
    Import denied [mac]:34:85:84:20:8f:80, [ip]:192.168.28.20, [name]:AH-208f80, [entities_id]:0
Whe I do the snmp walk to my APS I get the following
sudo fusioninventory-netdiscovery --first 192.168.28.20 --last 192.168.28.20 --credentials version:1,community:AIDA --debug
[debug] scanning block 192.168.28.20-192.168.28.20
[debug] creating 1 worker threads
[debug] [thread 1] creation
[debug] [thread 1] scanning 192.168.28.20:
[debug] full match for sysobjectID .1.3.6.1.4.1.26928.1 in database
[debug] [thread 1] - scanning 192.168.28.20 with SNMP, credentials 1: success
[debug] [thread 1] - scanning 192.168.28.20 with netbios: no result
[debug] [thread 1] - scanning 192.168.28.20 with echo ping: success
[debug] [thread 1] - scanning 192.168.28.20 in arp table: no result
[debug] [thread 1] termination
<?xml version="1.0" encoding="UTF-8" ?>
<REQUEST>
  <CONTENT>
    <DEVICE>
      <AUTHSNMP>1</AUTHSNMP>
      <CONTACT>AIDA</CONTACT>
      <DESCRIPTION>AP630, HiveOS 10.0r8 build-236132</DESCRIPTION>
      <DNSHOSTNAME>192.168.28.20</DNSHOSTNAME>
      <IP>192.168.28.20</IP>
      <IPS>
        <IP>127.0.0.1</IP>
        <IP>192.168.28.20</IP>
        <IP>198.18.40.1</IP>
        <IP>198.18.8.1</IP>
      </IPS>
      <LOCATION>AIDA|BAJO</LOCATION>
      <MAC>34:85:84:20:8f:80</MAC>
      <MODEL>NETWORKING AH-209100</MODEL>
      <SNMPHOSTNAME>AH-208f80</SNMPHOSTNAME>
      <TYPE>Extreme </TYPE>
      <UPTIME>3 days, 22:54:24.74</UPTIME>
    </DEVICE>
    <MODULEVERSION>2.7</MODULEVERSION>
    <PROCESSNUMBER>1</PROCESSNUMBER>
  </CONTENT>
  <DEVICEID>foo</DEVICEID>
  <QUERY>NETDISCOVERY</QUERY>
</REQUEST>
[debug] cleaning 1 worker threads
How can I solve the problem?
The rule that stop the importation is "unmanaged device"
Thanks in advance.
  Reply
#2
Hi eudelio,
first there's a problem in your sysobject.ids update: field separators must be tabulations, not spaces. This is why we can see "Extreme " as TYPE and "NETWORKING AH-209100" as MODEL in your XML.
  Reply
#3
(2020-11-06, 11:51:47)gbougard Wrote: Hi eudelio,
first there's a problem in your sysobject.ids update: field separators must be tabulations, not spaces. This is why we can see "Extreme " as TYPE and "NETWORKING AH-209100" as MODEL in your XML.

Thanks so much. Problem solved.

Now, the items are assigned to the correct assets, but, when I do a second network discovery, GLPI duplicates the item. 
After a SNMP discovery, I saw, the item doesn't give a serial number, so, that's the reason for a duplicate item.

How can I solve the problem? I've reviewed the import rules but not figured out where is the issue.

Thanks in advance.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)