• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[GLPI 9.5.3] The software assigned to the computer is multiple
#1
Hello Guys.
Assets > Computers > I choose one > Software tab and I see something like this for example:
[Image: 0f82f91681aec.jpg]
Is it normal? I guess I should only see one item here. How do I know now what program is really installed on this computer?
Do you have the same or do I have a bug?
Inventory by FusionInventory 9.5.0+1.0
  Reply
#2
You don't have same software with multiple versions installed on your computer?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#3
No. When something is updated a new entry appears.
But sometimes someone can install a lower version. As a result, I never know what soft actually is installed on the computer.

Edit... My guess is this isn't normal after all and should only see the current version of the program on the list? Maybe this is not a bug but something wrong with my Software dictionaries or Rules?

From the software side it looks like this:

Only one entry.
[Image: 03ad678b46b3e.jpg]


But in the installation tab:

[Image: 5cca19da19bda.jpg]
  Reply
#4
Today I tried to delete all versions from one computer. After that force inventory and... The software didn't back with correct version.
  Reply
#5
WebGreg,

indeed you can have as many software version as users on a windows computer for all software from the microcrosoft store (UWP inventory). You can so see such problem since the agent supports UWP inventory (since v2.4.2).

As admin you should probably be able to check all installed version. I think you can also remove obsolete softwares but you'll have to check the MSDN to find how to do this ;-)

A version for a user can generally be updated when the user is logged.
  Reply
#6
If I understand you correctly...

User1 logs in and the agent gets information that there is installed Edge v.1
User2 logs in... Edge is updated to the version 2 - agent gets that information and sends it to the server.
I see in GLPI two positions with Edge - v1 and v2.
User1 logs in and the agent gets information that Edge is in version 2 and sends updated information to the server.
I see in GLPI one position with Edge - v2

"As admin you should probably be able to check all installed version" - as computer administrator or glpi administrator? If GLPI - I don't know how.

And can you give me a hint what to do when I deleted the selected software and the agent does not download that information again? 
I thought that the agent gets information about the software (during each inventory) and if the program is not on the computer list - an entry is added. But nothing appeared. The program is installed at the computer, but I don't have it listed in my GLPI. I don't want to delete the computer to import it with everything again. I need only actual list of programs - along with that one deleted.
  Reply
#7
"As admin you should probably be able to check all installed version"... Sorry I was not clear. I meaned as Administrator on the computer itself.
You can use the Get-AppxPackage command from an administrator powershell on the related computer:
Code:
Get-AppxPackage -AllUsers >appx-packages.txt
Then you can edit the txt file and check which users are using which Appx package version.

The agent is only doing inventory. You must delete the software on the computer itself and next time the agent will do an inventory it will be removed from the list on GLPI.

Deleting a software in GLPI, will only push it in the GLPI trashbin. If you remove it from the trashbin by cleaning it, it will probably appear again after the next inventory. This way you're just hiding the problem on the GLPI side.
  Reply
#8
Hi @gbougard

I made test. Deployment of an agent on a clean station (the first agent's inventory) - multiple entries. This means that this does not happen after the update.

I tried with Get-AppxPackage -AllUsers:

PackageFullName : Microsoft.Windows.CapturePicker_10.0.17763.1_neutral__cw5n1h2txyewy
PackageUserInformation : {S-1-5-21- [domain\user1]: Installed, S-1-5-21- [domain]: Installed, S-1-5-21- [domain\user2]: Installed}

PackageFullName : Microsoft.Windows.CapturePicker_10.0.18362.449_neutral__cw5n1h2txyewy
PackageUserInformation : {S-1-5-21- [domain\user3]: Installed, S-1-5-21- [domain\user4]: Installed, S-1-5-21- [domain\user5]: Installed}



FusionInventory:

CapturePicker 10.0.17763.1
CapturePicker 10.0.18362.449


You were right Smile I have 2 users with version 10.0.17763.1 and 3 with 10.0.18362.449.
But it is annoying Sad


I also have:

Eye Control 10.0.17763.1
Eye Control 10.0.18362.449

However, no entries in Get-AppxPackage with "Eye" string.
  Reply
#9
Thank you for your detailed tests.

I agree, this is annoying, but this is just the reality of the UWP package management system provided by Microsoft. From a security point of view, you absolutely need to know some softwares are installed with an older version.

I think you have tools to uninstall undesired UWP packages from a profile. This should be a way to keep a system as clean as possible.

About "Eye Control" software, the agent tries to get the package pretty name. So maybe it can not match the exact output of Get-AppxPackage, but it can match what you see in Microsoft Store. The agent uses its own powershell script to find more accurate datas. You can find the script at the end of the Task/Inventory/Win32/Software.pm file.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)