• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
problème sur tache decouverte matériel reseau
#1
bonjour,
je suis passé en client fusion en 2.1.14 et maintenant lorsque j'execute la tache que me retrouve avec le message suivant !

[error] Deflating problem. Is the string really compressed? Do you use the correct URL to the server. The string start with: <div style="position:fload-left; background-color:red; z-index:10000"><strong>PHP Warning: </strong>SimpleXMLElement::addAttribute() [<a href='function.SimpleXMLElement-addAttribute'>function.SimpleXMLElement-addAttribute</a>]: Attribute name and value are required in /usr/share/glpi/plugins/fusinvsnmp/inc/communicationsnmp.class.php at line 66</div><div style="position:fload-left; background-color:red; z-index:10000"><strong>PHP Warning: </strong>SimpleXMLElement::addAttribute() [<a href='funct
[error] No anwser from the server

une idée ?
  Reply
#2
je viens de réinstaller le client 2.2.2 et lorsque je lance en mode debug , je me retrouve avec l'erreur suivante :

[error] No target defined, aborting
  Reply
#3
en activant l'option /usr/bin/fusioninventory-agent --debug --stdout
j'ai ca !
[debug] Lib directory: /usr/local/share/fusioninventory/lib
mkdir /usr/local/var/fusioninventory/__LOCAL__
Execution failure:.
Can't use an undefined value as an ARRAY reference at /usr/local/share/fusioninventory/lib/FusionInventory/Agent/Storage.pm line 21.
  Reply
#4
?? personne !
  Reply
#5
Tu lance bien l'agent en root ?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#6
tout a fait !
  Reply
#7
Dans la conf de l'agent désactive la ligne : local = ..... et relance l'agent
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#8
j'ai pas de ligne local=
  Reply
#9
je peux faire quoi pour afficher plus de log ! pour trouver le problème ?
  Reply
#10
?
  Reply
#11
Hello,

J'ai eu le même problème, et j'avais oublié de mettre la ligne suivante : server=http://tonserveurglpi/pluginfusion/commenttulainstallé .

Et maintenant ça fonctionne.

Bon courage .

A+
  Reply
#12
pourtant dans mon agent.cfg sous /etc/fusioninventory/ j'ai bien ca !

basevardir=/var/lib/fusioninventory-agent
tag=50
server=http://xxx.xxx.xxx.xxx/glpi/plugins/fusioninventory/front/plugin_fusioninventory.communication.php
  Reply
#13
en fait ... en migrant en 2.2.2 le fichier de conf se trouve sous /usr/local/etc/fusioninventory/agent.cfg et non plus sous /etc/fusioninventory/agent.cfg
j'ai rajouté la ligne
server= et basevardir=
et c'est bon ca tourne , j'ai également réinstallé les modules ESX , DEPLOY et NETDISCOVERY mais ca ne remonte pas dans la conf de l'agent , je n'ai que la fonction INVENTORY: v2.2.2 d'activé .
  Reply
#14
en activant la log j'ai bien
[Thu Jun 14 12:12:15 2012][debug] Available tasks:
[Thu Jun 14 12:12:15 2012][debug] - ESX: 2.1.0
[Thu Jun 14 12:12:15 2012][debug] - Inventory: 1.0
[Thu Jun 14 12:12:15 2012][debug] - WakeOnLan: 1.0
[Thu Jun 14 12:12:15 2012][debug] - NetDiscovery: 2.1
[Thu Jun 14 12:12:15 2012][debug] FusionInventory Agent initialised
mais ca ne remonte pas dans la conf de l'agent
  Reply
#15
[info] task NetDiscovery is not enabled
alors que dans la conf de l'agent le module est activé !
  Reply
#16
Le message veut dire que l'agent n'a pas reçu d'ordre de scanne du serveur.
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)