• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problème mode demon avec agent prébuilt 2.2.2-1
#1
Bonjour,

J'utilise les agents prébuilt 2.2.2-1 sur des serveurs Linux Redhat 5.7 et AIX 7.1 car l'accès Internet est interdit depuis ces serveurs. Je ne peux donc pas faire d'installation par les méthodes classiques.
les agents fonctionnent car je les vois dans GLPI et les remontées d'infos fonctionnent dans GLPI.
Le problème c'est que je n'arrive pas à faire fonctionner les agents en mode demon.
Même si je les lancent avec l'option -d

Si quelqu'un peux m'aider, je le remercie d'avance
  Reply
#2
bonjour,
que se passe-t-il si vous lancer l'agent avec -d ? y'a-t-il un message d'erreur ?
  Reply
#3
J'ai eu pareil sur une debian hier, le mode daemon ne marche pas du tout en 2.2.2. L'agent a l'air lancé mis le port ne répond pas (n'est même pas ouvert)
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#4
Bonjour Wanna , Bonjour David,

j'ai essayé de démarrer l'agent avec l'option -d et je n'ai aucun message d'erreur , l'agent en lui même fonctionne , c'est juste le mode demon qui apparement ne fonctionne pas d'après David.

Question : dans les versions précédentes des agents en prébuilt, le mode demon fonctionne t'il ?

Si oui je ferai mes essais avec

Merci pour votre aide à tous les 2
  Reply
#5
Avec une 2.1.x pas de soucis
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#6
merci david , en effet avec une 2.1.14-1 cela fonctionne.

Par contre j'ai l'impression qu'avec cette version le déploiement de paquet ne fonctionne pas. Dis moi si je me trompe.

Je cherche également le moyen de faire une installation silencieuse de l'agent Windows. peux tu m'indiquer la démarche à suivre s'il te plait.

merci pour ton aide et tes réponses
  Reply
#7
j'ai trouvé pour l'installation silencieuse de l'agent Windows , je lirai mieux la doc la prochaine fois
  Reply
#8
bertrand0418 Wrote:Par contre j'ai l'impression qu'avec cette version le déploiement de paquet ne fonctionne pas. Dis moi si je me trompe.
il faut une 2.2.x pour le module de déploiement de paquets.
  Reply
#9
Oui mais le mode daemon fonctionne pas sur certaines installations avec l'agent 2.2.x Sad
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#10
Ok merci pour les infos.

David, tu pourrais nous dire quand une version des agents en prébuilt sortira avec le mode daemon et le déploiement de paquets s'il te plait ?

Merci à tous pour votre aide et vos réponses
  Reply
#11
ddurieux, tu as un rapport de bug la dessus ?
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
  Reply
#12
Non j'ai vu ça hier, faut que je refasse un test sur une debian (car je plus accès à la machine que j'avais hier sous la main)
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#13
Bonjour à tous,

David, as tu du nouveau concernant le mode Daemon et le télédéploiement s'il te plait ?

En attendant j'utilise la version 2.1.14-1 de l'agent prebuilt. Je ne m'en sort pas avec les options dans le fichier agent.cfg. Pourrais tu m'aider sur ce sujet ?
Voila ce dont j'ai besoin :
l'agent doit communiquer obligatoirement en HTTPS : j'ai rentré l'alias DNS de mon serveur en https sur la ligne qui se termine par communication.php
je ne veux pas que l'agent check le certificat
je veux que mon agent remonte tout de suite dans GLPI

Globalement les options qui sont à 0 veulent dire OUI à l'option en question ?

Merci d'avance
  Reply
#14
Pour le HTTPS, ça va être compliqué. Le plus simple est de faire des inventaires locaux et des les pousser aveec curl qui lui peut faire du SSL, ceci eventuellement depuis une autre machine ( http://forge.fusioninventory.org/project...using_curl ).
Une autre solution est de faire un proxy HTTP → HTTPS, par exemple en PHP que une machine, vous avez ainsi l'avantage de continuer a travailler avec du HTTP sur le serveur, mais avoir du HTTPS en sortie.

Si vous avez vraiment besoin de HTTPS, il faut recompiler Perl, OpenSSL et IO::Socket::SSL sur le OS en question. Les versions qui viennent avec les “prebuilts” 2.2.x sont basés sur la lib Crypt::SSLeay qu'on n'utilise plus sur la 2.2.x. De façon générale, le SSL est assez compliqué a supporter via ces mécanismes.
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
  Reply
#15
Bonjour à tous,

Je m'en sort quand même avec le HTTPS

Mais maintenant j'ai une bizzarerie, le nombre d'agent qui remonte dans GLPI au niveau du plugins fusioninventory ne dépasse pas 150, comme si c'était une limite. En plus j'ai des agents qui disparaissent quand des nouveaux apparaissent. C'est normal ou bien j'ai mal réglé quelque choses ?
A terme je devrais avoir près de 2000 agents. j'espere que ca pose pas de problème
  Reply
#16
Amon avis t'as un soucis avec les règles d'import de matériel, il doit sans duote fusionner des machines qui ne devrait pas.
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#17
je débute avec GLPI et fusionInventory , tu pourrais préciser s'il te plait ?
  Reply
#18
J'ai oublié de préciser quelque chose d'important, le pépin qui m'arrive ne se produit qu'avec les agent AIX , j'ai une bonne centaines d'agents Windows et Linux qui eux ne me posent pas ce problème
  Reply
#19
Il me semble que Proc:Big Grinaemon ne support pas AIX. Si c'est le cas, il ne faut pas chercher plus loin. Le plus simple est de le lancer via la crontab.
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
  Reply
#20
Bonjour Goneri,

Encore une precision, les agent AIX sont en 2.1.14-1 car comme vu plus haut les versions 2.2.2.-1 en effet ne supportaient pas le mode Daemon
  Reply
#21
A cause du SSL, c'est ça ?
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
  Reply
#22
le SSL n'est pas en cause , il me fallait imperativement le mode Daemon , c'est pour ca que , en attendant une version 2.2.X qui integre le mode Daemon fonctionnel , je suis en 2.1.14-1
J'arrive vraiment pas a comprendre d'ou viens ce problème avec mes agents AIX
  Reply
#23
La pour le coup, je suis étonné. Nous utilisions déjà Proc:Big Grinaemon. Pouvez-vous ouvrir le bug ?
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
  Reply
#24
Goneri, vous n'avez pas une petite idée sur mon problème avec mes agents AIX, pkoi j'ai des agents qui apparaissent et disparaissent comme si des agents remplacaient d'autres
  Reply
#25
Si le problème est arrivé avec la version 2.2.x, il faudrait ouvrir un bug sur la forge et continuer la discution a cette endroit afin de pouvoir mieux tracer nos échanges.
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)