• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
fusioninventory-agent bad token
#1
J'ai un agent solaris standalone 2.2.4 lancé en daemon qui fonctionne parfaitement.
Ce matin j'ai lancé une tache de découverte ESX avec comme vecteur cet agent (ce que j'ai déjà fait de nombreuses fois) et l'agent m'indique :
[Tue Aug 7 09:37:41 2012][debug] [http server] invalid request (bad token or bad address)

Une idée?
  Reply
#2
Si le token est pas bon, il faut que l'agent se lance et contacte le serveur pour mettre à jour ce token
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#3
en fait ma question est plutot ; pq un agent lancé en mode deamon perdrait son token?
  Reply
#4
Si l'agent n'arrive pas à contacter le serveur, ou si t'as un autre agent qui a le même deviceid et qui se mergerait sur l'agent (dans la gestion des agents dans GLPI)
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#5
tu veux dire qu'en cas de perturbation réseau le token est perdu?
Imagine si j'ai 1000 agents déployés et que je dois tous les relancer...
  Reply
#6
euh honetement j'ai pas testé ce cas là
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#7
ça m'inquiète un peu je te cache pas
cas d'école :
- micro coupure réseau
- les tokens de tous les agents (en deamon) ne sont plus bons
- tu dois relancer les agents --> donc kill du deamon, modif de agent.cfg pour virer daemon=1, lancement agent, modif agent.cfg pour remettre daemon=1 et relance agent en daemon

et ça sur plus de 1000 agents...
ingérable
  Reply
#8
Non au pire tu attends la prochaine execution de l'agent (par défaut une fois toutes les 24 heures) et là il renvoi au serveur. Mais comme j'ai dis, je dois tester ça
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#9
j'ai réglé ce paramètre toutes les 2h sur mes plateformes de test.
Paradoxalement ça c'est remit a marcher vers 3h du mat
je ne sais pas ce qui c'est passé a 3h
  Reply
#10
ah ben la je ne peut pas te dire Big Grin
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#11
il s'est remis a marcher pour mon netdiscovery et mon netinventory
par contre il refuse de lancer un scan ESX...
la tache retourne : Unable to find agent to run this job
J'ai comme l'impression que l'agent n'est pas réellement fonctionnel
  Reply
#12
étonnant un ps me donne 2 processus fusion
le 1er est le daemon et le second une tache qui a jamais du s'arreter
apres kill du process le deamon se remet a accepter des taches
  Reply
#13
Toujours le même problème avec GLPI 0.83.6/ FI 0.83+20 / FI agent 2.2.6


je crois savoir pourquoi et je souhaiterai confirmation d'un dev
J'ai 2 FI serveur: 2 serveurs de test

Mon agent FI a été inventorié par le 1er FI serveur mais depuis l'installation de l'agent il ne remonte plus sur ce serveur
Mon agent FI pointe maintenant vers un second serveur FI.

J'ai cependant l’impression que les token se marche dessus.
Est ce du au fait de ma conf FI serveur (push défini sur les taches)?
A quoi sert le champ server dans agent.cfg si le tache est définie en push sur le serveur FI?

Token FI server 1 : YPLOXMSI
Token FI server 2 : DATCEVCD

Message dans la log agent : [Mon Dec 3 11:19:12 2012][debug] [http server] request /now/YPLOXMSI from client xxx.xxx.xxx.xxx (ip serveur FI 1)
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)