• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Création d'un pre-built
#1
Bonsoir,

Utilisateur d'OCS, je découvre ce projet avec plaisir... Surtout concernant les pre-built !

2 petites questions...

- quels sont les pré-requis pour la bonne exécution d'un pre-built, s'il y en a.

- Ayant accès à des parcs très hétérogènes (HP-UX, Solaris, AIX, Linux), y a-t-il une procédure pour créer des pre-built ? Y a-t-il une raison (contrainte) à l'absence de package pour AIX ou HP-UX ? Si je peux aider la communauté ce sera avec plaisir !

Merci d'avance.
Cordialement,
Nam.
  Reply
#2
Bonjour
1- l'avantage d'un prebuilt est justement qu'il n'y a pas de pré-requis. En fait le seul est d'avoir un prebuilt pour sa plate-forme.
2- pour créer un prebuilt, il faut télécharger le fichier dans http://prebuilt.fusioninventory.org/base, le détarrer puis lancer le script shell qu'il contient. Nous n'avons pas de prebuilt pour HP-UX ni AIX (quoiqu'il y en a un à tester pour AIX 6.1) tout bonnement car nous n'avons pas eu accès à la plate-forme pour lancer le script et le débugger pour les problèmes éventuels de compilation du perl

Pour plus d'infos, je vous invite à passer sur notre canal irc (#fusioninventory sur irc.freenode.net)
Cordialement,
Walid
  Reply
#3
1- Parfait
2- Ok ! Je vais me pencher là dessus, j'ai régulièrement accès (de manière temporaire malheureusement) à de nombreuses plateformes. Cela permettra d'étendre votre catalogue !

See you soon.
  Reply
#4
avec grand plaisir, on ne demande qu'à étendre le nombre de plate-formes supportées !
  Reply
#5
Bonjour,

Première tentative de pre-built...

J'ai fait une installation CPAN de l'agent Fusion sur un serveur "Mandrake 10.2"... On ne troll pas svp ;-)
Inventaire OK...

Je tente la génération d'un pre-built... KO...

La longue compilation se termine par:

Code:
Configuring IO-Compress-2.027 ... OK
==> Found dependencies: Compress::Raw::Bzip2, Compress::Raw::Zlib
! Finding Compress::Raw::Bzip2 on cpanmetadb failed.
! Finding Compress::Raw::Bzip2 on search.cpan.org failed.
! Couldn't find module or a distribution Compress::Raw::Bzip2
! Finding Compress::Raw::Zlib on cpanmetadb failed.
! Finding Compress::Raw::Zlib on search.cpan.org failed.
! Couldn't find module or a distribution Compress::Raw::Zlib
! Bailing out the installation for IO-Compress-2.027. Retry with --prompt or --force

Y a-t-il des pré-requis ? La version de perl locale embarquée avec l'OS est 5.8.6 ...

La tentative d'installation manuelle du module via CPAN ou manuelle sort un joli :

Code:
make: *** Pas de règle pour fabriquer la cible « /usr/lib/perl5/5.8.6/i386-linux/CORE/EXTERN.h », nécessaire pour « blocksort.o ». Arrêt.

Bref, help Smile

See you.
  Reply
#6
Pourquoi vous n'utilisez le rpm pour Mandriva ?
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
  Reply
#7
C'est une bonne question... Cette option m'avait échappée.

Le RPM est-il un équivalent du pre-built ou une version équivalente du module CPAN ? Ce qui m'intéresse étant d'avoir une version de l'agent complètement indépendante fonctionnant même si Perl n'est pas (et ne peut pas être) installé sur la machine cible.

Je teste ça demain.
  Reply
#8
mandrake 10.2 = mandriva 10.2 ?
chez moi le prebuilt fonctionne bien sur mandriva 10.2
  Reply
#9
oui on peut dire mandrake = mandriva

Quel prebuilt ? le mandriva 2010 ? Ne fonctionne pas chez moi.
  Reply
#10
j'en ai fait un, le temps de l'uploader et de relancer le build il faut un peu de temps !
  Reply
#11
http://prebuilt.fusioninventory.org/stab...10.2-i586/ voilà, à tester
  Reply
#12
Ah ah un nouveau package arrivé comme par magie Smile

Merci je teste ça demain.
  Reply
#13
chez moi il marche nickel, même en remontée d'inventaire ssl
ce que je fais en général c'est que je monte une vm vierge du système avec juste le nécessaire pour le build
ensuite je lance ça dessus
  Reply
#14
L'agent fonctionne parfaitement merci beaucoup.

Il y a beaucoup d'autres pre-built cachés dans les tiroirs ? Smile

Merci en tout cas.
  Reply
#15
tout ceux qui sont faits sont sur http://prebuilt.fusioninventory.org
celui pour la mandriva 10.2, je l'ai fait après avoir lu votre post
  Reply
#16
Ok ! et bien merci d'autant plus !
  Reply
#17
sinon tu peux venir sur #fusioninventory sur irc.freenode.net (il y a une appli web http://webchat.freenode.net) pour discuter de ce qui concerne l'agent & les prebuilts
  Reply
#18
quelle est la liste exacte de toutes les plate-formes sur lesquelles il faudrait un prebuilt ?
  Reply
#19
Je n'ai pas cette information (la liste des plateforme)... Ce serait trop facile Smile

Je vais voir pour le canal IRC.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)