• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Software deployment via GLPI / (CLOSED)
#1
Hi,

Ok, this is somewhat embarrassing since I've had this working once in a test environment. This was however a long time ago and I have no memories on how it did work and what I did to get it working..
Code:
FusionInventory agent plugin: 0.83+1.0
GLPI version: 0.83.4
OS: Ubuntu Server 12.04LTS, 3.2.0-29-generic-pae
I was going to test a Java deployment and uploaded a new file to the server:
http://content.screencast.com/users/su_r...000896.png

I select a test computer and choose 'target a task' and then select the newly created package:
http://content.screencast.com/users/su_r...000897.png

When I push 'post' it says 'Operation successful' but where should I check running tasks since it doesn't seem to install anything?

php-errors.log says:
Code:
2012-09-15 15:14
MASSIVEACTION DEBUG:
Array
(
    [item] => Array
        (
            [7] => 1
        )

    [massiveaction] => Post
    [action] => plugin_fusinvdeploy_targetDeployTask
    [itemtype] => Computer
    [tasks_id] => 0
    [packages_id] => 2
    [_glpi_csrf_token] => ccfd06960d09456f28f5647f67e0f0a8
)

Any clues what I'm doing wrong? :-)

Thanks in advance and have a nice weekend!

br,
Chris

edit: thread solved. I need to make a short howto since the deployment process is not that clear for a new user
edit2: closed again, how-to coming..
#2
Can you make a sreenshot of this task ?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
#3
ddurieux Wrote:Can you make a sreenshot of this task ?

Hi,

Thanks for Your reply!

Of course I could do that but I'm not quite sure of what You want the screenshot? Could You please specify or copy/paste url and I'll do that?

Thanks!

br,
Chris

edit: some spelling..
#4
in menu plugins > FUsionInventory > fusioninventory > task management
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
#5
Thanks!

It is empty:
http://content.screencast.com/users/su_r...000898.png

br,
Chris
#6
Tried to make a new group, put a 32bit XPP PC into that group but same story, doesn't seem to do anything.

I have a memory that there should have been options in this drop down (install / remove):
http://content.screencast.com/users/su_r...000899.png
#7
you must create a task first
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
#8
Thanks for Your reply!

ddurieux Wrote:you must create a task first


Excuse my stupidity but where shall I create the task? :-)

I know I'm not the sharpest knife in the box but this is at the edge of being funny. I'll have to make a small howto when I get this to work for other stupid people like me.
#9
In task management in plugin fusioninventory into GLPI
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
#10
Thank You for the reply!

ddurieux Wrote:In task management in plugin fusioninventory into GLPI

I guess I missed a vital part and if so, this is not clear IMO. I don't have VPN access to the other server at the moment where I tried getting this to work so I did just setup a clean install on another computer.


Code:
GLPI: 0.83.4
FusionInventory 0.83+2.0

I followed Your instructions and created a task (the yellow + sign at the top of the page which I've completely missed before), see screenshot:

http://content.screencast.com/users/su_r...7_0945.png

What is strange, when I made the "install task" the deploy task also showed up? I have to test this at home later tonight and see if I can replicate this process!

Thank You very much Sir for Your kind help with my issue! I wish You a great and productive week!

br,
Chris
#11
Another stupid question; what am I doing wrong when there is no task showing up here:
http://content.screencast.com/users/su_r...000909.png

In task management, I have the following tasks (/glpi/plugins/fusioninventory/front/tasksummary.php?see=actives):
http://content.screencast.com/users/su_r...000910.png

Sorry for my stupid questions/problems!

br,
Chris
#12
Task has to be inactive for it to show up as a task on assets page!
http://content.screencast.com/users/su_r...000911.png

br,
Chris
#13
I have fixed this for next version if my memory is good
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
#14
ddurieux Wrote:I have fixed this for next version if my memory is good

OK :-)

That is no big issue if one just knows how it is working. I've been thinking about it for ~2 days and suddenly by mistake I found that it has to be inactive for task to show up.

br,
Chris


Forum Jump:


Users browsing this thread: 1 Guest(s)