• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Agent MAC OSX
#1
Bonjour
J'ai modifié sur le mac le fichier agent.cfg
j'ai rajout 127.0.0.1 en http-trust
debug = 2

Je n'ai pas "force inventory" en http://localhost:62354 ?

Quand je lance http://localhost:62354/now j'ai le message
Acces Denied ...

je suis en tant que root sur la machine
et je ne vois pas de log dans /var/log ???

Quel est le problème ?

Merci
Merci

GLPI 0.90.5/ Plugins Fusion : 090+1.4 / Agent : 2.3.18 < Serveur Centos 64 Bits>
  Reply
#2
Bonjour,

Les modifications que j'ai faites de mon côté sur le fichier /opt/fusioninventory-agent/agent.cfg :
Code:
server = http://monserver.domain.com/glpi/plugins/fusioninventory/
    tag = MonTag
    httpd-trust = 127.0.0.1
    daemon = 1
Pour ma part, tout fonctionne très bien avec ces paramètres : le lien apparaît sur la page http://localhost:62354, et l'appel direct à l'URL http://localhost:62354/now fonctionne aussi.

Est-ce que l'agent a été redémarré suite à la modification du fichier agent.cfg ? C'est impératif pour que les modifications soient prises en compte.
Pour cela, je fais depuis un terminal :
Code:
ps -ef | grep fusion
J'obtiens comme réponse :
Code:
0 27034     1   0 10:12   ??         0:00.26 /opt/fusioninventory-agent/perl/bin/perl -e ^J^J@INC = split(/:/,$ENV{PERL5LIB});^Jrequire "/opt/fusioninventory-agent/perl/bin/fusioninventory-agent";^J^J^J -- --conf-file=./agent.cfg
  501 27253  2734   0 10:19   ttys000    0:00.00 grep fusion
Je vois que l'agent a le numéro de processus 27034, et pour tuer ce processus je fais :
Code:
sudo kill -9 27034
Puis je relance l'agent, qui va prendre en compte les nouveaux paramètres avec la commande :
Code:
sudo /opt/fusioninventory-agent/run.sh

Autre solution pour prendre en compte les modifications dans le fichier agent.cfg : rebooter le Mac ;-)

Cordialement,
Marc
GLPI 9.4.4 - Fusioninventory for GLPI 9.4+1.0 - Fusioninventory Agent 2.5.1
  Reply
#3
OK
j'avais vu dans le forum les modifications que j'avais fait
mais je lancais ensuite fusioninventory-agent ....

ok pour run.sh
pour le log j'avais oublié de decommenté dans le fichier agent.cfg !!!

Si le mac redemarre il faudra refaire run.sh ?
existe t-il un moyen de le mettre au démarrage ?
Merci

GLPI 0.90.5/ Plugins Fusion : 090+1.4 / Agent : 2.3.18 < Serveur Centos 64 Bits>
  Reply
#4
Pas besoin de faire un "run.sh" au démarrage du Mac, l'installeur de FusionInventory a créé un script de démarrage, /Library/LaunchDaemons/org.fusioninventory.agent.plist, qui s'en occupe automatiquement.
En revanche, il faut bien avoir positionné "daemon = 1" dans agent.cfg pour que l'agent démarre.
GLPI 9.4.4 - Fusioninventory for GLPI 9.4+1.0 - Fusioninventory Agent 2.5.1
  Reply
#5
OK merci
Merci

GLPI 0.90.5/ Plugins Fusion : 090+1.4 / Agent : 2.3.18 < Serveur Centos 64 Bits>
  Reply
#6
bonjour,

j'ai installé un agent FusionInventory sur un Mac OS X, powerPC. La version de GLPI est 0.83.6 et l'agent Fusioninventory utilisé est fusioninventory-agent_macosx-ppc_2.2.7-3.pkg.tar

Modification du fichier agent.cf:
- httpd-trust = 127.0.0.1
- tag = MonTag
- daemon = 1
- debug=2

http://localhost::62354 est ok
malgré que j'ai relancé run.sh et aussi redémarré le système, l'information sur le Mac OS n'est jamais remontée dans GLPI. merci d'avance de votre avis
  Reply
#7
Bonjour,

Avez-vous bien donné la bonne valeur au champ 'server' dans le fichier agent.cfg ?
Vous pouvez aussi essayer d'accéder à l'adresse du serveur depuis un navigateur pour voir si ça fonctionne.
GLPI 9.4.4 - Fusioninventory for GLPI 9.4+1.0 - Fusioninventory Agent 2.5.1
  Reply
#8
il faut mettre daemon=0 si vous utilisez launchd. Vous avez quoi comme adresse de serveur ? Il faudrait accompagner votre poste avec un log de l'agent.
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
  Reply
#9
bonjour,

Le premier URL de GLPI est https://MonDomain.x.x/glpi/plugins/fusioninventory
Il est accessibles depuis un navigateur

Quand j'attribue la valeur daemon=0, je ne peux plus accéder à localhost:62354
merci
  Reply
#10
le deuxième URL de GLPI est: http://IP/glpi/plugins/fusioninventory

voici le log du poste:

ci-dessous est le log du poste sur lequel tourne l'agent:
[Mon Mar 25 16:40:12 2013][debug] FusionInventory unified agent for UNIX, Linux and MacOSX (2.2.7-3)
[Mon Mar 25 16:40:12 2013][debug] Configuration directory: ./etc
[Mon Mar 25 16:40:12 2013][debug] Data directory: ./share
[Mon Mar 25 16:40:12 2013][debug] Storage directory: ./var
[Mon Mar 25 16:40:12 2013][debug] Lib directory: ./perl/agent
[Mon Mar 25 16:40:12 2013][debug] [target server0] Next server contact planned for Mon Mar 25 17:22:34 2013
[Mon Mar 25 16:40:13 2013][debug] [target server1] Next server contact planned for Mon Mar 25 17:16:46 2013
[Mon Mar 25 16:40:13 2013][debug] Available tasks:
[Mon Mar 25 16:40:13 2013][debug] - ESX: 2.2.1
[Mon Mar 25 16:40:13 2013][debug] - Inventory: 1.0
[Mon Mar 25 16:40:13 2013][debug] - WakeOnLan: 1.0
[Mon Mar 25 16:40:13 2013][debug] - NetDiscovery: 2.2.0
[Mon Mar 25 16:40:13 2013][debug] - Deploy: 2.0.4
[Mon Mar 25 16:40:13 2013][debug] - NetInventory: 2.2.0
[Mon Mar 25 16:40:13 2013][debug] FusionInventory Agent initialised
[Mon Mar 25 16:40:13 2013][debug] [http client] Using Compress::Zlib for compression
[Mon Mar 25 16:40:13 2013][debug2] [http client] sending message:
<?xml version="1.0" encoding="UTF-8" ?>
<REQUEST>
<DEVICEID>ig5-xxx.xxx-2013-03-21-17-06-23</DEVICEID>
<QUERY>PROLOG</QUERY>
<TOKEN>ZCFRKQKR</TOKEN>
</REQUEST>

[Mon Mar 25 16:40:13 2013][fault] failed to load IO::Socket::SSL, unable to perform SSL certificate validation.
You can use 'no-ssl-check' option to disable it. at perl/agent/FusionInventory/Agent/HTTP/Client.pm line 142.

[Mon Mar 25 16:40:13 2013][debug] [http client] Using Compress::Zlib for compression
[Mon Mar 25 16:40:13 2013][debug2] [http client] sending message:
<?xml version="1.0" encoding="UTF-8" ?>
<REQUEST>
<DEVICEID>ig5-4012.xxx-2013-03-21-17-06-23</DEVICEID>
<QUERY>PROLOG</QUERY>
<TOKEN>ZCFRKQKR</TOKEN>
</REQUEST>

[Mon Mar 25 16:40:13 2013][error] [http client] communication error: 501 Protocol scheme 'proxy.xxx.xx' is not supported
[Mon Mar 25 16:40:13 2013][fault] No answer from the server at perl/agent/FusionInventory/Agent.pm line 248.
  Reply
#11
Ah, SSL n'est pas possible avec l'agent Mac Sad Désolé.
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
  Reply
#12
Effectivement, cela fonctionne bien avec un serveur GLPI sans le SSL.
Y-aurait-il une solution alternative pour inventorier les machines Mac sur le serveur GLPI avec le SSL?
merci
  Reply
#13
Il faudrait refaire une partie du packaging pour intégrer IO::Socket::SSL.
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
  Reply
#14
Dès que j'aurai un peu de temps, j'aimerais bien aider là-dessus, car je pense qu'on pourrait aussi ajouter la désinstallation de la version précédente et le 'kill' des processus actifs quand on installe une mise à jour ; actuellement il faut faire tout ça à la main sur Mac...
GLPI 9.4.4 - Fusioninventory for GLPI 9.4+1.0 - Fusioninventory Agent 2.5.1
  Reply
#15
Pour le moment, j'ai ajouté # à la ligne 142 dans le fichier client.pm et cela a rien donné.
une idée en attendant d'une nouvelle mise à jour? merci
  Reply
#16
En attendant la mise à jour du package, voici comment le probleme peut être 'contourné':

BrowserMatch ^FusionInventory-Agent UAallowed
#Add by ELA
Alias /glpi /var/www/MonDomain/www-ssl/glpi
<Directory /var/www/MonDomain/www-ssl/glpi>
Options FollowSymLinks Multiviews
AllowOverride None
Order Deny,Allow
Deny from all
Allow from env=UAallowed
</Directory>
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)