• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Uninstalled software still present in GLPI DB
#1
Dear all,

I've just noticed that if I uninstall a software from a client and i force the inventory update the uninstalled software is still prensent in GLPI.

I'm on GLP 0.83.7 and Fusioninventory 0.83+2.1

Have you any idea how to solve it?

Thank you

L.
  Reply
#2
Just upgraded a windows client to agent version 2.2.7-3 but this didn't solve the problem.

It's really weird cause if I install a new software on the PC the software appera in GLPI, if I uninstall it it has not been removed!!!

Ive also checked the XML that the agent produce if I run it manually and the software unistalled are not in the report so I assume the problem is to fusioninventory-GLPI side.
  Reply
#3
any news?
  Reply
#4
So software not preent in last XML and already present into GLPI?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#5
thank for your reply;

where I can check thxe XML? on client or server side?

I've also noticed that alternate username is not syncronized with username... with GLPI those issue was solved using "force syncreonization" but here is not present...
  Reply
#6
See tab "import information" tab in computer form, you have link to download the xml
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#7
ddurieux Wrote:See tab "import information" tab in computer form, you have link to download the xml


Hi ddurieux,

you are right, the software remain in the inventory but I can not find it into XML!!

thank you

L.
  Reply
#8
Ok so glpi may not have the software, so yes it's a bug :/
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#9
may I halep you with some log?

I'm using
FusionInventory 0.83+2.1

I've already uninstalled it, delete all fusioninv folder and reinstalled it
  Reply
#10
And with reinstall it, make a new inventory you always have this software?

Send me the XML and the name of the software please
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#11
yes I've deleted the3 fusioninv. folder under glpi/plugin

then cleaned the plugin in the webpage and reinstalled it.

same issue.

Maybe I've missed something?
  Reply
#12
looks like affter a "data integrity check" on computer the software disappeared. (I dont know if this could solve the issue on all the other computer)

I've tried to apply this to all my pc, using fusioninventory plugin --> Inventory --> integrity check I've selected all and then cliecked on clean button.

after some second IE reports an error reading this URL:

http://myserver.url/plugins/fusinvinvent...egrity.php

on /var/log/httpd I've found:

PHP Fatal error: Call to a member function cleanGLPI() on a non-object in /var/www/html/glpi/plugins/fusinvinventory/front/libintegrity.php on line 54, referer: http://glpi.nuovafima.it/plugins/fusinvi...egrity.php
  Reply
#13
Hi ddurieux
I've solved the problem in the data integrity check module increasing the max_input_vars in php.ini.

now I'm able to use the data integrity check in fusioninventory.

I've a couple of question:

1. I've checked the Item "Only in GLPI (check to delete)" and after the update they had gone. Great; then I've checke the item "Only in last inventory (check to import)" but after the update they remains.

2. there is a way to schedule the integrity check?

thanks

Ps if I click on clean button sometime it fail with error:

PHP Warning: include(): Input variables exceeded 0. To increase the limit change max_input_vars in php.ini. in /var/www/html/glpi/inc/includes.php on line 53

L.
  Reply
#14
Integrity checkis a little bugged. I have rewritn all inventory engine in the next verion (in beta now) and will fix all yous problems
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#15
Sounds good!!

let me know if you need a tester.... I'll look on the website for a release.
  Reply
#16
You can see here to test the beta version: http://www.fusioninventory.org/news/2013...ug_hunter/
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#17
Perfect; I'll test it with GLPI 0.84.
  Reply
#18
^^
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#19
I've just made a test upgrading glpi&fusioninventory to latest nigtly.

I've this error on php_errors.log:

[12-Apr-2013 10:58:21] PHP Warning: set_error_handler() expects the argument (Toolbox::userErrorHandlerDebug) to be a valid callback in /var/www/html/glpi/plugins/fusioninventory/front/communication.php on line 62
[12-Apr-2013 10:58:21] PHP Notice: Use of undefined constant PLUGIN_FUSIONINVENTORY_VERSION - assumed 'PLUGIN_FUSIONINVENTORY_VERSION' in /var/www/html/glpi/plugins/fusioninventory/front/communication.php on line 67
[12-Apr-2013 10:58:22] PHP Warning: set_error_handler() expects the argument (Toolbox::userErrorHandlerDebug) to be a valid callback in /var/www/html/glpi/plugins/fusioninventory/front/communication.php on line 62
[12-Apr-2013 10:58:22] PHP Notice: Use of undefined constant PLUGIN_FUSIONINVENTORY_VERSION - assumed 'PLUGIN_FUSIONINVENTORY_VERSION' in /var/www/html/glpi/plugins/fusioninventory/front/communication.php on line 67
[12-Apr-2013 10:58:43] PHP Warning: set_error_handler() expects the argument (Toolbox::userErrorHandlerDebug) to be a valid callback in /var/www/html/glpi/plugins/fusioninventory/front/communication.php on line 62
[12-Apr-2013 10:58:43] PHP Notice: Use of undefined constant PLUGIN_FUSIONINVENTORY_VERSION - assumed 'PLUGIN_FUSIONINVENTORY_VERSION' in /var/www/html/glpi/plugins/fusioninventory/front/communication.php on line 67
[12-Apr-2013 10:58:43] PHP Warning: set_error_handler() expects the argument (Toolbox::userErrorHandlerDebug) to be a valid callback in /var/www/html/glpi/plugins/fusioninventory/front/communication.php on line 62
[12-Apr-2013 10:58:43] PHP Notice: Use of undefined constant PLUGIN_FUSIONINVENTORY_VERSION - assumed 'PLUGIN_FUSIONINVENTORY_VERSION' in /var/www/html/glpi/plugins/fusioninventory/front/communication.php on line 67
[12-Apr-2013 10:58:44] PHP Warning: set_error_handler() expects the argument (Toolbox::userErrorHandlerDebug) to be a valid callback in /var/www/html/glpi/plugins/fusioninventory/front/communication.php on line 62
[12-Apr-2013 10:58:44] PHP Notice: Use of undefined constant PLUGIN_FUSIONINVENTORY_VERSION - assumed 'PLUGIN_FUSIONINVENTORY_VERSION' in /var/www/html/glpi/plugins/fusioninventory/front/communication.php on line 67
  Reply
#20
Plugin FusionInventory is right installed + activated?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#21
I've removed and cleaned the old plugin and installed and enabled the new one using latest glpi 0.84 noightly.

I've always the followin error forcing an inventory on a client:

[15-Apr-2013 09:02:14] PHP Warning: set_error_handler() expects the argument (Toolbox::userErrorHandlerDebug) to be a valid callback in /var/www/html/glpi/plugins/fusioninventory/front/communication.php on line 62
[15-Apr-2013 09:02:14] PHP Notice: Use of undefined constant PLUGIN_FUSIONINVENTORY_VERSION - assumed 'PLUGIN_FUSIONINVENTORY_VERSION' in /var/www/html/glpi/plugins/fusioninventory/front/communication.php on line 67
[15-Apr-2013 09:02:14] PHP Warning: set_error_handler() expects the argument (Toolbox::userErrorHandlerDebug) to be a valid callback in /var/www/html/glpi/plugins/fusioninventory/front/communication.php on line 62
[15-Apr-2013 09:02:14] PHP Notice: Use of undefined constant PLUGIN_FUSIONINVENTORY_VERSION - assumed 'PLUGIN_FUSIONINVENTORY_VERSION' in /var/www/html/glpi/plugins/fusioninventory/front/communication.php on line 67
[15-Apr-2013 09:02:14] PHP Warning: set_error_handler() expects the argument (Toolbox::userErrorHandlerDebug) to be a valid callback in /var/www/html/glpi/plugins/fusioninventory/front/communication.php on line 62
[15-Apr-2013 09:02:14] PHP Notice: Use of undefined constant PLUGIN_FUSIONINVENTORY_VERSION - assumed 'PLUGIN_FUSIONINVENTORY_VERSION' in /var/www/html/glpi/plugins/fusioninventory/front/communication.php on line 67
  Reply
#22
In reply to the people asking about sleepright nasal breathe aid canada, sport intra nasal breathe aid, do nasal strips help running, what does putting a bandaid on your nose do, can nasal polyps cause difficulty breathing, best nasal dilator for sleep, do breathe right strips work for snoring, how to operate breathing apparatus, mute nasal dilator uk, breathe right extra strength tan, nasal breathing devices, nasal dilator, nasal breathing problems in dogs, breathe right extra strength clear nasal strips, how to learn to nose breathe, I highly suggest this - top site for can you breathe through your nose when running, do breathe right strips work for congestion, do breathe right nose strips work, how to stop snoring through my nose, sleepwell nasal dilator reviews, breathe right strips for snoring reviews, how to know if your dog has breathing problems, can't breathe through nose during exercise, how to apply a nose strip, nasal strips for running, breathe right strips review sleep apnea, breathe right clear regular nasal congestion strips 30, breathe right extra strength large, how to use biore charcoal nose strips, do breathe right strips work for nasal congestion, is good as well. See More Most Top Rated Nasal Dilators Today a14486c
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)