• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Résolu] [GLPI 0.83.7] Problème déploiement automatique
#1
Bonjour,

J'ai une erreur Communication : 404 Not found lorsque j'essaie de déployer un fichier depuis mon serveur GLPI.

Voici mes configs :

Serveur GLPI sous ubuntu 12.10
Apache 2 + PHP 5 + Mysql + PhpMyAdmin + ftpd
GLPI 0.83.7

[Image: 1173960999.png]

la partie inventaire fonctionne correctement avec un poste sous XP

voici la config du paquet :

[Image: 1173963573.png]

la config du déploiement :

[Image: 1173965612.png]

on voit bien que la tâche est préparée !

et voici enfin la fin du log de l'agent où apparait l'erreur en question :

Code:
[Sun Jan 27 16:16:42 2013][debug] Running FusionInventory::Agent::Task::Inventory::Input::Win32::USB
[Sun Jan 27 16:16:48 2013][debug] Running FusionInventory::Agent::Task::Inventory::Input::Win32::User
[Sun Jan 27 16:16:49 2013][debug] Running FusionInventory::Agent::Task::Inventory::Input::Win32::Videos
[Sun Jan 27 16:16:49 2013][debug] Section PRINTERS has changed since last inventory
[Sun Jan 27 16:16:49 2013][debug] Section HARDWARE has changed since last inventory
[Sun Jan 27 16:16:49 2013][debug] Section DRIVES has changed since last inventory
[Sun Jan 27 16:16:49 2013][debug] [http client] Using Compress::Zlib for compression
[Sun Jan 27 16:16:50 2013][debug] running task WakeOnLan in process -1096
[Sun Jan 27 16:16:51 2013][debug] No WakeOnLan requested in the prolog
[Sun Jan 27 16:16:51 2013][info] task WakeOnLan is not enabled
[Sun Jan 27 16:16:51 2013][debug] running task NetDiscovery in process -2944
[Sun Jan 27 16:16:51 2013][debug] No NetDiscovery requested in the prolog
[Sun Jan 27 16:16:51 2013][info] task NetDiscovery is not enabled
[Sun Jan 27 16:16:53 2013][debug] running task Deploy in process -1116
[Sun Jan 27 16:16:54 2013][error] [http client] communication error: 404 Not Found
[Sun Jan 27 16:16:54 2013][debug] bad JSON: No answer from server.
[Sun Jan 27 16:16:54 2013][error] [http client] communication error: 404 Not Found
[Sun Jan 27 16:16:54 2013][debug] bad JSON: No answer from server.
[Sun Jan 27 16:16:56 2013][debug] running task NetInventory in process -176
[Sun Jan 27 16:16:56 2013][debug] No SNMPQuery requested in the prolog
[Sun Jan 27 16:16:56 2013][info] task NetInventory is not enabled

Voilà je ne comprends pas le problème, si vous pouviez m'aider ce serait sympa.
#2
T'as mis quoi dans la configuration du plugin FusionInventory?, y a un lien qui doit être paramétré quand tu va la première fois sur les pages du plugin
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
#3
Je viens de voir le log apache, apparemment il cherche les fichiers au mauvais endroit.

[Image: 1173977260.png]

Je ne comprends pas pourquoi il va chercher les fichiers à cet endroit.

Voici la configuration du module deploy sur le serveur :

URL d'accès au service : http://assistlab.galaxy-swiss.com/plugin...inventory/

J'ai utilisé la même URL lors de l'installation des clients (version des agents : fusioninventory-agent_windows-i386_2.2.7-3)

Dossier racine pour l'envoi de fichier depuis le serveur : /var/www/files/_plugins/fusinvdeploy/upload

Voilà, je n'y comprends rien. Mais je suis sûr que je suis au bon endroit pour obtenir des réponses ;p
#4
Ben si tu regarde la loupe (info bulle) tu verras qu'il faut mettre http://assistlab.galaxy-swiss.com et pas http://assistlab.galaxy-swiss.com/plugin...inventory/ dans l'URL d'accès au service
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
#5
Utilisez-vous bien FusionInventory for GLPI 0.83+2.1 et avez-vous entré l'adresse du serveur dans le champ "URL d'accès au service" de la Configuration Générale.
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
#6
ok je teste demain matin, et vous redis si ça corrige le problème. Merci à vous deux.
Bonne soirée
#7
Tip Top ça fonctionne parfaitement maintenant !

Je vous remercie de l'aide apportée.

Je vais maintenant m'atteler à l'authentification par l'AD...

Bonne soirée


Forum Jump:


Users browsing this thread: 1 Guest(s)