• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Résolu] Problème de dépendance à l'installation sous CentOS 5
#1
Bonjour,

Je viens d'installer l'agent FusionInventory sur une machine CentOS 5 toute neuve, en suivant cette procédure :

Ajout de EPEL à yum :
Code:
cd /root
wget http://download.fedoraproject.org/pub/epel/5/i386/epel-release-5-4.noarch.rpm
rpm -ivh epel-release-5-4.noarch.rpm

Ajout du Repository OpenSuse Build Service :
Code:
cd /etc/yum.repos.d/
wget http://download.opensuse.org/repositories/home:guillomovitch/CentOS_CentOS-5/home:guillomovitch.repo
cd
yum install fusioninventory-agent

Configurer l'agent (positionner server = http://monserveur/glpi/plugins/fusioninventory/, httpd-trust = 127.0.0.1, daemon = 1) :
Code:
vi /etc/fusioninventory/agent.cfg

Lancer l'agent :
Code:
service fusioninventory-agent start
Et là le service ne démarre pas en indiquant juste [Echec] Sad

En tapant la commande
Code:
fusioninventory-agent
j'ai le message d'erreur
Code:
[error] Can't load Proc::Daemon. Is the module installed?
Du coup j'ai installé le module qui n'avait pas voulu s'installer automatiquement :
Code:
yum install perl-Proc-Daemon
Et là le service a bien accepté de démarrer, plus de problème Smile

Hope it can help,
Marc
GLPI 9.4.4 - Fusioninventory for GLPI 9.4+1.0 - Fusioninventory Agent 2.5.1
  Reply
#2
+1 pour XENSERVER 6.1
- EyesOfNetworks 3.0 (CentOS) & XenServer x64 6.1
- glpi 0.84.80
- fusioninventory-for-glpi- 0.84+3.2
- fusioninventory-agent_2.3.15
  Reply
#3
Merci, ça "help" bien !
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)