• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
mauvaise entité lors de la remontée de logiciel.
#1
Bonjour,

je suis en FI 0.83+2.3 et glpi 0.83.91

Depuis la migration sur FI 0.83+2.3, les logiciels sont remontés parfois dans la bonne entité (celle du PC) et parfois dans l'entité racine.

J'ai essayé d'influencer l'entité des logiciels à l'aide des règles d'inventaire sur les entités, mais elles n'ont plus d'influence sur l'entité de destination des logiciels lors de l'import.

Est ce que quelqu'un rencontre ce problème? ou aurait une solution?

Merci d'avance.

PS. les PCs sont remontés dans les bonnes entités
GLPI 0.84.8 / FusionInventory 0.84+3.5 / Agent 2.3.16 / serveur wamp 2.4 / MS serveur 2008 R2
  Reply
#2
Y avait déjà le soucis en 0.83+2.x
Ca vient du fait que les machines bougent d'entité je crois
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#3
Existe t il une solution ou un correctif pour ce problème?
GLPI 0.84.8 / FusionInventory 0.84+3.5 / Agent 2.3.16 / serveur wamp 2.4 / MS serveur 2008 R2
  Reply
#4
ben normalement, c'est mieux géré en 084 (GLPI 0.84 ne va pas trop tarder)
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#5
- Je ne peux donc pas espérer un solution sur la 0.83?
- 084 est il compatible avec l'agent 2.1.12-1?
- As tu une date le libération prévue pour la 084?
GLPI 0.84.8 / FusionInventory 0.84+3.5 / Agent 2.3.16 / serveur wamp 2.4 / MS serveur 2008 R2
  Reply
#6
* Ben faudrait que je regarde en 0.83. Essaye de supprimer la ligne dans glpi_plugin_fusinvinventory_libserialization correspondant à l'ID de ton pc et relance un inventaire

* 084 est compatible avec l'agent 2.1 oui

* GLPI 0.84 devrait arriver très très prochainement
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#7
Je ne comprend pas très bien ce que tu veux dire par:
Essaye de supprimer la ligne dans glpi_plugin_fusinvinventory_libserialization correspondant à l'ID de ton pc et relance un inventaire

à quoi correspond "glpi_plugin_fusinvinventory_libserialization" ?
GLPI 0.84.8 / FusionInventory 0.84+3.5 / Agent 2.3.16 / serveur wamp 2.4 / MS serveur 2008 R2
  Reply
#8
ah pardon, je suis allé trop vite, c'est une des tables MySQL
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#9
J'ai effacé la ligne d'un PC dans la table glpi_plugin_fusinvinventory_libserialization et refait un inventaire mais j'ai toujours le même problème.

Certains logiciels sont remontés dans_
- l'entité racine
- dans une fausse entité
- dans l'entité correcte (celle du PC).
GLPI 0.84.8 / FusionInventory 0.84+3.5 / Agent 2.3.16 / serveur wamp 2.4 / MS serveur 2008 R2
  Reply
#10
Sad ça ne va pas être simple à corriger en 0.83
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#11
OK j'attends sur la sortie de la 0.84
J'ai maintenant un environement test, je vais essayer la version beta de 0.84

Merci dans tous les cas pour ton aide
GLPI 0.84.8 / FusionInventory 0.84+3.5 / Agent 2.3.16 / serveur wamp 2.4 / MS serveur 2008 R2
  Reply
#12
Ah oui ça c'est top Wink

le plugin est releasé mais glpi est encore en RC
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#13
Pour installer 0.84+1.0 depuis 0.83+2.3, j'ai désactivé les plugins:

FusionInventory
FusionInventory INVENTORY
FusionInventory SNMP
Déploiement FusionInventory

ensuite effacer les répertoire corresponants sur le serveur

Copié à la place le répertoire fusioninventory 0.84+1.0

Démarré GLPI --> Le statut de fusioninventory est "mettre à jour"

Main dans les celules ou je dois selectionner une action sur la ligne de fusiononventory celles-ci sont vides. Donc je ne peux plus rien faire sur le plugin FI

Comment régler ce problème
GLPI 0.84.8 / FusionInventory 0.84+3.5 / Agent 2.3.16 / serveur wamp 2.4 / MS serveur 2008 R2
  Reply
#14
T'as une capture d'écran s'il te plait?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#15
Voici la capture demandée:

[Image: radA0EE2.jpg]
GLPI 0.84.8 / FusionInventory 0.84+3.5 / Agent 2.3.16 / serveur wamp 2.4 / MS serveur 2008 R2
  Reply
#16
Ca c'est bizarre Sad
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#17
pour info supplémentaire.

GLPI m'a demandé dans la liste des plugin de désinstaller le plugin "Déploiement FusionInventory" que de toute façon je n'utilise pas
GLPI 0.84.8 / FusionInventory 0.84+3.5 / Agent 2.3.16 / serveur wamp 2.4 / MS serveur 2008 R2
  Reply
#18
Active le mode debug dans tes préférences et reviens sur la page, on dirait que t'as une erreur, ça permettra de l'afficher
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#19
voici l'erreur:

Fatal error: Call to undefined function __() in C:\xampp\htdocs\glpi\plugins\fusioninventory\setup.php on line 544
GLPI 0.84.8 / FusionInventory 0.84+3.5 / Agent 2.3.16 / serveur wamp 2.4 / MS serveur 2008 R2
  Reply
#20
Euh t'es sur que t'es sur un GLPI 0.84 ?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#21
OK c'est pour ma pomme j'ai pas upgradé GLPI.

Alors que faut il faire en premier? upgrader GLPI et ensuite FI?

ou tout en même temps et ensuite installer.

(Je dois en plus controler la compatibilité de mes autres plugins)
GLPI 0.84.8 / FusionInventory 0.84+3.5 / Agent 2.3.16 / serveur wamp 2.4 / MS serveur 2008 R2
  Reply
#22
oui GLPI en premier, fusion après (puisque c'est un plugin)
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#23
OK je fais l'installation et ensuite te donne des nouvelles concernant la remontée des Logiciel et leur entité avec 0.84.
GLPI 0.84.8 / FusionInventory 0.84+3.5 / Agent 2.3.16 / serveur wamp 2.4 / MS serveur 2008 R2
  Reply
#24
En faisant l'installation de flpi 084, je remarque que la majorité des plugins que j'ai installé ne sont pas compatible avec 084.

Cela signifie qu'une mise en production de cette version 084 pour moi n'est pas pensable avant que tous les plugins que j'ai installé soit compatibles. (dans une année peut-être)

n'est il possible de revenir en dessous de FI 0.83+2.x depuis FI .83+2.3 en plus en restant en GLPI 0.83.91 car j'imagine très dificilement de pouvoir vivre encore des mois sans la gestion correcte des logiciels et de leur entité.


merci d'avance pour ton aide.
GLPI 0.84.8 / FusionInventory 0.84+3.5 / Agent 2.3.16 / serveur wamp 2.4 / MS serveur 2008 R2
  Reply
#25
ah mince :/

Logiquement tu peux revenir en 0.83+2.2, car pas eu de modif de base pour la 0.83+2.3
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)