• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
probleme d'upgrade en 2.3.6
#1
Bonjour a tous,

Je viens d'upgrader l'agent en version 2.3.6 sur différentes machines qui étaient en version 2.3.5
pour l'upgrade , j'utilise une tache de déploiement de FusionInventory

depuis, les machines upgradées ne communique plus avec le GLPI

si, sur une des machines upgradées, je lance manuellement l'agent
Code:
C:\>"c:\Program Files\FusionInventory-Agent\fusioninventory-agent.bat"

Perl lib version (5.18.2) doesn't match executable 'fusioninventory-agent' version (v5.18.1) at c:/Program Files/FusionInventory-Agent/perl/lib/Config.pm line 62.
Compilation failed in require at c:/Program Files/FusionInventory-Agent/perl/lib/lib.pm line 6.
BEGIN failed--compilation aborted at c:/Program Files/FusionInventory-Agent/perl/lib/lib.pm line 6.
Compilation failed in require at fusioninventory-agent line 5.
BEGIN failed--compilation aborted at fusioninventory-agent line 5.

Avez vous une idée sur la cause du problème ?
  Reply
#2
L'upgrade de lui même avec le module deploy ne fonctionne pas, donc c'est normal
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#3
Bonjour,

j'ai fait les upgrades depuis cette petite proc sous windows en ayant transféré les installers dans le dossier c:\packages\fusion:

Code:
rem ***********************   Version 32 ou 64 ?
if %PROCESSOR_ARCHITECTURE%==AMD64 (set installeur=fusioninventory-agent_windows-x64_2.3.6.exe)
if %PROCESSOR_ARCHITECTURE%==x86 (set installeur=fusioninventory-agent_windows-x86_2.3.6.exe)

rem ************************   Installations
:instal
c:\packages\fusion\%installeur% /acceptlicense  /installtasks=Full /installtype=from-scratch /execmode=Service /runnow /server='http://xxx.xxx.xxx.xxx/glpi/plugins/fusioninventory/' /S

:end
cd \

Le seul hic, c'est qu'il installe la version 32 bits.. de temps en temps.. en fait .. souvent Sad
mais les agents communiquent correctement
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)