• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
bad JSON: jobs/actions must be an array
#1
Bonjour,

La fonction de déploiement marchait bien jusqu'à ce que je force l'arrêt d'une tâche. Depuis ce temps, les agents restent en mode "préparé" lorsque je force l'exécution d'une tâche de déploiement. En mode debug en console sur un des serveurs clients, j'obtiens ce qui suit en boucle:

...
[debug] Running FusionInventory::Agent::Task::Inventory::Virtualization
[debug] Running FusionInventory::Agent::Task::Inventory::Virtualization::Vmsystem
[debug] [http client] Using Compress::Zlib for compression
[debug] running task Deploy in process 32303
[debug] bad JSON: jobs/actions must be an array

J'utilise GLPI 0.84.3 + fusion pour GLPI 0.84+1.2 + l'agent fusion 2.3.5.1 .
  Reply
#2
Met à jour en 0.84+2.2
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#3
Je viens de mettre à jour le plugin fusion pour GLPI à 0.84+2.2 et j'ai toujours le même problème. Pour le débogage, j'ai désactivé le 2ème serveur GLPI qui se trouve dans la config de l'agent du client avec lequel je débogue. Une chose que je trouve curieuse est que ça boucle avec plusieurs numéros de tâches de déploiement distinctes alors qu'il n'y a qu'une seule tâche de déploiement active que j'ai forcé via l'interface web. Se pourrait-il que ce soit les anciennes tâches dont j'ai forcé l'arrêt et qui me cause mon problème actuel..?

J'aurais aimé mettre un bout du output que j'ai en mode débug (incluant 2 numéros différents pour les messages "running task Deploy in process") mais la contrainte du forum "Too more links in message. Allowed 1 links. Reduce number of links and post it again." m'empêche de le faire. J'ai essayé de trouver et de supprimer les bouts qui pourraient ressembler à un "link" mais j'ai fini par abandonner (après plus de 10 minutes sans succès)..
  Reply
#4
Je viens de faire un test en désactivant le serveur GLPI principal de la config de l'agent et en mettant le serveur secondaire avec lequel je n'avais jamais fait de tâches de déploiement et, après avoir conçu un paquet puis une tâche, j'ai la même erreur.
  Reply
#5
essaye de recréer la tache, recréer le package
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#6
Ça fonctionne bien après avoir recréé la tâche, merci.
  Reply
#7
super Wink
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)