• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
TLSv1.2 Alert - Unknown CA, error 500 can't connect to myglpisrv:443
#1
Hi,
I'm trying to set up FusionInventory Agent with SSL and I can't get it to work. The log shows:
[error] [http client] communication error: 500 Can't connect to myglpisrv.local:443

there's no more connectivity issues other than Wireshark says:
TLSv1.2 - Alert (Level: Fatal, Description: Unknown CA)

How can I troubleshoot?

I did use this - openssl x509 -inform der -in myglpisrv.local.cer -out myglpisrv.local.pem
Best regards, Olo

Latest stable versions of GLPI+FI+OCS on Apache/2.2.15 (Unix) | CentOS 6.x x64 (epel, remi, remi-php55, remi-safe, home_guillomovitch) | AD w2k8R2, w7 (x64), FusionInventory Agent 2.3.18, FusionInventory 0.90+1.4
  Reply
#2
Put debug=3 (or --debug --debug --debug) to have ssl log
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#3
I'm not sure if I understood you right. I use this command line to install under w7:
fusioninventory-agent_windows-x64_2.3.8.exe /S /acceptlicense /add-firewall-exception /ca-cert-file="%ProgramFiles%\FusionInventory-Agent\perl\bin\myglpisrv.local.pem" /execmode=Service /server="https://myglpisrv.local/glpi" /no-p2p /runnow. The installation process completes without errors.

Adding /debug=3 stops the installation, /debug=2 works OK though. According to the documentation: 2 stands for Full debug.
Best regards, Olo

Latest stable versions of GLPI+FI+OCS on Apache/2.2.15 (Unix) | CentOS 6.x x64 (epel, remi, remi-php55, remi-safe, home_guillomovitch) | AD w2k8R2, w7 (x64), FusionInventory Agent 2.3.18, FusionInventory 0.90+1.4
  Reply
#4
Using server's certificate apparently was a bad idea. I had to do this:
copy MyCompany-Root-CA.crt+MyCompany-Sub-CA.crt MyCompany-CAs.pem

The server's certificate was issued by MyCompany-Sub-CA.

Now, skip to the next error.
Best regards, Olo

Latest stable versions of GLPI+FI+OCS on Apache/2.2.15 (Unix) | CentOS 6.x x64 (epel, remi, remi-php55, remi-safe, home_guillomovitch) | AD w2k8R2, w7 (x64), FusionInventory Agent 2.3.18, FusionInventory 0.90+1.4
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)