• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
probleme remontée agent et cron
#1
Bonjour,

Voici ma config :

FusionInventory 0.84+3.1
FusionInventory Agent (2.3.9.1)

Le tout sur un même serveur ubuntu 10.04

Je cherche a automatiser les remotées snmp de mes imprimantes.
Decouverte ok
Remontées ok lorsque je lance l'agent manuellement (sudo fusioninventory-agent)

Dès lors que je planifie le lancement de l'agent via cron ( 0 */1 * * * root /usr/local/bin/fusioninventory-agent )

L'agent se lance bien mais la tache reste en cours d'execution sans qu'il ne se passe rien et au bout de quelques heures j'ai comme résultat : "Erreur Agent arrêté/crashé"

Lorsque je regarde les logs de l'agent, on dirait que les threads ne s'initialisent pas contrairement a quand je lance l'agent manuellement...

J'avoue que je seche un peu...

Julien
  Reply
#2
Voici la fin du log de l'agent lancé en cron :

<REPLY>
<OPTION>
<NAME>SNMPQUERY</NAME>
<PARAM CORE_QUERY="1" THREADS_QUERY="200" PID="2730">
</PARAM>
<DEVICE TYPE="PRINTER" ID="1249" IP="@ip" AUTHSNMP_ID="2" MODELSNMP_ID="0">
</DEVICE>
...
<DEVICE TYPE="PRINTER" ID="1157" IP="@ip" AUTHSNMP_ID="1" MODELSNMP_ID="0">
</DEVICE>
<AUTHENTICATION ID="1" VERSION="1" COMMUNITY="xxxx">
</AUTHENTICATION>
</OPTION>
<PROLOG_FREQ>12</PROLOG_FREQ>
</REPLY>


Et puis rien ne se passe après ca.
Dans le résumé de la tache dans glpi j'ai ca :

---------------------------------------------------------------------------------------------------------------
25-08-2014 20:55 Préparé
agent-2014-07-23-13-58-26 25-08-2014 21:00 Démarré 200 threads
Périmètre(60) 26-08-2014 00:56 Erreur Agent arrêté/crashé
---------------------------------------------------------------------------------------------------------------

Par contre lorsque je lance l'agent manuellement les différentes taches se lancent normalement
Et la tache Netinventory s'effectue correctement
  Reply
#3
déjà passe de 200 a 100 Threads, puis t'as rien du tou du tout dans les logs après ça?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#4
J'ai essayé de changer le nombre de threads mais ca ne change rien. D'autant plus qu'avec 200 et en lancant l'agent manuellement tout fonctionne.

Non je n'ai plus rien dans les logs comme si les taches ne se lancaient pas.
  Reply
#5
Aujourd'hui test de l'agent avec 100 threads :

Il crash encore plus tot.

Je metterai bien le log complet mais a chaque fois le forum répond qu'il y a trop de lien dans mon message (meme si je met des balise code)

Quand ca veut pas ...

Du coup juste la fin :

<REQUEST>
<DEVICEID>agent-2014-07-23-13-58-26</DEVICEID>
<QUERY>PROLOG</QUERY>
<TOKEN>12345678</TOKEN>
</REQUEST>
*Tue Aug 26 21:00:05 2014**debug2* format: Zlib
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)