• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SNMP Inventory for printers doesn't work
#1
Hi, all!
Sorry for my worst english.
Agent version: FusionInventory Agent (2.3.10.1)
GLPI version: 0.84.7
After task Netdiscovery (succesfully complete), i'm run task SNMP inventory (for printer), but agent ignore it.
To agent log add this line:
[Wed Aug 6 10:56:55 2014][debug] [server] request /status from client 127.0.0.1
Common debug log:

[Wed Aug 6 11:17:58 2014][debug] Time to call Proc:Big Grinaemon
[Wed Aug 6 11:17:58 2014][debug] Daemon started
[Wed Aug 6 11:17:58 2014][debug] Available tasks:
[Wed Aug 6 11:17:58 2014][debug] - ESX: 2.2.1
[Wed Aug 6 11:17:58 2014][debug] - Inventory: 1.0
[Wed Aug 6 11:17:58 2014][debug] - NetInventory: 2.2.0
[Wed Aug 6 11:17:58 2014][debug] - WakeOnLan: 2.0
[Wed Aug 6 11:17:58 2014][debug] - NetDiscovery: 2.2.0
[Wed Aug 6 11:18:03 2014][info] [server] HTTPD service started at http://localhost:62354
[Wed Aug 6 11:18:03 2014][debug] FusionInventory Agent initialised

Need help Smile
  Reply
#2
How you have configurer your task?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#3
Screen: http://s019.radikal.ru/i635/1408/bb/00ad950785ea.png
  Reply
#4
click on reinitialize, seems task broken (it will reset it with this action )
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#5
Unfortunately, reinitialize does not help.
  Reply
#6
This task not running on agent by normal planning mode. Only "force start" get reaction on agent such as:
Wed Aug 6 10:56:55 2014][debug] [server] request /status from client 127.0.0.1
  Reply
#7
perhaps server url on agent is not right
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#8
ddurieux Wrote:perhaps server url on agent is not right

server = http://my-domain.ru/plugins/fusioninventory/

Task discovery working normally, strange...
  Reply
#9
:p
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#10
ddurieux Wrote::p
Any idea? Smile
  Reply
#11
php-errors.log:

2014-08-08 15:01:09
Notice(8): Undefined index: Printer
Backtrace :
/var/www/my-domain.ru/plugins/fusioninventory/inc/networkinventory.class.php:478 Toolbox::userErrorHandlerNormal()
/var/www/my-domain.ru/plugins/fusioninventory/inc/taskjob.class.php:2433 PluginFusioninventoryNetworkinventory->prepareRun()
/var/www/my-domain.ru/plugins/fusioninventory/inc/taskjob.class.php:1334 PluginFusioninventoryTaskjob->prepareRunTaskjob()
/var/www/my-domain.ru/plugins/fusioninventory/front/task.form.php:56 PluginFusioninventoryTaskjob->forceRunningTask()

This strings add to log file everytime after force exec SNMP inventory task.
May need any more logs?
  Reply
#12
Hello, I have exactly the same problem. Netdiscovery is running fine. It is discovering my printers and inserts them in Assets->Printers. But then when I would like to run the Network inventory, the only thing I get is a "Reinitialization" button. I can do whatever I want that is the only reaction I get. It seem that I'm missing something. I searched for a solution but could not find anything. I got the same PHP errors with the 2.2 version, but they vanished with the 3.5 version. So I'm using 0.84+3.5 with fusioninventory-agent-2.3.12.

PLEASE HELP Smile
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)