• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SNMP Inventory Issue
#1
What is the best way to trouble shoot SNMP inventory problems with Fusion Inventory?

I have two Avaya 5650 switches on the same VLAN. One switch works perfectly and shows model, firmware, location and all ports. The other switch does not show model, location, or firmware and only shows 1 port. When I do an snmp scan with another tool, it shows everything correctly.

I also have a lot of Lexmark Laser Printers and some show up but most do not. I have ran snmp scan on the printers that don't show up and I get the correct information. It is only is fusion inventory that I get nothing returned. I created an IP range with 1 address of a Lexmark Printer. Network discovery shows 0 items found. Network inventory shows no suitable devices to inventory.

Any guidance would be greatly appreciated.
  Reply
#2
Just an update as I am still trying to get this to work, the fusioninventory-agent log does show the model, location, and firmware but that information is never uploaded into glpi. I still don't show any other ports on that switch.

As for the printers, the following in part of the fusioninventory-agent log when I run a netdicovery. However, the log under tasks on the glpi server shows zero entries found.
[Wed Oct 22 09:41:08 2014][debug] Thread 28 switched to RUN state
[Wed Oct 22 09:41:08 2014][debug] thread 28: scanning 172.25.13.229...
[Wed Oct 22 09:41:08 2014][debug] thread 28: scanning 172.25.13.229 with netbios: no result
[Wed Oct 22 09:41:08 2014][debug] full match for sysobjectID .1.3.6.1.4.1.641.1.71106749 in database
[Wed Oct 22 09:41:08 2014][debug] thread 28: scanning 172.25.13.229 with snmp credentials 2: success
[Wed Oct 22 09:41:08 2014][debug] Thread 28 switched to STOP state
[Wed Oct 22 09:41:09 2014][debug] Thread 28 deleted
[Wed Oct 22 09:41:09 2014][debug2] [http client] sending message:
<?xml version="1.0" encoding="UTF-8" ?>
<REQUEST>
<CONTENT>
<AGENT>
<END>1</END>
</AGENT>
<MODULEVERSION>2.2.0</MODULEVERSION>
<PROCESSNUMBER>26</PROCESSNUMBER>
</CONTENT>
<DEVICEID>KTRSWKSTA118.KTRSNT.Local-2014-10-21-12-52-35</DEVICEID>
<QUERY>NETDISCOVERY</QUERY>
</REQUEST>
[Wed Oct 22 09:41:09 2014][debug2] format: Zlib
[Wed Oct 22 09:41:09 2014][debug2] [http client] receiving message:
<?xml version="1.0" encoding="UTF-8"?>
<REPLY>
</REPLY>
  Reply
#3
Printers are being inventoried now that I have built a linux box just to run network discovery and network inventory. Apparently, even though you can install and run the modules on windows devices, it is not reliable.

Still have issues with the network switch not being inventoried like the other switches.

Windows agent seems to be hit or miss on Windows 7 machines. About 1/2 of the machines we are testing gets dmidecode bad file descriptor errors. Not sure how to go about trouble shooting it. If I run DMIDECODE from a command line, I have no issues and all bios information is returned. The agent fails every time.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)