• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Résolu]Remontée logiciels "supprimés" après installation PhotoshopCS2
#1
Bonjour,

Nous utilisons actuellement la version 0.83+2.1 de Fusion couplée à GLPI 0.83.7 (je sais, c'est pas tout jeune ..).

Nous rencontrons la problématique suivante :
- sur un poste en particulier (les autres postes fonctionnent correctement), nous lançons un inventaire Fusion ==> Import OK
- l'utilisateur se connecte, une mise à jour de l'inventaire est faite ==> l'import ne comporte plus les logiciels (hormis l'OS) et donc tous les logiciels dans GLPI sont "désinstallés".
- nous avons essayé de
- désinstaller / réinstaller Fusion ==> Pb identique : pas de logiciel de remonté.
- suppression de poste dans GLPI ==> Pb identique : pas de logiciel de remonté.
- désinstallation du plugin Fusion pour faire un inventaire "manuel" ==> Pb identique : pas de logiciel de remonté dans le fichier xml.
- nous avons réinstallé le poste ==> Pb identique : pas de logiciel de remonté dans le fichier xml.

Bizarrement, cette problématique semble liée à l'utilisateur qui est connecté.

Savant que le pare feu est désactivé, qu'il s'agit d'un poste sous Windows 7, qu'est ce qui peut empêcher un inventaire des logiciels (le reste de l'inventaire est OK (matériel, profil connecté, etc ...)) ?

Merci d'avance pour votre aide.

EDIT : après plusieurs tests, le problème survient après l'installation de Photoshop CS2. En le désinstallant, tout refonctionne et le ré-installant ....... plus de remontées de logiciel Sad
#2
L'agent est installé en mode daemon avec un compte administrateur ?

Quelle version de l'agent est installé?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
#3
Bonjour,

L'agent est bien installé et éxécuté avec un compte admin.

La version est 0.83+2.1.

Pour faire les test, j'ai désinstallé Fusion est l’exécute à partir d'une clé USB avec un compte Admin.
Je n'arrive pas à voir ce que modifie Adobe Photoshop CS2 qui empêche Fusion de remonter les logiciels (dons d'attaquer en lecture la base de registre).

Merci de votre aide.
#4
Fait un inventaire avec xml lcoal surla machine pour voir si dans ce fichier xml il y a bien tous les logiciels
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
#5
Avec un inventaire manuel, dans le fichier xml, j'ai la même problématique :

Adobe photoshop CS2 non installé ==> fichier XML complet
Adobe photoshop CS2 installé ==> Fichier XML incomplet (manque toute la partie software).
#6
Donc il y a bien un soucis, tu as bien la dernière version de l'agent, la 2.3.12?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
#7
Non, nous sommes en 2.2.7-3.
Le problème est que si nous souhaitons monter en version, je pense que GLPI doit également monter, non (nous sommes en GLPI 0.83.7.....) ?

Je vais essayer la version 2.3.12 en xml local, histoire de voir.

Merci.
#8
essaye en local déjà pour voir, mais la 2.3.12 est compatible avec un plugin fusion 0.83
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
#9
Bonjour,

J'ai essayé en local avec la version 2.3.12 ==> ça fonctionne Smile
J'ai installé la version cliente 2.3.12 et l'ai fait communiquer avec le serveur ==> Pas de pb de remontée.

IL me reste donc à faire évoluer Fusion serveur sur GLPI en version 2.3.12 et voir comment déployer la nouvelle version sur l'ensemble des postes (via gpo je pense) sur les postes ayant déjà Fusion INventory sans toucher au TAG.

Mais ça c'est un autre sujet....

Je passe le sujet en Résolu.

Merci.
#10
Pour déployer la mise à jour de l'agent 2.3 par dessus une version 2.2 via une GPO, tu peux t'inspirer de mon script disponible dans le sujet suivant :
http://forum.fusioninventory.org/viewtopic.php?id=2535

Je l'ai utilisé sur plusieurs sites sans souci, mais je n'utilise qu'un seul TAG par site, je le code donc en dur dans mon script VBS avec la ligne :
TagArg = "/tag=montag".

Tu dois pouvoir récupérer dynamiquement le TAG dans la base des registres de la même façon que je repère si une version 2.2 est installée.
GLPI 9.4.4 - Fusioninventory for GLPI 9.4+1.0 - Fusioninventory Agent 2.5.1


Forum Jump:


Users browsing this thread: 1 Guest(s)