• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Modules de l'agent non remontés [RESOLU]
#1
Bonjour à tous,

je suis en train d'essayer la tache "deploy" de glpi, je savais pas du tout comment je pouvais m'y prendre .

du coup j'ai jeté un coup d'oeil ici --> http://jgaborieau.files.wordpress.com/20...y-glpi.pdf

j'ai eu les grande lignes, parfait .

en revanche coté serveur j'avais pas le paquet "fusioninventory-agent-task-deploy", du coup -->
Code:
apt-get install fusioninventory-agent-task-deploy

Code:
root@glpi-migration:~# dpkg -l | grep fusion
ii  fusioninventory-agent                           1:2.3.5.1-1                   amd64        Hardware and software inventory
ii  fusioninventory-agent-task-deploy               1:2.3.5.1-1                   all          Software deployment support for
ii  fusioninventory-agent-task-esx                  1:2.3.5.1-1                   all          ESX and ESXi inventory
ii  fusioninventory-agent-task-network              1:2.3.5.1-1                   all          Network device discovery for Fu
ii  libfusioninventory-agent-task-snmpquery-perl    1:2.3.5.1-1                   all          transitional dummy package

mais quand je vais dans GLPI --> plugin --> fusionInventory --> Géneral --> gestion des agents --> ( filtre sur mon serveur glpi ) --> je n'ai que :

[Image: 8vnda3.png]

Pourtant ici tout est coché :

[Image: eC1JPM.png]

j'ai relancé l'agent avec
Code:
/etc/init.d/fusioninventory-agent restart

et toujours rien...

m'voyez ??
  Reply
#2
dans les dernières versions, ça ne remonte plus la liste des modules de l'agent, don cil ne faut pas s'y fier
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#3
merci david ,
j'ai écrit ce post car quand je lance l'action de déploiement d'un paquet, il ne se passe absolument rien.
vous savez, quand on force une action, dans fusion, il y a toujours une ligne avec le statut de la tâche.
donc je pensais qu'il n'y avait rien car le nom du module n'apparaissait pas.
je ne sais pas si je suis très claire dans mes explications...
  Reply
#4
[Image: 385509CaptureDeploy.png]

Donc, voila la version illustrée Smile

Je clique sur Forcer, il ne se passe rien .

je pensais que rien ne se passait car je n'avait pas de modules remontés avec l'agent .

mais ça vient pas de là apparemment .

dans les logs d'apache, je ne vois pas grand chose .
J'ai supprimé l'agent de glpi, puis j'ai refais un inventaire, mon agent est revenu dans GLPI, mais ca ne marche pas plus pour autant .
  Reply
#5
Supprime la tache et essaye d'en recréer une
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#6
Pareil Sad
  Reply
#7
Je precise que j'utilis les taches d'inventaires etc... eux fonctionnent bien
  Reply
#8
Bonjour tout le monde,

savez vous ou si il existe des logs dans fusion ?

car j'ai désinstallé fusion-for-glpi et réinstallé,
Du coup, j'ai du reconfigurer tout fusion pour glpi ( les taches, les communautés snmp ... )

rien n'y fait, la tache d’exécution de déploiement de paquetage ne se lance pas .

Est ce qu'il y a des personnes qui utilisent la version 0.84+3.5 de glpi et qui utilise le déploiement ?

Bonne journée

Cordialement
  Reply
#9
Bah oui déjà utilisé et ça fonctionne, je n'ai jamais eu ton cas là :/
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#10
merci pour la réponse David,
je vais activer les logs sql, et regarder ce qu'il se passe dans mysql.

tu penses que ça a un sens ?
  Reply
#11
Je pense avoir trouvé !!!

il faut que sur l'agent il y ait "déploiement de paquetage " ? de coché ?

là bizarrement, la tache se lance ...
  Reply
#12
Ça fonctionne !!!

je ne pensais pas qu'il fallait installé le module "deploy" sur les postes clients, je pensais que ce module servait à lancer la tache ( un peu comme l'agent de découverte LAN ).

J’espère que ce thread pourra aider d'autre personnes .

Merci en tout cas d'avoir pris le temps de me lire .

Bonne journée à tous
  Reply
#13
Ah c'était juste ça Wink
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)