• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Taches ne fonctionnent plus
#1
je me suis rendu compte qu'aucune tache ne fonctionne
j'etais passé a la version 0.85 mais comme la version du plugin de fusion
n'est pas encore prête je suis revenu à la version 0.84.8

J'ai retrouvé mon GLPI de prod mais je viens de me rendre compte
que les taches ne fonctionnent plus

Comment debugger ?
Merci

GLPI 0.90.5/ Plugins Fusion : 090+1.4 / Agent : 2.3.18 < Serveur Centos 64 Bits>
  Reply
#2
J'ai les anomalies suivantes dans le fichier log de l'agent
qui me bloque les agents ... J'ai plus de 100 lignes ...et cela a démarré le 13 Decembre ...
Je vérifie c'est après un scanning du réseau dur plusieurs plages d'adresses IP ...

[Sat Dec 13 13:25:02 2014][debug] [http server] response status 200
[Sat Dec 13 13:25:03 2014][debug] [http server] request /status from client 192.168.80.10
[Sat Dec 13 13:25:03 2014][debug] [http server] response status 200
[Sat Dec 13 13:30:03 2014][debug] [http server] request /status from client 192.168.80.10
[Sat Dec 13 13:30:03 2014][debug] [http server] response status 200
[Sat Dec 13 13:30:04 2014][debug] [http server] request /status from client 192.168.80.10
[Sat Dec 13 13:30:04 2014][debug] [http server] response status 200
[Sat Dec 13 13:35:03 2014][debug] [http server] request /status from client 192.168.80.10
[Sat Dec 13 13:35:03 2014][debug] [http server] response status 200
[Sat Dec 13 13:35:04 2014][debug] [http server] request /status from client 192.168.80.10
[Sat Dec 13 13:35:04 2014][debug] [http server] response status 200
[Sat Dec 13 13:40:02 2014][debug] [http server] request /status from client 192.168.80.10
[Sat Dec 13 13:40:02 2014][debug] [http server] response status 200
[Sat Dec 13 13:40:03 2014][debug] [http server] request /status from client 192.168.80.10
[Sat Dec 13 13:40:03 2014][debug] [http server] response status 200
[Sat Dec 13 13:45:03 2014][debug] [http server] request /status from client 192.168.80.10
[Sat Dec 13 13:45:03 2014][debug] [http server] response status 200
[Sat Dec 13 13:45:04 2014][debug] [http server] request /status from client 192.168.80.10
[Sat Dec 13 13:45:04 2014][debug] [http server] response status 200
[Sat Dec 13 13:50:02 2014][debug] [http server] request /status from client 192.168.80.10

[Sat Dec 20 13:45:01 2014][debug] [http server] response status 200
[Sat Dec 20 13:45:02 2014][debug] [http server] request /status from client 192.168.80.10
[Sat Dec 20 13:45:02 2014][debug] [http server] response status 200
[Sun Dec 21 13:14:35 2014][debug] [http server] request / from client 127.0.0.1
[Sun Dec 21 13:14:35 2014][debug] [http server] response status 200
[Sun Dec 21 13:14:36 2014][debug] [http server] request /site.css from client 127.0.0.1
[Sun Dec 21 13:14:36 2014][debug] [http server] response status 200
[Sun Dec 21 13:14:43 2014][debug] [http server] request /logo.png from client 127.0.0.1
Merci

GLPI 0.90.5/ Plugins Fusion : 090+1.4 / Agent : 2.3.18 < Serveur Centos 64 Bits>
  Reply
#3
J'ai basculer en GLPI et FUSIONINVENTORY en 0.85 ...

LA comprehension des taches n'est plus la meme
mais je ne sais pas comment arrêter une tache

J'ai une tache "en cours (Bleu)" mais depuis le 23/12 (Decouvert du réseau)
Comment l'arrêter ???
Merci

GLPI 0.90.5/ Plugins Fusion : 090+1.4 / Agent : 2.3.18 < Serveur Centos 64 Bits>
  Reply
#4
Elle est plantée?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#5
Non "en cours" mais je ne vois pas comment m'arrêter

J'ai regardé dans les actions automatiques et je n'ai plus de taches depuis le 20/12
20-12-2014 13:45 1.378 seconde 0 Action terminée, rien à faire
20-12-2014 13:40 1.539 seconde 0 Action terminée, rien à faire
20-12-2014 13:35 2.132 secondes 0 Action terminée, rien à faire

Est ce que le mode doit être CLI ou GLPI ?

Dans ma crontab j'ai toujours
*/5 * * * * /usr/bin/php /var/www/html/glpi/front/cron.php &>/dev/null
Merci

GLPI 0.90.5/ Plugins Fusion : 090+1.4 / Agent : 2.3.18 < Serveur Centos 64 Bits>
  Reply
#6
Elle doit être CLI
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#7
Je ne comprends pas les taches
j'ai "en cours" et "succès" mais je ne vois plus les mises à jour
que j'avais l'habitude de voir sur le materiel réseau

je ne vois que
54a13ae3b775b
2014-12-31 01:57:32 Démarré 1 threads
2014-12-29 15:28:35 Préparé
549993c740942

la difference est grande entre préparé et démarré ...


Je modifie une tache pour démarrer dans la minute mais je ne vois pas comment elle démarre
j'ai mis l'actualisation sur 5 secondes .... pour surveiller
Merci

GLPI 0.90.5/ Plugins Fusion : 090+1.4 / Agent : 2.3.18 < Serveur Centos 64 Bits>
  Reply
#8
après 'démarré', y a plus rien?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#9
il n'y a plus rien

Quel est le lien entre le taskscheduler
et la crontab
*/5 * * * * /usr/bin/php /var/www/html/glpi/front/cron.php &>/dev/null


J'ai bien les logs suivants
31-12-2014 14:15 0.046 seconde 0 Action terminée, traitement complet
31-12-2014 14:10 0.204 seconde 0 Action terminée, traitement complet
31-12-2014 14:05 0.049 seconde 0 Action terminée, traitement complet
31-12-2014 14:00 0.046 seconde 0 Action terminée, traitement complet
31-12-2014 13:55 0.046 seconde 0 Action terminée, traitement complet

Faut il mettre le tascheduler toutes les minutes !!!
Merci

GLPI 0.90.5/ Plugins Fusion : 090+1.4 / Agent : 2.3.18 < Serveur Centos 64 Bits>
  Reply
#10
c'est mieux toutes les minutes
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#11
Ce qui est bizarre c'est sur l'ouverture de "plugins" fusioniventory
le dasboard m'affiche à droite le nombre de tache succès , échec , préparé
qui change mais sur la ou les taches c'est "en cours (bleu) et succès (vert)"
en cliquant pour ouvrir c'est toujours les 2 lignes "en cours et démarré "
rien de plus ...
Merci

GLPI 0.90.5/ Plugins Fusion : 090+1.4 / Agent : 2.3.18 < Serveur Centos 64 Bits>
  Reply
#12
Je suis sur un agent ou toutes les taches on démarre mais après 2 jours de preparations !!!!
j'ai ensuite l'erreur ci dessous

2015-01-01 03:35:48 Erreur L'agent demande une configuration qui lui a déjà été envoyée par le serveur. L'agent est susceptible d'avoir rencontré une erreur critique
2014-12-31 01:57:32 Démarré 1 threads --------- LE 31 alors que j'avais modifié la date pour démarré avant ....

2014-12-29 15:28:35 Préparé

En regardant l'agent je suis la aussi dans un état ou il me dit ... running task ...

This is FusionInventory Agent 2.3.14
The current status is running task NetDiscovery
Force an Inventory
Next server target execution planned for: •http://xxx/plugins/fusioninventory/: Wed Dec 31 00:01:03 2014

mais j'ai la date de la prochaine execution
Merci

GLPI 0.90.5/ Plugins Fusion : 090+1.4 / Agent : 2.3.18 < Serveur Centos 64 Bits>
  Reply
#13
s'il est démarré, c'est que l'agent a contacté le serveur, donc il faudrait voir les logs de l'agent pour voir ce qu'il se passe
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#14
Comment justement debugger !!
Qaund ej change l'heure de debut de programmation je mets "maintenant + 2 minutes"
est ce que dans 2 minutes je dois el voir dans "prépare""

Quel est le fichier log qui me trace cela ?

Entre "preparé" et "En cours" dans quel fichier log je dois voir le changement ?

Comment mettre le log en route ?
Merci

GLPI 0.90.5/ Plugins Fusion : 090+1.4 / Agent : 2.3.18 < Serveur Centos 64 Bits>
  Reply
#15
Je suis perdu. "maintenant + 2 minutes" => t'as ça ou?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#16
Quand on veut modifier le "l'heure et le jour du debut de la tache"
on choisit le petit calendrier et le bouton et l'huere et les minutes

donc pour voir le déroulement je choisis "maintenant" pour avoir l'heure de suite
et je change les minutes à +2

Si "maintenant" me donne 13h40 je mets donc 13h42

Je peux ainsi voir das le monitoring des logs si je vois quelque chose
je programme le rafraichissement à 5 secondes et je regarde si pour la tache je vois "préparé" ... En cours ....

mais je ne vois rien de cela ...

Comment donc suivre une "debug" sur une tache qui doit donc se dérouler dans un timing
de "maintenant + 2 minutes" ..
Merci

GLPI 0.90.5/ Plugins Fusion : 090+1.4 / Agent : 2.3.18 < Serveur Centos 64 Bits>
  Reply
#17
Bonjour,

J'ai un peu le même problème avec une configuration similaire, les taches restent toujours en cours d'execution et coté agent debug niveau 2 j'ai ca :

"too much link, 1 link allowed, blabla"

La tache semble terminée mais aucune ligne l'indiquant dans le log et coté serveur, tache toujours en cours d'execution des heures apres la derniere ligne de log.
Je suis egalement sur Centos mais en x86, glpi 0.85.1 et plugin FI 0.85+1.0
  Reply
#18
Ah je n'avais jamais vu ce message dans l'agent
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#19
Il est 13H40 et depuis ce matin j'ai sur une tache
que l'état "préparé"

54ab57e55048c
2015-01-06 07:35:01 Préparé

Comment voir et ou voir ce qui doit se passer ?
Y a til un fichier de log sur le serveur ?
la machine est toujours en Waiting sur le http
et rien dans le log de l'agent ....
Merci

GLPI 0.90.5/ Plugins Fusion : 090+1.4 / Agent : 2.3.18 < Serveur Centos 64 Bits>
  Reply
#20
préparé = il attend que l'agent le contacte
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#21
C'est donc l'agent qui va déclencher la tache ?
je pensais que c'etait le serveur qui allait comme avant déclencher
l'agent pour la tache !!!

L'agent va demarrer ma tache quand dans mon réseau les machines
sont éteintes (imprimantes)
Car je vois que le prochain contact c'est pour 22h04 ce soir !!!!!!

Il me semblait qu'avant la tache démarré de suite (suivant l'heure programmé)
et que la repetition était aussi programmé (tous les 3 jours , meme heure)

Ce qui était plus sur d'avoir par exemple mes imprimantes d'allumés sur le réseau !!!!!
Merci

GLPI 0.90.5/ Plugins Fusion : 090+1.4 / Agent : 2.3.18 < Serveur Centos 64 Bits>
  Reply
#22
yep il manque un bout de code pour le réveil des agents :p
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#23
Peut on remettre le bouton "forcer le démarrage" ?
Merci

GLPI 0.90.5/ Plugins Fusion : 090+1.4 / Agent : 2.3.18 < Serveur Centos 64 Bits>
  Reply
#24
Y a til deja un bout de code ou il faut attendre la nouvelle version de l'agent
Merci

GLPI 0.90.5/ Plugins Fusion : 090+1.4 / Agent : 2.3.18 < Serveur Centos 64 Bits>
  Reply
#25
Non il n'est pas encore fait
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)