• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Version Client stable FusionInventory 0.84+3.5 ?
#1
Bonjour,

Je rencontre un problème sur les taches de découvertes réseau après une montée en version.

GLPI 0.84.8 (nous ne passons pas encore sur la version 0.85 puisque plusieurs plugins que nous utilisons ne sont pas encore compatibles).
Fusion 0.84+3.5
Clients Windows 7 avec fusioninventory-agent_windows-x86_2.3.15.

La tache planifiée "Découverte Réseau" a le statut "En cours".
Le fichier de log côté client indique :
..........
[Mon Mar 2 11:39:03 2015][debug] [thread 3] termination
[Mon Mar 2 11:39:15 2015][debug] [http server] request /status from client x.x.x.x
[Mon Mar 2 11:39:15 2015][debug] [http server] response status 200
[Mon Mar 2 11:39:16 2015][debug] [http server] request /status from client x.x.x.x
[Mon Mar 2 11:39:16 2015][debug] [http server] response status 200
[Mon Mar 2 11:40:10 2015][debug] [http server] request /status from client x.x.x.x
[Mon Mar 2 11:40:10 2015][debug] [http server] response status 200
[Mon Mar 2 11:40:11 2015][debug] [http server] request /status from client x.x.x.x
[Mon Mar 2 11:40:11 2015][debug] [http server] response status 200
[Mon Mar 2 11:41:10 2015][debug] [http server] request /status from client x.x.x.x
[Mon Mar 2 11:41:10 2015][debug] [http server] response status 200
[Mon Mar 2 11:41:11 2015][debug] [http server] request /status from client x.x.x.x
[Mon Mar 2 11:41:10 2015][debug] [http server] response status 200


C'est comme si la tâche fonctionnait correctement (au travers du log, les actions demandées sont bien effectuées) mais qu'à la fin, le client demandait au attentait une commande du serveur pour soit envoyer le résultat, soit clôturer la tâche ou quelque chose comme ça.

J'ai testé avec la version client 2.3.14,2.3.13, 2.3.8 ==> même problème.

Avec la version 2.2.7, la tâche fonctionne correctement.

Comme il y a plus de paramètres possibles entre la version 2.2 et la version 2.3, peut être que j'en ai oublié un ; voici ceux qui sont renseignés :

[HKEY_LOCAL_MACHINE\SOFTWARE\FusionInventory-Agent]
"backend-collect-timeout"="180"
"ca-cert-dir"=""
"ca-cert-file"=""
"debug"="2"
"delaytime"="3600"
"html"="0"
"httpd-ip"="0.0.0.0"
"httpd-port"="4440"
"httpd-trust"="127.0.0.1/32,10.0.0.0/32"
"local"=""
"logfile"="C:\\Program Files\\FusionInventory-Agent\\fusioninventory-agent.log"
"logfile-maxsize"="16"
"logger"="File"
"no-category"=""
"no-httpd"="0"
"no-p2p"="0"
"no-ssl-check"="1"
"no-task"=""
"password"=""
"proxy"=""
"server"="https://frsrvglpi03/glpi/plugins/fusioninventory/"
"scan-homedirs"="0"
"tag"="TEST"
"timeout"="180"
"user"=""

Merci d'avance pour votre aide.
  Reply
#2
Bonjour,

J'avance un petit peu :

Avec une version cliente 2.2, la découverte réseau sur une plage IP de 255 se passe bien.
Avec la version 2.3.8, ça fonctionne mais avec une plage d'Ip de 10 Ip.
Avec la dernière version du client, d'après le log, l'agent plante à la fin de la découverte.
  Reply
#3
je suis revenu avec une version 2.3.5 pour que mes tâches decouverte reseau, inventaire réseau, et inventaire vmware fonctionnent

Cdlt
  Reply
#4
Bonjour stanislas93,

Merci pour ce retour.

Je viens de faire des tests et pour moi, c'est toujours pareil, l'agent ne répond plus (ou pas correctement) et la tache se plante.
J'ai testé toutes les versions 2.3.x (y compris la 2.3.16) et toujours pareil.

Je pense installer sur les postes qui serviront de relais la version 2.2.7 et la 2.3.15 sur les postes qui auront un inventaire local, en attendant qu'une version stable (peut être la 2.4 ?) ne sorte (je ne sais pas se que apporte la version 2.3.16).

Etant toujours dans les tests, si quelqu'un à une autre piste ....

Merci.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)