• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
agent fusion 2.3.15 sous linux
#1
Bonjour

J'ai remis en place une archi Glpi/Fusion avec Glpi 0.85.2 et fusion 0.85 1+1 avec la version de l'agent 2.3.15 sous linux debian wheezy en m'appuyant sur votre dépot. Tout s'installe bien mais le service fusioninventory se lance mais ne s'arrête pas. /etc/init.d/fusioninventory-agent stop n'arrête pas le process.


/etc/init.d/fusioninventory-agent stop
Stopping fusioninventory-agent: fusioninventory-agent.

root@serveur-linux:~# /etc/init.d/fusioninventory-agent status
[FAIL] fusioninventory-agent is not running ... failed!

Alors qu'il tourne bien, il y a l'ai d'avoir un probleme de creation du pid dans /var/run

root@serveur-linux:~# ps wwaux | grep fusion
root 5993 0.0 2.4 16244 12468 ? S 12:01 0:04 /usr/bin/perl /usr/bin/fusioninventory-agent -d
root 13940 0.0 0.1 3568 812 pts/1 S+ 16:44 0:00 grep fusion

On final on voit bien l'agent dans la gestion des agents sous Glpi/Fusion par contre il n'inventorie pas mon serveur dans parc/ordinateur impossible d'avoir l'inventaire


pour compléter j'ai un autre agent windows et ils ont les mêmes jetons, est ce normal

Cdlt
  Reply
#2
Bonjour

Mieux vaut tard que jamais...

La réponse est là : http://forge.fusioninventory.org/issues/3032

Il faut spécifier --pidfile /var/run/fusioninventory-agent.pid dans la ligne de commande du script /etc/init.d/fusioninventory

Stan
  Reply
#3
Je n'avais pas remarqué le problème à l'installation.
Pour être plus précis le script init a une petite erreur sous Debian (les autres distrib je ne sais pas) même avec le package 2.3.16.

La ligne de commande du start passe le paramètre --pidfile à start-stop-daemon alors qu'il doit être passé à fusioninventory-agent.
L'option avec start-stop-daemon vérifie la présence du pid elle ne le crée pas. Alors que celle de fusioninventory-agent le fait.

En clair :
Code:
start-stop-daemon --start --quiet --exec $DAEMON -- $DAEMON_OPTS --pidfile /var/run/$NAME.pid || true
au lieu de :
Code:
start-stop-daemon --start --quiet --pidfile /var/run/$NAME.pid --exec $DAEMON -- $DAEMON_OPTS || true

A noter que le problème n'apparait pas en Jessie (Debian 8) car systemd intercepte le script init et génère le sien.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)