• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fusioninventory2.3.0/GLPI 0.78.3 /Agent 2.1.7/ Ubuntu 8.04
#1
Discovery task always comes up with this error. "Unable to find agent to run this job"
I am trying to discover switches.

Thank you
  Reply
#2
Your agent is in daemon mode ? and your agent is associated with a computer to have ip ?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#3
Cron, I have now changed it to daemon in /etc/default/fusioninventory-agent and ran the command ./fusioninventory-agent --daemon, is that ok?
OCS and GLPI are on the same server, GLPI default HTTP address for Server so I have set localhost:62354?

The switches IP range have been set in Fusioninventory IP Range Config
These are my plugins

fusioninventory-agent
libfusioninventory-agent-task-netdiscovery-perl
libfusioninventory-agent-task-snmpquery-perl

What I want to do is get the MAC addresses of ports on the switch and associate these with the Computers imported from OCS, is that right?

Thank you
  Reply
#4
You must inventory with "snmpquery" your switch (if it's Cisco or Procuve devices) );
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#5
I was not able to get any query to run. "Unable to find agent to run this job"

I have uninstalled GLPI 0.78 and installed 0.72.1
Now I am able to Discover the IP range of the Switches but not the MAC addresses.

h*tp://forge.fusioninventory.org/projects/fusioninventory-for-glpi/wiki/En_IX_exemple_22x
MANAGING THE DEVICES FOUND.

The part of this tutorial does not produce any results; no MAC address, no Cisco switch information.



I have already spent 3 weeks trying to get this to work, 71/2 hours today ;-(

Thank you ddurieux for your help. (Hopefully this thread may also help others)
  Reply
#6
You will have problem on configuration, if you can come on irc chan (#fusioninventory on freenode servers) and we will guide you better Wink
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#7
Tried IRC, IRC may be blocked on our WAN. What is your channell name #fusioninventory?
  Reply
#8
yes #fusioninventory
You can use web access : http://webchat.freenode.net
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#9
(This is a record of an IRC converstaion with ddurieux. Perhaps it will help someone else)

What version of plugin fusioninventory in glpi you use ?
hi
I have just installed the agent modules from here http://debian.fusioninventory.org/debian/pool/
plugin 2.2.1

can you have glpi078 in a test environment
it works better :p
2 versions of the agent are showing under agent configuration ?

I prefer guide you in version 0.78
It is no problem to install .78, just takes 20 minutes
will I install 78, there is no problem

ok, forplugin fusioinventory, get this archive http://prebuilt.fusioninventory.org/fusi...lpi/devel/
David, is .78.3 ok?
yes Wink

hello David I am getting this message '0.72.2 delete search of state from reservationsError during the database updateUnknown column 'device_type' in 'where clause' while updating the DB

You have this when you do what action ?
I am configuring GLPI from .72 to .78, maybe I should delete old DB or create a new one with different name?
Yes start from crash
Ok

you have computers in your 0.72 version ?

I have installed .78 and the plugin. The plugin is not showing up though. The name of the folder is /glpi/plugins/fusionInventory-for-GLPI-snapshot-20110322-2112 ??
no
in this folder you will have 3 folders
like :
fusioninventory
fusinvsnmp
fusinvinventory
you have this ?
ok will I activate plugins
3 plugins activated
nice

what about the agent?
run your agent with server=http://ipserver/glpi/plugins/fusioninventory/
no agent there, do I run from /usr/bin first to record to glpi?
yes with this line :
fusioninventory-agent --debug --server=http://ipserver/glpi/plugins/fusioninventory/
you will see your agent in glpi http://....plugins/fusioninventory/front/agent.php
ok I have agent
nice
click on it

This is the name I am using so you will understand server=http://glpi/plugins/fusioninventory/
on agent module tab
ok
server=http://glpi/plugins/fusioninventory/ is the URL to communicate with GLPI
yes for your information
ah ok Wink

modules
in agent modules tab, check SNMPQUERY and NETDISCOVERY and update
no others?
keep other like this
We don't use to modify for SNMP Wink
NMPQUERY and NETDISCOVERY checked wake on LAN and INVENTORY not checked
Ok?

in tab threads number, set first to 15 and second to 5
ok
ok, now you will go to menu "ip ranges"
"ip range configuration"
ok done
create your range ip
done
in first tab, click on "Create task easily"
ok
after in agent, select your agent in list and update
there are 3 entries in agent list, auto manage auto mange subnet, and my agent

select your agent for the moment
We try in simple case Wink
ok thanks
ok agent selected

ok go in menu tash management
"task management" *
you will have now a task like "NETDISCOVERY of IP Range (permanent)..."
tasks?
yes tasks
when I go to tasks>action> I only have snmpinventory ;(
in module list ?
I am still in IP range config
no, go in menu "Task management"
OK netdiscovery and snmpquery

you are on menu "Task management" ?
yes
click on your task "NETDISCOVERY of IP Range (permanent)..."
ok
set active to yes and Communication type to PULL
done
click on button : force running
done
run your agent

how?
fusioninventory-agent --debug --server=http://ipserver/glpi/plugins/fusioninventory/
like the first time Wink
running
ok finding the range, takes about 5 to 10 minutes I think

like this, we discover your devices
it's the first point
when finished, we will do inventory of switch discovered
ok, this is the first time I was able to discover ip in .78. fantastic. What is the difference between push and pull and what are the 'threads'?
here we use pull because we run agent by hand, and server prepare task and when agent contact server get informations
in push, agent must be in daemon, and when you force running, glpi send request to agent to start and contact itself the server and get informations
push is run agent from webpage?
yes but you must start agent in daemon
fusioninventory-agent --debug --server=http://ipserver/glpi/plugins/fusioninventory/ -d
I think I have set agent to daemon
this start in daemon
for threads
if you have 500 ip to scan, it will query one ip by one
to make more than 500 seconds
if you set threads number to 10, agent will scan 10 ip at same time, so time is only 50 seconds (about :p )
very good,
what 2 entries for threads?
15 and 5
first is for discovery, you can use many of threads

ok scan is complete, that was fast
if you set 50 threads, agent use about 1 Go of RAM when discover
and 5 if for inventory, and use more ressources Wink
smokinjojo: nice Wink

my ip range is now scanned
ok, go in menu Inventory > networks
you will see your network devices
I see in unknown devices
you don't have in "Inventory > networks" ?
nothing in networks
strange
in unknown devices you have your switch ?
this is the Cisco switch range
***-***-***03.tuam.vsds.valeo this is the name of one of our switches; there are 18 switches discovered
Ok

select all and at the bottom
select update in list
and "type"
and "networking device" and click on "post" button
ok , successful but nothing under inventory>networks
wait :p
check all again
and select "import" in list
and post
the unknown devices?
they will be "moved" to inventory>networks
ok
yes the unknown devices
ok success

so in inventory>networks
check all
and use "load the correct SNMP model"
and post
ok done
in search , you have select box with "items seen"
yes
select in this "fusinv - SNMP models"
and click on search button
done
a new column is present
"FusInv - SNMP models"
No

you have click on "search" button
?
select all>search>fusInv-SNMP models contains
search
yes

you will have a new column with name "fusInv-SNMP model"
I have not set the user in snmp authentication, is this a problem?
in the list
the user ?
there is nothing in FusInv - SNMP models
yes, I have not yet entered the 'user' in snmp authentication

oh
that's why we have problem with fields empty
add your snmp authentication and re force running task

will I enter user info?
yes in SNMP athentication menu
done and 'update'
where do I force running task?

in task management
lots of menu I know
netdiscovery?
yes
and run agent
ok will do now

looks good, has started to find the IP range,...
finished scan, there is only one result in unknown devices?

and in inventory > networks ?
it is the same as before no change, just the unknown devices we have imported

ok, search in field "sysdescr" instead of FusInv - SNMP models
empy field from the search
empty field
strange
any ideas?

Cisco catlyst 3750 and 3550 are examples of the switches we have here
I think SNMP authentication is not good
I think so, where is the problem though,
in authentication, you have set version number and community string ?
I have no idea. We are already using snmp to pull information into MRTG if you know this software. SNMP is working on the switches
I have set it for community v2c I dont think we use v1
yes v2c
and put your community
strange

do you know cisco commands?
If so I will check one of the switches
snmpwalk -v 2c -c community ip sysdescr
from ubuntu command line?or on Cisco
'ip No address associated with hostname'
smokinjojo: ubuntu
this is the result 'ip No address associated with hostname'
and this 'snmpwalk: Unknown host (ip) (Connection timed out)'
change "ip" by ip address of cico switch
:p

i also tried this 'snmpwalk -v 2c -c community *.107.30.3 sysdescr' response was 'Timeout: No Response from *.107.30.3'
ok, so you have a problem

perhaps an ACL on cisco to allow to query only from a server (Mrtg server I think)
maybe I can add fusion, do you know how to add acl
how do I check the acl's
I am on a switch
with telnet
these are the communities on switch *** RO *****t RO **** RO and ***-***-ro RO
I was using ***-***-ro as username, looks like that is the community?
I think
not very sure

if that is the community what is the username, the same?
I don't have use Cisco telnet since 8 months
yes
probably

how do I get the scan to run again, I tried 'force running' on netdiscovery but it did not scan the IP range
run agent *
I did that, did not scan the IP range. What am I missing?
in task page
if you refresh, in the bottom, do you have many buttons "force end" ?
just checked the agent tab I have 2 agents??
In task management I have just 1 'force running'
David, 2 agents, that is not right is it? I am now running a scan of IP range
I see it is picking up Ciso IOS software now, that looks good ;-)
ok I have network devices and SysDescr
nice

check all
and load correct SNMP model in list

thanks for your help David. I have just installed OCSmass import and am importing computers, where do I go now to get MAC addresses off switches and link to imported computers?
I will load correct snmp model as soon as import computers is complete
(in this plugin version, fusioninventory agents or ocs agents can send inventory directly to GLPI) Wink

I will now try to load correct SNMP model for switches?
yes
Wink

what happened, I had a list of cisco switches in Networks and they have now disappeared and I am back to the unknown imported devices;-( Where did they go???

in trash ?
I dont think so
nothing in trash in Networks, that is weird, before I ran OCS import they were there
remember I wrote this line 'ok I have network devices and SysDescr'
Yes I remember
so retry netdiscovery
but it's strange
ok I will do that

you discover, you get correct SNMP model
and after you make SNMPinventory
oh Wink
that did not work. I Purged all the discovered devices, created a same IP range with new name and new netdiscovery.
Oh

so now you have all of your cisco ?
ok, now some of the discovered devices went to networks and some went to unknown devices
humm perhaps because agent don't have in it's database definition some ciscos
probably, can we work on network devices for a few minutes?
Yes

check all and made load correct snmp models
aagh! That returned no new column
for load correct snmp models, you check all and set this at bottom
after to see column, in top you must select "fusinv snmp models" and click on button with name "search"
ok, it is there. Ta

great
ok, you have numbers in this column ?
yes
nice

so next, go in your iprange
fusion plugin IP range ?
in second tab (permanent task - inventory)
yes
yes

click for create task
ok
set your agent too
pull
do I leave discovery tab as 'active'?
yes
go in task management
and task "SNMPQUERY of IP Range (permanent)..."
ok
"force running" and run agent
and when finished, your cisco will have many ports Wink
it is the finish line ^^
.and run agent?
Yes

where do I see the ports?
under Networks
yes on each switch
you have 2 tab, first "connections"
and second (better) "fusinv - SNMP"

I see information but no ports
ah ?
for any of switch ?
there was a lot of the message in agent 'Use of uninitialized value in array element at /usr/share/perl5/FusionInventory/Agent/Task/SNMPQuery.pm line 957.'
no ports on any of the switches
under connections or FusInv snmp
grr
you have a tab fuvinv - XML in the switch
can you send me xml data by mail?
Yes

in tab fusinv xml there is very basic data only name ip mac and serial number

oh
perhaps you have put ACL not for all SNMP
you will have something like this : http://pastebin.com/vAGt2RaE
in the xml
no, no xml
I think I will post you the screen from the agent running, I think you would understand it

I posted the screengrab from the running agent. ddurieux_all advised me to comment out
the line in the agent config file /etc/fusioninventory/agent.cfg

local=/tmp

# Store inventory in a local directory
local=/tmp

I commented out the line and ran the agent again.
The correct port information was downloaded for the the discovered Switches.
  Reply
#10
DD, thanks for your help. Is there any reason why Fusion would not be able to identify Catalyst 2950, 3550, 3750 models?
  Reply
#11
If model / firmware not yet added, see http://forge.fusioninventory.org/project...g_snmpwalk
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#12
Hi is the following error supposed to be there when running SNMP query on the discovered devices?

[debug] sending XML
[error] Deflating problem. Is the string really compressed? Do you use the correct URL to the server. The begin was: <div style="position:fload-left; background-color:red; z-index:10000"><strong>PHP Notice: </strong>Undefined variable: a_mapping in /var/www/glpi/plugins/fusinvsnmp/inc/configlogfield.class.php at lin
  Reply
#13
I think you must get last version released today (http://forge.fusioninventory.org/attachm...3.0.tar.gz) and reinstall the plugins, I have made very lot's of fixes since version you use Wink
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#14
Thats great DD, thanks.
  Reply
#15
DD I had a problem with the new plugin; I think it was SNMP authentication. Has anything changed for Public community v2c?
  Reply
#16
You can change (not recommanded) or can add your own SNMP authentication
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#17
I rolled back to the previous version of the plugins and it worked perfectly, probably something I am missing. I will try the new plugins again when I get the chance.
Any reason why Fusion is only picking up some of the PC's plugged into the switch?
  Reply
#18
I think the reason Fusion is not picking up any PC's attached to the switch is because the switch is a temporary switch cabled with a crossover cable.
  Reply
#19
humm not sure it's a problem
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#20
Hello. Just got our new Cisco phones in. Is there support in the plugin for POE phones DD?
  Reply
#21
I spent weeks trying to get the SNMPquery scanning from the GLPI webpage. That is, using 'push' instead of pull.

(If someone can explain to me how to upload an image to this Forum I will upload a screenshot of the automatic scans.)
It has been running regularly now for 3 weeks.

This my agent.cfg file.


ocsdeploy=0
maxsize=0
delaytime=3600
timeout=180
debug=1
tag=joe
snmpquery=0
server=http://myservername/glpi/plugins/fusioninventory/front/plugin_fusioninventory.communication.php
stdout=0
logfile=/var/log/fusioninventory.log
port=62354
socket=0
homedirs=0
envvar=0
printer=0
local=/tmp
dir=/usr/share/perl5/auto/share/dist/FusionInventory-Agent
color=0
html=0
check=0
netdiscovery=0
daemon=0
devlib=0
logger=Stderr
inventory=0
info=1
wakeonlan=0
lazy=0
force=0
software=0
fork=0
wait=



I am using Fusioninventory plugin 2.4.0 and Agent 2.1.9 with GLPI 0.80

You need to run a command like this to get automatic scanning setup (search on the Forum for this)
This is the command I used in my setup.
/usr/bin/php5 /var/www/glpi/front/cron.php&>/dev/null

Then this command should give you some results when you run it.

tail -f /var/www/glpi/files/_log/cron.log

The new agent uses a different format for the .cfg file but as far as I know if you have your old .cfg file you can use that instead
One thing to look at if you get the error message, 'unable to find agent to run this task' (which I did for months!!) you may want to enter the domain and username/password in the .cfg file.

I am just trying to help anyone else who may have problems getting fusion to work like we all hope it can Wink but it is just so difficult to get any help on fusioninventory problems.

Dont forget to also use
#fusioninventory at http://webchat.freenode.net to try and get more information from ddurieux and Goneri and the other developers.

Just installed a new VOIP system for the phones. SNMPquery not pulling any information for the phones yet but hopefully that will also work. If I get any more information I will keep this thread updated. If anyone else has any pearls of wisdom regarding running Fusioninventory please help others who are struggling looking for help.
  Reply
#22
For the phones, it will be available in 2.2 version of the agent. (not yet ready)
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#23
Thanks DD, looking forward to Ver 2.2 I can see all the phones on the switches so it will be great to have some tracking on them with Fusioninventory.
Is it possible to insert Images here in the Forum?
  Reply
#24
For image, use for example http://www.hostingpics.org/ and put link here
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#25
Disappearing computers; fusioninventory plugin 2.4.0 and GLPI 0.82. Installed and activated the plugin and all the information on Computers disappeared.
Eventually discovered that the problem was Users imported from Active Directory. Seems like there is come conflict between either GLPI+FusInv+AD or between FusInv+AD. It does not interfere with operation for us as we only use GLPI for Asset management not ticketing. Might be of use to somebody.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)