• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fusioninventory2.3.0/GLPI 0.78.3 /Agent 2.1.7/ Ubuntu 8.04
#51
I will give you the quick link and then delete them if you like

http://hpics.li/2b10756
http://hpics.li/4a27b5a
http://hpics.li/423e92d
  Reply
#52
But you cannot use FI as a standalone can you?
  Reply
#53
It's better with great pictures. It seems a bug in SQL query, set your GLPI settings in DEBUG mode to see error.
What field you add to have blank page ?

Standalone ?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#54
It does not seem to matter which fusinv tab I try to add, switch or hardware port etc. the result is the same; computer information disappears.
All I can do then is deactivate fusioninventory plugin and the computers reappear
  Reply
#55
This is the error I found

'Error: Mixing of GROUP columns (MIN(),MAX(),COUNT(),...) with no GROUP columns is illegal if there is no GROUP BY clause'
  Reply
#56
Does it matter which version of mysql we are using?
  Reply
#57
Code:
SELECT 'glpi' AS currentuser, `glpi_computers`.`name` AS ITEM_0, `glpi_computers`.`id` AS ITEM_0_2, `glpi_states`.`name` AS ITEM_1, `glpi_manufacturers`.`name` AS ITEM_2, `glpi_computers`.`serial` AS ITEM_3, `glpi_computertypes`.`name` AS ITEM_4, `glpi_computermodels`.`name` AS ITEM_5, `glpi_operatingsystems`.`name` AS ITEM_6, `glpi_locations`.`completename` AS ITEM_7, `glpi_computers`.`date_mod` AS ITEM_8, `glpi_computers`.`contact` AS ITEM_9, GROUP_CONCAT(glpi_networkequipments.name SEPARATOR '$$$$') AS ITEM_10, `glpi_computers`.`id` AS id
FROM `glpi_computers`
LEFT JOIN `glpi_states` ON (`glpi_computers`.`states_id` = `glpi_states`.`id` )
LEFT JOIN `glpi_manufacturers` ON (`glpi_computers`.`manufacturers_id` = `glpi_manufacturers`.`id` )
LEFT JOIN `glpi_computertypes` ON (`glpi_computers`.`computertypes_id` = `glpi_computertypes`.`id` )
LEFT JOIN `glpi_computermodels` ON (`glpi_computers`.`computermodels_id` = `glpi_computermodels`.`id` )
LEFT JOIN `glpi_operatingsystems` ON (`glpi_computers`.`operatingsystems_id` = `glpi_operatingsystems`.`id` )
LEFT JOIN `glpi_locations` ON (`glpi_computers`.`locations_id` = `glpi_locations`.`id` )
LEFT JOIN glpi_networkports AS FUSIONINVENTORY_10 ON (FUSIONINVENTORY_10.items_id = glpi_computers.id AND FUSIONINVENTORY_10.itemtype='Computer')
LEFT JOIN glpi_networkports_networkports AS FUSIONINVENTORY_11 ON FUSIONINVENTORY_10.id = FUSIONINVENTORY_11.networkports_id_1 OR FUSIONINVENTORY_10.id = FUSIONINVENTORY_11.networkports_id_2
LEFT JOIN glpi_networkports AS FUSIONINVENTORY_12 ON FUSIONINVENTORY_12.id = CASE WHEN FUSIONINVENTORY_11.networkports_id_1 = FUSIONINVENTORY_10.id THEN FUSIONINVENTORY_11.networkports_id_2 ELSE FUSIONINVENTORY_11.networkports_id_1 END
LEFT JOIN glpi_networkequipments ON FUSIONINVENTORY_12.items_id=glpi_networkequipments.id
WHERE `glpi_computers`.`is_deleted` = '0' AND `glpi_computers`.`is_template` = '0'
ORDER BY ITEM_0 ASC LIMIT 0, 20
  Reply
#58
Can you try version 0.80+1.1 ? (not released but release planned for next monday or tuesday) : http://glpi.siprossii.com/temp/fusion0801.1.tar.gz
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#59
David, I tried that, it looks impressive. I got the mail late so I just quickly installed the plugin and ran it; same problem Computer info disappears.
I can reinstall GLPI and retry the plugin again if you think that would help?
When I turn on debug the error message is the same as above

Code:
SELECT 'glpi' AS currentuser, `glpi_computers`.`name` AS ITEM_0, `glpi_computers`.`id` AS ITEM_0_2, `glpi_states`.`name` AS ITEM_1, `glpi_manufacturers`.`name` AS ITEM_2, `glpi_computers`.`serial` AS ITEM_3, `glpi_computertypes`.`name` AS ITEM_4, `glpi_computermodels`.`name` AS ITEM_5, `glpi_operatingsystems`.`name` AS ITEM_6, `glpi_locations`.`completename` AS ITEM_7, `glpi_computers`.`date_mod` AS ITEM_8, `glpi_computers`.`contact` AS ITEM_9, GROUP_CONCAT(glpi_networkequipments.name SEPARATOR '$$$$') AS ITEM_10, `glpi_computers`.`id` AS id
etc. etc.
WHERE `glpi_computers`.`is_deleted` = '0' AND `glpi_computers`.`is_template` = '0'
ORDER BY ITEM_0 ASC LIMIT 0, 20
  Reply
#60
I created a new DB and used the fi agent running on the local PC to report to GLPI (disabled OCS import). The result was 1 Computer in GLPI.
When I tried to enable the fusinv switch tab in computers the same error occurs as reported above. The problem occurs only when the FusionInventory SNMP plugin is enabled.
Any more ideas?
  Reply
#61
With plugin FusionInventory version 0.80+1.1 ?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#62
Plugin 0.80+1.1 GLPI 0.80.1
This seems to be the problem query when I try to enable the fusinv-switch tab in Inventory Computers.
Code:
LEFT JOIN glpi_networkports AS FUSIONINVENTORY_10 ON (FUSIONINVENTORY_10.items_id = glpi_computers.id AND FUSIONINVENTORY_10.itemtype='Computer')
LEFT JOIN glpi_networkports_networkports AS FUSIONINVENTORY_11 ON FUSIONINVENTORY_10.id = FUSIONINVENTORY_11.networkports_id_1 OR FUSIONINVENTORY_10.id = FUSIONINVENTORY_11.networkports_id_2
LEFT JOIN glpi_networkports AS FUSIONINVENTORY_12 ON FUSIONINVENTORY_12.id = CASE WHEN FUSIONINVENTORY_11.networkports_id_1 = FUSIONINVENTORY_10.id THEN FUSIONINVENTORY_11.networkports_id_2 ELSE FUSIONINVENTORY_11.networkports_id_1 END
LEFT JOIN glpi_networkequipments ON FUSIONINVENTORY_12.items_id=glpi_networkequipments.id
  Reply
#63
Any update on this DD?
  Reply
#64
What I really need to know is if anyone else has this problem; if not then there is something wrong with my configuration and I might be able to track it down with a bit of help from yourself?

Plugin 0.80+1.1
GLPI 0.80.1
OCSimport 1.5.0
MySql 4.1.22-log
FusionInventory Agent (2.1.9)
Ubuntu 10.04.2 LTS \n \l
  Reply
#65
For anyone who is interested or who has been following this thread; the reason I was getting a MYSql error in Inventory>Computers after adding a Fusinv Inventory tab was MYSql version was too old. I am now using MYSql version 5+ and the problem has disappeared; hallelujah.
  Reply
#66
very nice Wink
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#67
Any news on the new agent; the agent that promises to discover and inventory Cisco phones?
  Reply
#68
Agent 2.2.x and plugin fusion 0.80+1.2 , inventory is very light :p
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#69
Where can I get agent 2.2.x?
  Reply
#70
For example here : http://prebuilt.fusioninventory.org/stable/ or in the CPAN (perl)
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#71
Hi DD, hope you are well

I just installed 0.83+2.0 and fusioninventory-agent (2.2.3) with GLPI 0.83.31.
There is no create task appearing under the IP configuration tab; any ideas?
  Reply
#72
Yes it was removed, you can use wizard or task management now
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#73
Any ideas what this is when I try to install the plugin?
'Change of the database layout - glpi_plugin_fusioninventory_agentmodules ( 0 Sec(s))
0.80+1.4 multiple alter in glpi_plugin_fusioninventory_agentmodules Error during the database updateTable 'glpi.glpi_plugin_fusioninventory_agentmodules' doesn't exist'

fusioninventory-for-glpi-metapackage_0.83+2.0-BETA1 / GLPI 83.31 / glpi-massocsimport-1.6.1
  Reply
#74
Reinstalled everything. OCS and fusioninventory seemed to be working ok the it disappeared
'Change of the database layout - glpi_plugin_fusioninventory_agentmodules ( 3 Sec(s))
0.80+1.4 multiple alter in glpi_plugin_fusioninventory_agentmodules Error during the database updateDuplicate column name 'id'
  Reply
#75
Apologies for another post ;(

problems with the agent (2.2.3)

[info] Inventory saved in /tmp/vsds-tua-*****-2012-09-10-21-24-00.ocs
[debug] running task WakeOnLan
[info] task WakeOnLan is not enabled
[debug] [http client] Using Compress::Zlib for compression
[debug] running task Inventory
[debug] No inventory requested in the prolog response
[info] task Inventory is not enabled
[debug] running task WakeOnLan
[debug] No WakeOnLan requested in the prolog
[info] task WakeOnLan is not enabled
root@vsds-tua-******:/usr/bin#
  Reply


Forum Jump:


Users browsing this thread: 3 Guest(s)