• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
running task ESX // [http client] communication error: 404 Not Found
#1
Bonjour,

Je suis en train d'activer l'inventaire ESX sur mon infra.
Cependant, lorsque je démarre l'agent de manière forcée sur le matériel dédié à l'inventaire distant des ESX, voici ce que j'ai :

Code:
[Thu Aug 13 14:05:44 2015][info] FusionInventory Agent starting
[Thu Aug 13 14:06:07 2015][debug] FusionInventory Agent (2.3.16)
[Thu Aug 13 14:06:07 2015][debug] Configuration directory: /etc/fusioninventory
[Thu Aug 13 14:06:07 2015][debug] Data directory: /usr/share/fusioninventory
[Thu Aug 13 14:06:07 2015][debug] Storage directory: /var/lib/fusioninventory-agent
[Thu Aug 13 14:06:07 2015][debug] Lib directory: /usr/share/fusioninventory/lib
[Thu Aug 13 14:06:07 2015][debug] [target server0] Next server contact planned for Fri Aug 14 01:59:42 2015
[Thu Aug 13 14:06:07 2015][debug] Available tasks:
[Thu Aug 13 14:06:07 2015][debug] - ESX: 2.2.1
[Thu Aug 13 14:06:07 2015][debug] - Inventory: 1.0
[Thu Aug 13 14:06:07 2015][debug] - NetDiscovery: 2.2.0
[Thu Aug 13 14:06:07 2015][debug] - NetInventory: 2.2.0
[Thu Aug 13 14:06:07 2015][debug] - WakeOnLan: 2.0
[Thu Aug 13 14:06:07 2015][debug] - Deploy: 2.0.4
[Thu Aug 13 14:06:07 2015][debug] [http client] Using Compress::Zlib for compression
[Thu Aug 13 14:06:07 2015][info] sending prolog request to server server0
[Thu Aug 13 14:06:07 2015][info] running task ESX

----> [Thu Aug 13 14:06:07 2015][error] [http client] communication error: 404 Not Found <----

[Thu Aug 13 14:06:07 2015][debug] Inventory task execution not requested, but execution forced
[Thu Aug 13 14:06:07 2015][info] running task Inventory
[Thu Aug 13 14:06:07 2015][debug] Running FusionInventory::Agent::Task::Inventory::AccessLog
[Thu Aug 13 14:06:07 2015][debug] Running FusionInventory::Agent::Task::Inventory::Generic
[Thu Aug 13 14:06:07 2015][debug] Running FusionInventory::Agent::Task::Inventory::Generic::Arch
[Thu Aug 13 14:06:07 2015][debug] Running FusionInventory::Agent::Task::Inventory::Generic::Dmidecode
[Thu Aug 13 14:06:07 2015][debug] Running FusionInventory::Agent::Task::Inventory::Generic::Dmidecode::Battery
[Thu Aug 13 14:06:07 2015][debug] Running FusionInventory::Agent::Task::Inventory::Generic::Dmidecode::Bios
[Thu Aug 13 14:06:07 2015][debug] Running FusionInventory::Agent::Task::Inventory::Generic::Dmidecode::Memory
[Thu Aug 13 14:06:07 2015][debug] Running FusionInventory::Agent::Task::Inventory::Generic::Dmidecode::Ports
etc.

Ce message vous dit-il qqch ?
Merci pour votre retour.
Ph1 // Admin Systèmes & Réseaux
OS : Ubuntu 14.04
Authentification Kerberos // SSO Multi domaines AD
GLPI 9.2.3 // Fusion Inventory 9.2+2.0 (agent 2.4)
  Reply
#2
Dans l'entité racine dans GLPI, onglet fusioninventory, tu as mis quoi comme url d'accès au service?
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#3
Bonjour ddurieux,

J'ai bien mis http://inventaire.domain.local/glpi/plug...inventory/ et les sous-entités héritent de cette configuration.
Info complémentaire :
La machine qui effectue l'inventaire ESX est également le serveur GLPI. Peut être devrais-je indiquer une url "locale" plutôt que le fqdn ?
Par ailleurs, l'inventaire ordi fonctionne bien.

Merci pour ton retour.

PS :
J'ai ça aussi dans ma conf apache :
Code:
###################################################
# Config SSO Informatique Kerberos DOMAINE1.LOCAL #
###################################################

<Location /informatique>
           AuthName "CLIENT GLPI Authentification"
           AuthType Kerberos
           KrbAuthRealms DOMAINE1.LOCAL
           KrbServiceName HTTP
           Krb5Keytab  /etc/apache2/domain1_HTTP.keytab
           KrbMethodNegotiate on
           KrbMethodK5Passwd on
           KrbAuthoritative on
           require valid-user
  #         ErrorDocument 401 "<html><meta http-equiv=\"refresh\" content=\"0;url=/glpi/index.php?noAUTO=1/\"></html>"
    </Location>
(autant de fois qu'il y a de domaines non approuvés)

et ça pour bypasser l'authent' lors de la remontée d'inventaire :
Code:
###################################
# Config Synchro Fusion Inventory #
###################################
<Location "/glpi/plugins/fusioninventory/">
  Satisfy Any
  Options FollowSymLinks
</Location>
Ph1 // Admin Systèmes & Réseaux
OS : Ubuntu 14.04
Authentification Kerberos // SSO Multi domaines AD
GLPI 9.2.3 // Fusion Inventory 9.2+2.0 (agent 2.4)
  Reply
#4
C'est pas bon, l'url doit être: http://inventaire.domain.local/glpi/
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#5
Bonjour ddurieux,

A présent, je peux en effet "piloter l'agent" depuis le plugin.
En revanche, j'ai toujours "500 Can't connect to xx.xx.xx.xx:443 (certificate verify failed)" dans la tâche qui passe en erreur du coup.

Pour info, je suis en ESXi 6.
Merci pour ton aide !
Ph1 // Admin Systèmes & Réseaux
OS : Ubuntu 14.04
Authentification Kerberos // SSO Multi domaines AD
GLPI 9.2.3 // Fusion Inventory 9.2+2.0 (agent 2.4)
  Reply
#6
autant que, de manière manuelle, j'ai pu avoir l'inventaire de hosts esxi 5.1, en utilisant de façon manuelle le fusioninventory-esx.bat et le fusioninventory-injector.bat, je n'ai pas pu avoir l'inventaire d'un host sous esxi 6.0, il semble que certaines fonctions n'existent plus sur cette derniere version.
Windows 2008 R2, wamp server 2.2, GLPI 85.4, FusionInventory for GLPI 85+1.2, FusionInventory-Agent 2.3.16
  Reply
#7
Merci pour ton retour Izarias !
ddurieux, as tu eu des retours d'xp là-dessus ?
Ph1 // Admin Systèmes & Réseaux
OS : Ubuntu 14.04
Authentification Kerberos // SSO Multi domaines AD
GLPI 9.2.3 // Fusion Inventory 9.2+2.0 (agent 2.4)
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)