• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Creation de package sur Mac
#1
Bonjour,

j'essaie de construire un package de l'agent sur mac en suivant la procédure de DarkOmen78 mais sans succès:
https://github.com/Darkomen78/Fusioninventory/

Lorsque j'éxécute le script :

./Build_Fusioninventory_OSX_flavor.sh 2.3.9

J'obtiens cette erreur :

./Build_Fusioninventory_OSX_flavor.sh: line 4: syntax error near unexpected token `newline'
./Build_Fusioninventory_OSX_flavor.sh: line 4: `<!DOCTYPE html>'

Quelqu'un pourrait-il m'aider svp ?

Merci
  Reply
#2
Bonjour,

le problème a été résolu par la mise à disposition du nouveau script sur

Fusion n’a pas l’air de fonctionner en mode daemon, je peux lancer un inventaire par :
./usr/local/fusioninventory/bin/fusioninventory-agent

Mais l’inventaire ne se lance automatiquement autrement.

De plus, j’ai une erreur lorsque j’accède à :
http://127.0.0.1:62354

Dans les logs :
tail /var/log/fusioninventory.daemon.log
[info] task NetInventory execution not requested
Use of uninitialized value $handle in <HANDLE> at /usr/local/fusioninventory/share/lib/FusionInventory/Agent/Task/Inventory/MacOS/License.pm line 45.
readline() on unopened filehandle at /usr/local/fusioninventory/share/lib/FusionInventory/Agent/Task/Inventory/MacOS/License.pm line 45.
Use of uninitialized value $handle in <HANDLE> at /usr/local/fusioninventory/share/lib/FusionInventory/Agent/Task/Inventory/MacOS/License.pm line 45.
readline() on unopened filehandle at /usr/local/fusioninventory/share/lib/FusionInventory/Agent/Task/Inventory/MacOS/License.pm line 45.
[info] task WakeOnLan execution not requested
[error] [http server] Template access failed: Couldn't open file /usr/local/fusioninventory/share/html/index.tpl: No such file or directory
[error] [http server] Template access failed: Couldn't open file /usr/local/fusioninventory/share/html/index.tpl: No such file or directory
Execution failure:.
Can't call method "fill_in" on an undefined value at /usr/local/fusioninventory/share/lib/FusionInventory/Agent/HTTP/Server.pm line 240.


Quelqu'un aurait rencontré le même problème ?

Merci
  Reply
#3
Oui j'ai eu exactement le même problème.
Le mode deamon ne fonctionne pas.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)