• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Détection WMI Antivirus Windows 7
#1
Bonjour,

La détection de l'antivirus présent sur la machine ne fonctionne actuellement pas sous Windows 7.

Malgrès le fait d'utiliser SecurityCenter2 cela ne remonte rien chez moi Sad

Les champs qui sont présents chez moi sont :
- displayName
- instanceGuid
- pathToSignedProductExe
- productState

Testé avec un VBS chez moi, antivirus Symantec EndPoint Protection.

Le fait de remonter par exemple le champ versionNumber qui n'existe pas chez moi peut il planter cette récupération ?
#2
Bonjour, Vous utilisez l'agent 2.1.8-1 ? Normalement le problème est corrigé.
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
#3
Oui j'utilise l'agent en version 2.1.8-1, je vais retester cette partie.
#4
Pouvez-vous m'envoyer le fichier XML généré par l'agent ici : goneri@rulezlan.org
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
#5
Bonjour, après de nouveaux tests c'est en effet ok Wink
Les info remontent comme il faut sous Windows 7.
#6
Bonjour,

J'ai le même problème sous Windows 7 32bits avec la version de développement 2.1.8+dev-2.1.x-20110523-0913.
Pourtant dans le centre de maintenance Symantec Endpoint Protection indique bien qu'il est activé et à jour.

Cordialement

Les infos dans le XML :
<ANTIVIRUS>
<GUID>{88C95A36-8C3B-2F2C-1B8B-30FCCFDC4855}</GUID>
<NAME>Symantec Endpoint Protection</NAME>
</ANTIVIRUS>
#7
Le centre de sécurité est-il actif ? Que retournent ces commandes ?

Code:
wmic /namespace:\\root\SecurityCenter PATH AntiVirusProduct GET /valie
wmic /namespace:\\root\SecurityCenter2 PATH AntiVirusProduct GET /value
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
#8
SecurityCenter :
retourne rien, également avec un logiciel d'exploration des objets WMI on voit bien que rien n'est renseigné dans SecurityCenter

SecurityCenter2 :
displayName=Symantec Endpoint Protection
instanceGuid={88C95A36-8C3B-2F2C-1B8B-30FCCFDC4855}
pathToSignedProductExe=C:\Program Files\Symantec\Symantec Endpoint Protection\WS
CSavNotifier.exe
pathToSignedReportingExe=C:\Program Files\Symantec\Symantec Endpoint Protection\
Rtvscan.exe
productState=462848

Le service centre de sécurité est bien actif.
#9
Merci, j'ai corrigé le bug, pouvez-vous vérifier qu'il est bien corrigé pour vous :
http://prebuilt.fusioninventory.org/deve...dows-i386/
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/
#10
Apparemment ça fonctionne.

Merci beaucoup !
#11
super, merci pour le retour Smile
Please contact Fusioninventory Partners companies if you look for a FusionInventory on site expert.
http://www.fusioninventory.org/partners/


Forum Jump:


Users browsing this thread: 1 Guest(s)