• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Netdiscovery sur switch Cisco SF300
#1
Bonjour,

Je rencontre un petit soucis lorsque je tente un Netdiscovery sur nos switchs Cisco SF300. En isolé, FI trouve quelque chose, mais pas lors de l'exécution d'un job par l'agent... Je rencontre uniquement le problème sur des switchs Cisco SF, nos switchs HP sont bien détectés par les jobs de découverte.

En isolé :

Code:
fusioninventory-netdiscovery --first 192.168.15.253 --last 192.168.15.253

J'ai bien un résultat :

Code:
<?xml version="1.0" encoding="UTF-8" ?>
<REQUEST>
  <CONTENT>
    <DEVICE>
      <AUTHSNMP>1</AUTHSNMP>
      <DESCRIPTION>SF300-24PP 24-Port 10/100 PoE+ Managed Switch</DESCRIPTION>
      <FIRMWARE>1.4.0.88</FIRMWARE>
      <IP>192.168.15.253</IP>
      <IPS>
        <IP>127.0.0.1</IP>
        <IP>192.168.15.253</IP>
      </IPS>
      <LOCATION>quelque part</LOCATION>
      <MAC>0c:f5:a4:bd:8c:6b</MAC>
      <MANUFACTURER>Cisco</MANUFACTURER>
      <SERIAL>DNI185003YY</SERIAL>
      <SNMPHOSTNAME>SITE-DIST1</SNMPHOSTNAME>
      <TYPE>NETWORKING</TYPE>
      <UPTIME>62 days, 03:47:31.00</UPTIME>
      <VENDOR>Cisco</VENDOR>
    </DEVICE>
    <MODULEVERSION>2.2.1</MODULEVERSION>
    <PROCESSNUMBER>1</PROCESSNUMBER>
  </CONTENT>
  <DEVICEID>foo</DEVICEID>
  <QUERY>NETDISCOVERY</QUERY>
</REQUEST>

Par contre, lors de l'exécution du job par l'agent, celui-ci ne détecte rien :

Code:
[Tue Sep 27 14:27:57 2016][debug] [thread 2] scanning 192.168.15.253:
[Tue Sep 27 14:28:00 2016][debug] [thread 2] - scanning 192.168.15.253 with nmap: no result
[Tue Sep 27 14:28:00 2016][debug] [thread 2] - scanning 192.168.15.253 with netbios: no result
[Tue Sep 27 14:28:00 2016][debug] [thread 2] termination
[Tue Sep 27 14:28:00 2016][debug2] [http client] sending message:
<?xml version="1.0" encoding="UTF-8" ?>
<REQUEST>
  <CONTENT>
    <AGENT>
      <END>1</END>
    </AGENT>
    <MODULEVERSION>2.2.1</MODULEVERSION>
    <PROCESSNUMBER>894</PROCESSNUMBER>
  </CONTENT>
  <DEVICEID>luna-2016-09-27-12-27-04</DEVICEID>
  <QUERY>NETDISCOVERY</QUERY>
</REQUEST>
Production : GLPI 0.90.4 - FusionInventory 0.90+1.3 - FusionInventory Agent 2.3.18
  Reply
#2
Dans la plage IP dans le plugin fusion, t'as bien mis la bonne communauté SNMP (t'as un onglet pour ça)
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#3
Dans la plage IP dans le plugin fusion, t'as bien mis la bonne communauté SNMP (t'as un onglet pour ça)
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply
#4
Bon d'accord... J'avais pas ! Rolleyes

Je ne me rappel jamais de l'onglet SNMP pour la partie découverte pourtant quand tu le dit il est visible...

Merci pour le mémo !
Production : GLPI 0.90.4 - FusionInventory 0.90+1.3 - FusionInventory Agent 2.3.18
  Reply
#5
Wink
c'est sur que avant ça ne fonctionnait pas comme ça, donc c'est normal que tu ne t'en rappelle jamais, juste une question d'habitude
Co-leader, official developper
DCS official PARTNER: dcs.glpi@dcsit-group.com
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)